aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
committerantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
commita271c81a691520343b54826252aba0c2600e31ab (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /science
parent19ea8e358e68f9d94cca6a73917529e296948d19 (diff)
downloadfreebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.gz
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.zst
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.zip
Convert to USES=jpeg
Diffstat (limited to 'science')
-rw-r--r--science/afni/Makefile5
-rw-r--r--science/hdf-java/Makefile5
-rw-r--r--science/hdf/Makefile5
-rw-r--r--science/paraview/Makefile3
4 files changed, 7 insertions, 11 deletions
diff --git a/science/afni/Makefile b/science/afni/Makefile
index 8816b4e26f5a..a4cbb5f663af 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -29,8 +29,7 @@ LIB_DEPENDS= libXm.so:${PORTSDIR}/x11-toolkits/open-motif \
libR.so:${PORTSDIR}/math/R \
libgsl.so:${PORTSDIR}/math/gsl \
libnetcdff.so:${PORTSDIR}/science/netcdf-fortran
-RUN_DEPENDS= cjpeg:${PORTSDIR}/graphics/jpeg \
- mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
+RUN_DEPENDS= mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
whirlgif:${PORTSDIR}/graphics/whirlgif \
ppmtogif:${PORTSDIR}/graphics/netpbm \
endian:${PORTSDIR}/sysutils/endian \
@@ -40,7 +39,7 @@ CONFLICTS= im-[0-9]* \
nifticlib-[0-9]* \
open-usp-tukubai-[0-9]*
-USES= gettext iconv gmake motif perl5 shebangfix
+USES= gettext iconv jpeg:run gmake motif perl5 shebangfix
SHEBANG_FILES= suma_change_spec 3dPAR2AFNI.pl
# Some prereqs use gcc anyway
diff --git a/science/hdf-java/Makefile b/science/hdf-java/Makefile
index f28883188606..9b8677cf5934 100644
--- a/science/hdf-java/Makefile
+++ b/science/hdf-java/Makefile
@@ -13,15 +13,14 @@ COMMENT= Java interface to HDF5
BROKEN= Fails to configure, HDF5 library needs SZIP, SZIP not defined
-LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5 \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
USE_JAVA= yes
JAVA_VERSION= 1.6 1.7
JAVA_BUILD= yes
JAVA_RUN= yes
-USES= dos2unix gmake
+USES= dos2unix gmake jpeg
DOS2UNIX_REGEX= .*/examples/.*Makefile.in
GNU_CONFIGURE= yes
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 209e7fad6595..8a00ca8f2475 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -11,8 +11,7 @@ MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/HDF${PORTVERSION}/src/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Hierarchical Data Format library (from NCSA)
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libsz.so:${PORTSDIR}/science/szip
+LIB_DEPENDS= libsz.so:${PORTSDIR}/science/szip
CONFLICTS_INSTALL= netcdf-4.[0-9]*
@@ -22,7 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --with-jpeg=${LOCALBASE} --with-szlib=${LOCALBASE}
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-USES= fortran libtool tar:bzip2
+USES= fortran jpeg libtool tar:bzip2
PORTDATA= *
PORTEXAMPLES= *
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 353d020b9187..2ed717afe55c 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -19,7 +19,6 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:${PORTSDIR}/math/py-matplotlib
LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5 \
libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libtiff.so:${PORTSDIR}/graphics/tiff \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libexpat.so:${PORTSDIR}/textproc/expat2 \
@@ -43,7 +42,7 @@ USE_GL= yes
USE_XORG= x11 xt xext ice xdmcp xau xcb xfixes xdamage xxf86vm xrender sm
USE_LDCONFIG= yes
USE_GSTREAMER= yes
-USES= alias desktop-file-utils cmake:outsource execinfo gmake python shebangfix
+USES= alias desktop-file-utils cmake:outsource execinfo gmake jpeg python shebangfix
INSTALLS_ICONS= yes
CMAKE_ARGS+= -DBUILD_SHARED_LIBS="ON" \