aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-08-04 01:55:15 +0800
committerthierry <thierry@FreeBSD.org>2015-08-04 01:55:15 +0800
commitb6ee4f27f600740fb3c186489621b8b935020d72 (patch)
tree3dc5954a4b58e0a66b39515842f7dc3ab4825b5d /science
parent6737d3f8fbe59076107f16cd49c53ed48b9feaae (diff)
downloadfreebsd-ports-gnome-b6ee4f27f600740fb3c186489621b8b935020d72.tar.gz
freebsd-ports-gnome-b6ee4f27f600740fb3c186489621b8b935020d72.tar.zst
freebsd-ports-gnome-b6ee4f27f600740fb3c186489621b8b935020d72.zip
Fix build. Options helpers cannot be used here.
Reported by: amdmi3
Diffstat (limited to 'science')
-rw-r--r--science/meep/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/science/meep/Makefile b/science/meep/Makefile
index dfca3ed9d4ac..e419b2f0ef2a 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -30,15 +30,6 @@ OPTIONS_RADIO_MPI= OPENMPI MPICH2
OPTIONS_DEFAULT= ${MPI_DEFAULT}
OPENMPI_DESC= MPI support (with OpenMPI)
-OPENMPI_BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpiCC:${PORTSDIR}/net/openmpi
-OPENMPI_RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
-OPENMPI_CONFIGURE_ENV= MPICXX=${LOCALBASE}/mpi/openmpi/bin/mpiCC
-OPENMPI_CFLAGS= -I${LOCALBASE}/mpi/openmpi/include
-
-MPICH2_LIB_DEPENDS= libmpich.so.8:${PORTSDIR}/net/mpich2
-MPICH2_CONFIGURE_ENV= MPICXX=${LOCALBASE}/bin/mpicc
-MPICH2_CFLAGS= -I${LOCALBASE}/include
-
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD
@@ -57,4 +48,17 @@ CONFIGURE_ARGS+= --without-mpi
PLIST_SUB+= MPI="@comment " NOMPI=""
.endif
+.if ${PORT_OPTIONS:MMPICH2}
+LIB_DEPENDS+= libmpich.so.8:${PORTSDIR}/net/mpich2
+CONFIGURE_ENV+= MPICXX=${LOCALBASE}/bin/mpicc
+CFLAGS+= -I${LOCALBASE}/include
+.endif
+
+.if ${PORT_OPTIONS:MOPENMPI}
+BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpiCC:${PORTSDIR}/net/openmpi
+RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+CONFIGURE_ENV+= MPICXX=${LOCALBASE}/mpi/openmpi/bin/mpiCC
+CFLAGS+= -I${LOCALBASE}/mpi/openmpi/include
+.endif
+
.include <bsd.port.post.mk>