aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-17 12:52:15 +0800
committermaho <maho@FreeBSD.org>2007-01-17 12:52:15 +0800
commita3a4186c59033797f6e2e85e6561d0beea65d997 (patch)
tree6d08108c49229ab0713467f6c982df233ba47b23 /science
parent44c2d01c55f48a841ae0815eb5324ca851fa06d1 (diff)
downloadfreebsd-ports-gnome-a3a4186c59033797f6e2e85e6561d0beea65d997.tar.gz
freebsd-ports-gnome-a3a4186c59033797f6e2e85e6561d0beea65d997.tar.zst
freebsd-ports-gnome-a3a4186c59033797f6e2e85e6561d0beea65d997.zip
* Migrate to gfortran.
* Bump port revision. * Use gfortran compiled lapack. Submitted by: kris via pointyhat.
Diffstat (limited to 'science')
-rw-r--r--science/getdp/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index 69849861b0c6..9bcf06a2ec37 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= getdp
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -17,7 +17,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A rather general finite element solver using mixed finite elements
LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
- lapack.3:${PORTSDIR}/math/lapack
+ lapack.4:${PORTSDIR}/math/lapack
+
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}