aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-01-31 06:19:24 +0800
committerthierry <thierry@FreeBSD.org>2006-01-31 06:19:24 +0800
commitb636d32cdaa0e8ac40c89807606ff0690cb5c1f9 (patch)
tree7d66259ec1930ef1a0aecefa3c4679a728d35955 /science
parent334782d4421c52a0e4f845a9a03fdbb156223817 (diff)
downloadfreebsd-ports-gnome-b636d32cdaa0e8ac40c89807606ff0690cb5c1f9.tar.gz
freebsd-ports-gnome-b636d32cdaa0e8ac40c89807606ff0690cb5c1f9.tar.zst
freebsd-ports-gnome-b636d32cdaa0e8ac40c89807606ff0690cb5c1f9.zip
Repocopy math/netcdf to science/netcdf, along with cdf, hdf and hdf5.
PR: 92497 Submitted by: /me Repocopied by: marcus
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/gnudatalanguage/Makefile2
-rw-r--r--science/netcdf/Makefile2
-rw-r--r--science/netcdf4/Makefile2
-rw-r--r--science/ruby-netcdf/Makefile2
-rw-r--r--science/vis5d+/Makefile2
6 files changed, 6 insertions, 5 deletions
diff --git a/science/Makefile b/science/Makefile
index 42fa754e24d8..8d5e172aecc7 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -48,6 +48,7 @@
SUBDIR += mpb
SUBDIR += mpqc
SUBDIR += mpqc-mpich
+ SUBDIR += netcdf
SUBDIR += oases
SUBDIR += omnetpp
SUBDIR += openbabel
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 8d710737ac7e..a0f74283cc3f 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -69,7 +69,7 @@ CONFIGURE_ARGS+=--with-hdf5=no
.endif
.if !defined(WITHOUT_NETCDF)
-LIB_DEPENDS+= netcdf.1:${PORTSDIR}/math/netcdf
+LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
CONFIGURE_ARGS+=--with-netcdf=${LOCALBASE} --with-hdf=no
.else
CONFIGURE_ARGS+=--with-netcdf=no
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index b907ef08a76a..45c61fd487d6 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netcdf
PORTVERSION= 3.6.0p1
-CATEGORIES= math
+CATEGORIES= science
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-p/}
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index b907ef08a76a..45c61fd487d6 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netcdf
PORTVERSION= 3.6.0p1
-CATEGORIES= math
+CATEGORIES= science
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-p/}
diff --git a/science/ruby-netcdf/Makefile b/science/ruby-netcdf/Makefile
index bdb7cd4a2ad1..542145c820d1 100644
--- a/science/ruby-netcdf/Makefile
+++ b/science/ruby-netcdf/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A Ruby interface to the NetCDF scientific IO library
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
+LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
USE_RUBY= yes
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index d75ab4516bb8..3b85ddfd75bc 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -18,7 +18,7 @@ COMMENT= An OpenGL-based volumetric visualization program for scientific dataset
BUILD_DEPENDS= ${LOCALBASE}/lib/libmix.a:${PORTSDIR}/graphics/qslim \
convert:${PORTSDIR}/graphics/ImageMagick
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf \
+LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf \
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick