aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-11 00:31:33 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-11 00:31:33 +0800
commitc9ba8383bdf7b68530c33c54180a8639f51d94b2 (patch)
tree7c6811ddf9410d579010282fc349d31db01962b4 /science
parentefc20a2f6a7c56e7b601f1bf545bc6b671df6319 (diff)
downloadfreebsd-ports-gnome-c9ba8383bdf7b68530c33c54180a8639f51d94b2.tar.gz
freebsd-ports-gnome-c9ba8383bdf7b68530c33c54180a8639f51d94b2.tar.zst
freebsd-ports-gnome-c9ba8383bdf7b68530c33c54180a8639f51d94b2.zip
Follow-up commit to r396576 since I've forgotten to fix some things:
- Do not patch stuff in `pre-configure' target, do it in `post-patch' - It is our customary practice to mute ${REINPLACE_CMD} invocations - Do not (mis)use ${MAKE} when ${MAKE_CMD} should be used instead
Diffstat (limited to 'science')
-rw-r--r--science/cdf/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/science/cdf/Makefile b/science/cdf/Makefile
index 64e7ce4d1eae..6bbee78ae9ee 100644
--- a/science/cdf/Makefile
+++ b/science/cdf/Makefile
@@ -29,9 +29,9 @@ PORTDOCS= CDF_copyright.txt CHANGES.txt Release.notes Welcome.txt
OPTIONS_DEFINE= DOCS EXAMPLES
-pre-configure:
+post-patch:
.for def in ${DEFS}
- ${REINPLACE_CMD} -e 's|<path>|${PREFIX}|' \
+ @${REINPLACE_CMD} -e 's|<path>|${PREFIX}|' \
${WRKSRC}/src/definitions/definitions.${def}
.endfor
@@ -46,7 +46,7 @@ post-install:
${SED} -i '' 's,${STAGEDIR},,g' ${STAGEDIR}${PREFIX}/bin/definitions.?
regression-test: build
- @${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ @${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
${MAKE_ARGS} test -C ${BUILD_WRKSRC}
.include <bsd.port.mk>