aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-13 04:02:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-13 04:02:17 +0800
commitda8401876a10b6e2856b4ec67716220b224906ea (patch)
treef88a1450cbc4246001da9f0305903384543db47f /science
parent8533e471053a0facf04c07244922cf262c0838f2 (diff)
downloadfreebsd-ports-gnome-da8401876a10b6e2856b4ec67716220b224906ea.tar.gz
freebsd-ports-gnome-da8401876a10b6e2856b4ec67716220b224906ea.tar.zst
freebsd-ports-gnome-da8401876a10b6e2856b4ec67716220b224906ea.zip
Update to 1.3.0
- Update COMMENT - Update LICENSE_FILE - Add EXAMPLES option - Update pkg-descr - Update WWW - Bump PORTREVISION for dependent ports Changes: https://github.com/libkml/libkml/releases
Diffstat (limited to 'science')
-rw-r--r--science/libkml/Makefile39
-rw-r--r--science/libkml/distinfo5
-rw-r--r--science/libkml/files/patch-configure.ac20
-rw-r--r--science/libkml/files/patch-examples-domviewer-CMakeLists.txt7
-rw-r--r--science/libkml/files/patch-examples-helloworld-Makefile.am11
-rw-r--r--science/libkml/files/patch-examples-xsd-CMakeLists.txt11
-rw-r--r--science/libkml/files/patch-src-kml-base-Makefile.am48
-rw-r--r--science/libkml/files/patch-src-kml-base-file_posix.cc10
-rw-r--r--science/libkml/files/patch-src-swig-Makefile.am12
-rw-r--r--science/libkml/files/patch-third_party-Makefile.am83
-rw-r--r--science/libkml/pkg-descr5
-rw-r--r--science/libkml/pkg-plist58
12 files changed, 65 insertions, 244 deletions
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
index 6d0979550f05..5ea7a301cae1 100644
--- a/science/libkml/Makefile
+++ b/science/libkml/Makefile
@@ -2,36 +2,39 @@
# $FreeBSD$
PORTNAME= libkml
-PORTVERSION= 1.2
-DISTVERSIONPREFIX= release-
-PORTREVISION= 6
+PORTVERSION= 1.3.0
CATEGORIES= science
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Library for parse, generate, and operate on KML
+COMMENT= Reference implementation of OGC KML 2.2
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BUILD_DEPENDS= curl-config:ftp/curl
-LIB_DEPENDS= libexpat.so:textproc/expat2 \
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= boost-libs>=1.44.0:devel/boost-libs \
+ googletest>=1.7.0:devel/googletest \
+ minizip>=1.2.8:archivers/minizip
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
+ libexpat.so:textproc/expat2 \
+ libgtest.so:devel/googletest \
+ libminizip.so:archivers/minizip \
liburiparser.so:net/uriparser
-OPTIONS_DEFINE= SWIG
+OPTIONS_DEFINE= EXAMPLES
-CONFIGURE_ARGS= --disable-java --disable-python
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
+CMAKE_ARGS= -DWITH_JAVA=OFF -DWITH_PYTHON=OFF -DWITH_SWIG=OFF
USE_LDCONFIG= yes
-USES= autoreconf gmake libtool localbase
+USES= cmake pathfix
+
+PORTEXAMPLES= *
-GH_ACCOUNT= google
USE_GITHUB= yes
-SWIG_BUILD_DEPENDS= swig:devel/swig13
-SWIG_CONFIGURE_OFF= --disable-swig
+EXAMPLES_CMAKE_OFF= -DBUILD_EXAMPLES=OFF -DINSTALL_EXAMPLES=OFF
+EXAMPLES_CMAKE_ON= -DBUILD_EXAMPLES=ON -DINSTALL_EXAMPLES=ON -DKML_EXAMPLES_DIR=${EXAMPLESDIR}
+EXAMPLES_LIB_DEPENDS= libcurl.so:ftp/curl
-post-patch:
- @${FIND} ${WRKSRC} -name Makefile.am -exec ${REINPLACE_CMD} -e 's|-Werror||; s| -ansi -pedantic||' {} +
+post-patch-EXAMPLES-on:
+ @${REINPLACE_CMD} -e 's|DESTINATION examples/|DESTINATION $${KML_EXAMPLES_DIR}/|' ${WRKSRC}/examples/*/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/science/libkml/distinfo b/science/libkml/distinfo
index 879c908f97ca..95bb121b0428 100644
--- a/science/libkml/distinfo
+++ b/science/libkml/distinfo
@@ -1,2 +1,3 @@
-SHA256 (google-libkml-release-1.2_GH0.tar.gz) = 98b0808ac243390c09288bbc90c248879572ca7455f22dc4610aab32848d130d
-SIZE (google-libkml-release-1.2_GH0.tar.gz) = 8784768
+TIMESTAMP = 1483245177
+SHA256 (libkml-libkml-1.3.0_GH0.tar.gz) = 8892439e5570091965aaffe30b08631fdf7ca7f81f6495b4648f0950d7ea7963
+SIZE (libkml-libkml-1.3.0_GH0.tar.gz) = 6639857
diff --git a/science/libkml/files/patch-configure.ac b/science/libkml/files/patch-configure.ac
deleted file mode 100644
index 936d3bcf3a4c..000000000000
--- a/science/libkml/files/patch-configure.ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.ac.orig 2010-02-19 15:52:05 UTC
-+++ configure.ac
-@@ -6,7 +6,7 @@ AC_PREREQ(2.57)
- AC_INIT(libkml, 1.2.0, http://code.google.com/p/libkml/issues)
- AC_CONFIG_SRCDIR(README)
- AC_CONFIG_AUX_DIR(config)
--AM_INIT_AUTOMAKE(-Wall -Werror)
-+AM_INIT_AUTOMAKE(-Wall subdir-objects)
-
- AC_PROG_CPP
- AC_PROG_CXX
-@@ -88,7 +88,7 @@ if test "x$enable_swig" != xno; then
- AC_CHECK_PROG(SWIG, swig, swig)
- if test "x$SWIG" != x; then
- SWIG_VERSION=`swig -version 2>&1|grep Version|cut -d" " -f3`
-- if test ${SWIG_VERSION:4} -lt 35; then
-+ if test ${SWIG_VERSION#*.*.} -lt 35; then
- AC_MSG_WARN([You have SWIG $SWIG_VERSION installed, but libkml requires at least SWIG 1.3.35. The bindings will not be built.])
- SWIG=
- fi
diff --git a/science/libkml/files/patch-examples-domviewer-CMakeLists.txt b/science/libkml/files/patch-examples-domviewer-CMakeLists.txt
new file mode 100644
index 000000000000..8068aa15fe4c
--- /dev/null
+++ b/science/libkml/files/patch-examples-domviewer-CMakeLists.txt
@@ -0,0 +1,7 @@
+--- examples/domviewer/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
++++ examples/domviewer/CMakeLists.txt
+@@ -1,3 +1,3 @@
+ if(INSTALL_EXAMPLES)
+- install( FILES kml-aliases.txt DESTINATION ${KML_EXAMPLES_DIR} COMPONENT Development)
++ install( FILES domviewer.py DESTINATION ${KML_EXAMPLES_DIR} COMPONENT Development)
+ endif()
diff --git a/science/libkml/files/patch-examples-helloworld-Makefile.am b/science/libkml/files/patch-examples-helloworld-Makefile.am
deleted file mode 100644
index f8c12159112d..000000000000
--- a/science/libkml/files/patch-examples-helloworld-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- examples/helloworld/Makefile.am.orig 2010-02-19 15:52:05 UTC
-+++ examples/helloworld/Makefile.am
-@@ -10,7 +10,7 @@ endif
- noinst_LTLIBRARIES = libhelloutil.la
-
- libhelloutil_la_SOURCES = print.cc
--libhelloutil_la_LIBADD = $(top_builddir)/third_party/libminizip.la
-+libhelloutil_la_LIBADD = $(top_builddir)/third_party/libkmlminizip.la
-
- noinst_PROGRAMS = countkml createkml checklinks circlegen helloattrs helloenum \
- hellofeatures hellofolder hellogeometry hellohref hellokmz \
diff --git a/science/libkml/files/patch-examples-xsd-CMakeLists.txt b/science/libkml/files/patch-examples-xsd-CMakeLists.txt
new file mode 100644
index 000000000000..4d79e4f87bb9
--- /dev/null
+++ b/science/libkml/files/patch-examples-xsd-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- examples/xsd/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
++++ examples/xsd/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ if(INSTALL_EXAMPLES)
+- install(FILES
+- domviewer.py
+- DESTINATION examples/xsd) #compile py
++ file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.cc")
++ install(FILES ${eg_files} DESTINATION ${KML_EXAMPLES_DIR}/xsd)
++ install(FILES kml-aliases.txt DESTINATION ${KML_EXAMPLES_DIR}/xsd)
+ endif()
diff --git a/science/libkml/files/patch-src-kml-base-Makefile.am b/science/libkml/files/patch-src-kml-base-Makefile.am
deleted file mode 100644
index 873635622418..000000000000
--- a/science/libkml/files/patch-src-kml-base-Makefile.am
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/kml/base/Makefile.am.orig 2010-02-19 15:52:05 UTC
-+++ src/kml/base/Makefile.am
-@@ -1,7 +1,6 @@
- AM_CPPFLAGS = -I$(top_srcdir)/src \
- -I$(top_srcdir)/third_party/boost_1_34_1 \
- -I$(top_srcdir)/third_party/googletest-r108/include \
-- -I$(top_srcdir)/third_party/uriparser-0.7.5/include \
- -I$(top_srcdir)/third_party/zlib-1.2.3/contrib
-
- if GCC
-@@ -31,8 +30,8 @@ libkmlbase_la_SOURCES = \
- zip_file.cc
-
- libkmlbase_la_LIBADD = \
-- $(top_builddir)/third_party/libminizip.la \
-- $(top_builddir)/third_party/liburiparser.la
-+ $(top_builddir)/third_party/libkmlminizip.la \
-+ -luriparser
-
- # These header files will be installed in $(includedir)/kml/base
- libkmlbaseincludedir = $(includedir)/kml/base
-@@ -138,7 +137,7 @@ math_util_test_LDADD = libkmlbase.la \
- net_cache_test_SOURCES = net_cache_test.cc
- net_cache_test_CXXFLAGS = -DDATADIR=\"$(DATA_DIR)\" $(AM_TEST_CXXFLAGS)
- net_cache_test_LDADD = libkmlbase.la \
-- $(top_builddir)/third_party/liburiparser.la \
-+ -luriparser \
- $(top_builddir)/third_party/libgtest.la
-
- referent_test_SOURCES = referent_test.cc
-@@ -164,7 +163,7 @@ time_util_test_LDADD= libkmlbase.la \
- uri_parser_test_SOURCES = uri_parser_test.cc
- uri_parser_test_CXXFLAGS = -DDATADIR=\"$(DATA_DIR)\" $(AM_TEST_CXXFLAGS)
- uri_parser_test_LDADD= libkmlbase.la \
-- $(top_builddir)/third_party/liburiparser.la \
-+ -luriparser \
- $(top_builddir)/third_party/libgtest.la
-
- util_test_SOURCES = util_test.cc
-@@ -205,7 +204,7 @@ xmlns_test_LDADD= libkmlbase.la \
- zip_file_test_SOURCES = zip_file_test.cc
- zip_file_test_CXXFLAGS = -DDATADIR=\"$(DATA_DIR)\" $(AM_TEST_CXXFLAGS)
- zip_file_test_LDADD= libkmlbase.la \
-- $(top_builddir)/third_party/libminizip.la \
-+ $(top_builddir)/third_party/libkmlminizip.la \
- $(top_builddir)/third_party/libgtest.la
-
- CLEANFILES = check_PROGRAMS
diff --git a/science/libkml/files/patch-src-kml-base-file_posix.cc b/science/libkml/files/patch-src-kml-base-file_posix.cc
deleted file mode 100644
index 9dad7ba5b4c4..000000000000
--- a/science/libkml/files/patch-src-kml-base-file_posix.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/kml/base/file_posix.cc.orig 2010-02-19 15:52:05 UTC
-+++ src/kml/base/file_posix.cc
-@@ -29,6 +29,7 @@
- #include "kml/base/file.h"
- #include <stdlib.h>
- #include <string.h>
-+#include <unistd.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-
diff --git a/science/libkml/files/patch-src-swig-Makefile.am b/science/libkml/files/patch-src-swig-Makefile.am
deleted file mode 100644
index d1e64b582793..000000000000
--- a/science/libkml/files/patch-src-swig-Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/swig/Makefile.am.orig 2010-02-19 15:52:05 UTC
-+++ src/swig/Makefile.am
-@@ -1,8 +1,7 @@
- SUBDIRS = java python
-
- AM_CPPFLAGS = -I$(top_srcdir)/src \
-- -I$(top_srcdir)/third_party/boost_1_34_1 \
-- -I$(top_srcdir)/third_party/uriparser-0.7.5/include
-+ -I$(top_srcdir)/third_party/boost_1_34_1
-
- COMMONLIBS = $(top_builddir)/src/kml/engine/libkmlengine.la \
- $(top_builddir)/src/kml/dom/libkmldom.la \
diff --git a/science/libkml/files/patch-third_party-Makefile.am b/science/libkml/files/patch-third_party-Makefile.am
deleted file mode 100644
index d4a5b6b775aa..000000000000
--- a/science/libkml/files/patch-third_party-Makefile.am
+++ /dev/null
@@ -1,83 +0,0 @@
---- third_party/Makefile.am.orig 2010-02-19 15:52:05 UTC
-+++ third_party/Makefile.am
-@@ -1,40 +1,16 @@
--uriparser = uriparser-0.7.5
--
- AM_CPPFLAGS = -I$(top_srcdir)/third_party/zlib-1.2.3/contrib \
-- -I$(top_srcdir)/third_party/$(uriparser)/include \
- -I$(top_srcdir)/third_party/googletest-r108 \
- -I$(top_srcdir)/third_party/googletest-r108/include
-
--lib_LTLIBRARIES = libminizip.la liburiparser.la
-+lib_LTLIBRARIES = libkmlminizip.la
- noinst_LTLIBRARIES = libgtest.la
-
--libminizip_la_SOURCES = \
-+libkmlminizip_la_SOURCES = \
- zlib-1.2.3/contrib/minizip/unzip.c \
- zlib-1.2.3/contrib/minizip/ioapi.c \
- zlib-1.2.3/contrib/minizip/iomem_simple.c \
- zlib-1.2.3/contrib/minizip/zip.c
--libminizip_la_LDFLAGS = -lz
--
--liburiparser_la_SOURCES = \
-- $(uriparser)/lib/UriCommon.c \
-- $(uriparser)/lib/UriCommon.h \
-- $(uriparser)/lib/UriCompare.c \
-- $(uriparser)/lib/UriEscape.c \
-- $(uriparser)/lib/UriFile.c \
-- $(uriparser)/lib/UriIp4.c \
-- $(uriparser)/lib/UriIp4Base.c \
-- $(uriparser)/lib/UriIp4Base.h \
-- $(uriparser)/lib/UriNormalize.c \
-- $(uriparser)/lib/UriNormalizeBase.c \
-- $(uriparser)/lib/UriNormalizeBase.h \
-- $(uriparser)/lib/UriParse.c \
-- $(uriparser)/lib/UriParseBase.c \
-- $(uriparser)/lib/UriParseBase.h \
-- $(uriparser)/lib/UriQuery.c \
-- $(uriparser)/lib/UriRecompose.c \
-- $(uriparser)/lib/UriResolve.c \
-- $(uriparser)/lib/UriShorten.c
--liburiparser_la_LDFLAGS = -version-info 1:5:0
-+libkmlminizip_la_LDFLAGS = -lz
-
- boost_root = boost_1_34_1
- boost = $(boost_root)/boost
-@@ -79,13 +55,13 @@ libboostconfigplatforminclude_HEADERS =
-
- googletest = googletest-r108
- libgtest_la_SOURCES = \
-- $(googletest)/src/gtest.cc \
-- $(googletest)/src/gtest-death-test.cc \
-- $(googletest)/src/gtest-filepath.cc \
-- $(googletest)/src/gtest-internal-inl.h \
-- $(googletest)/src/gtest-port.cc \
-- $(googletest)/src/gtest-test-part.cc \
-- $(googletest)/src/gtest-typed-test.cc
-+ googletest-r108/src/gtest.cc \
-+ googletest-r108/src/gtest-death-test.cc \
-+ googletest-r108/src/gtest-filepath.cc \
-+ googletest-r108/src/gtest-internal-inl.h \
-+ googletest-r108/src/gtest-port.cc \
-+ googletest-r108/src/gtest-test-part.cc \
-+ googletest-r108/src/gtest-typed-test.cc
-
- EXTRA_DIST = \
- expat.win32/expat.h \
-@@ -159,15 +135,6 @@ EXTRA_DIST = \
- $(googletest)/include/gtest/internal/gtest-port.h \
- $(googletest)/include/gtest/internal/gtest-string.h \
- $(googletest)/include/gtest/internal/gtest-type-util.h \
-- $(uriparser)/COPYING \
-- $(uriparser).win32/debug/uriparser.lib \
-- $(uriparser).win32/release/uriparser.lib \
-- $(uriparser)/include/uriparser/Uri.h \
-- $(uriparser)/include/uriparser/UriBase.h \
-- $(uriparser)/include/uriparser/UriDefsAnsi.h \
-- $(uriparser)/include/uriparser/UriDefsConfig.h \
-- $(uriparser)/include/uriparser/UriDefsUnicode.h \
-- $(uriparser)/include/uriparser/UriIp4.h \
- zlib-1.2.3/zconf.h \
- zlib-1.2.3/zlib.h \
- zlib-1.2.3/contrib/minizip/crypt.h \
diff --git a/science/libkml/pkg-descr b/science/libkml/pkg-descr
index aea0aa9e2366..d7ad8c5efd88 100644
--- a/science/libkml/pkg-descr
+++ b/science/libkml/pkg-descr
@@ -2,4 +2,7 @@ This is Google's reference implementation of OGC KML 2.2. It also includes
implementations of Google's gx: extensions used by Google Earth, as well as
several utility libraries for working with other formats.
-WWW: https://github.com/google/libkml
+All of original documentation written by google is imported into "wiki" branch:
+https://github.com/libkml/libkml/tree/wiki
+
+WWW: https://github.com/libkml/libkml
diff --git a/science/libkml/pkg-plist b/science/libkml/pkg-plist
index 63480291f536..2a84646eb746 100644
--- a/science/libkml/pkg-plist
+++ b/science/libkml/pkg-plist
@@ -34,6 +34,7 @@ include/kml/convenience/google_picasa_web.h
include/kml/convenience/google_spreadsheets.h
include/kml/convenience/gpx_trk_pt_handler.h
include/kml/convenience/http_client.h
+include/kml/convenience/kml_feature_list_saver.h
include/kml/convenience/kmz_check_links.h
include/kml/dom.h
include/kml/dom/abstractlatlonbox.h
@@ -84,6 +85,7 @@ include/kml/dom/vec2.h
include/kml/dom/visitor.h
include/kml/dom/visitor_driver.h
include/kml/dom/xal.h
+include/kml/dom/xsd.h
include/kml/engine.h
include/kml/engine/bbox.h
include/kml/engine/clone.h
@@ -123,23 +125,6 @@ include/kml/regionator/region_handler.h
include/kml/regionator/regionator.h
include/kml/regionator/regionator_qid.h
include/kml/regionator/regionator_util.h
-include/kml/third_party/boost_1_34_1/boost/assert.hpp
-include/kml/third_party/boost_1_34_1/boost/checked_delete.hpp
-include/kml/third_party/boost_1_34_1/boost/config.hpp
-include/kml/third_party/boost_1_34_1/boost/config/compiler/gcc.hpp
-include/kml/third_party/boost_1_34_1/boost/config/no_tr1/utility.hpp
-include/kml/third_party/boost_1_34_1/boost/config/platform/linux.hpp
-include/kml/third_party/boost_1_34_1/boost/config/platform/macos.hpp
-include/kml/third_party/boost_1_34_1/boost/config/posix_features.hpp
-include/kml/third_party/boost_1_34_1/boost/config/select_compiler_config.hpp
-include/kml/third_party/boost_1_34_1/boost/config/select_platform_config.hpp
-include/kml/third_party/boost_1_34_1/boost/config/select_stdlib_config.hpp
-include/kml/third_party/boost_1_34_1/boost/config/stdlib/libstdcpp3.hpp
-include/kml/third_party/boost_1_34_1/boost/config/suffix.hpp
-include/kml/third_party/boost_1_34_1/boost/config/user.hpp
-include/kml/third_party/boost_1_34_1/boost/detail/workaround.hpp
-include/kml/third_party/boost_1_34_1/boost/intrusive_ptr.hpp
-include/kml/third_party/boost_1_34_1/boost/scoped_ptr.hpp
include/kml/xsd/xsd_complex_type.h
include/kml/xsd/xsd_element.h
include/kml/xsd/xsd_file.h
@@ -150,31 +135,26 @@ include/kml/xsd/xsd_simple_type.h
include/kml/xsd/xsd_type.h
include/kml/xsd/xsd_util.h
include/kml/xsd/xst_parser.h
-lib/libkmlbase.a
+lib/cmake/libkml/LibKMLConfig.cmake
+lib/cmake/libkml/LibKMLConfigVersion.cmake
+lib/cmake/libkml/LibKMLTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/libkml/LibKMLTargets.cmake
lib/libkmlbase.so
-lib/libkmlbase.so.0
-lib/libkmlbase.so.0.0.0
-lib/libkmlconvenience.a
+lib/libkmlbase.so.1
+lib/libkmlbase.so.1.3.0
lib/libkmlconvenience.so
-lib/libkmlconvenience.so.0
-lib/libkmlconvenience.so.0.0.0
-lib/libkmldom.a
+lib/libkmlconvenience.so.1
+lib/libkmlconvenience.so.1.3.0
lib/libkmldom.so
-lib/libkmldom.so.0
-lib/libkmldom.so.0.0.0
-lib/libkmlengine.a
+lib/libkmldom.so.1
+lib/libkmldom.so.1.3.0
lib/libkmlengine.so
-lib/libkmlengine.so.0
-lib/libkmlengine.so.0.0.0
-lib/libkmlminizip.a
-lib/libkmlminizip.so
-lib/libkmlminizip.so.0
-lib/libkmlminizip.so.0.0.0
-lib/libkmlregionator.a
+lib/libkmlengine.so.1
+lib/libkmlengine.so.1.3.0
lib/libkmlregionator.so
-lib/libkmlregionator.so.0
-lib/libkmlregionator.so.0.0.0
-lib/libkmlxsd.a
+lib/libkmlregionator.so.1
+lib/libkmlregionator.so.1.3.0
lib/libkmlxsd.so
-lib/libkmlxsd.so.0
-lib/libkmlxsd.so.0.0.0
+lib/libkmlxsd.so.1
+lib/libkmlxsd.so.1.3.0
+libdata/pkgconfig/libkml.pc