aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2012-01-22 01:40:15 +0800
committereadler <eadler@FreeBSD.org>2012-01-22 01:40:15 +0800
commite9db6e5787c03eac4b5310b1b5abeee5eea88e8c (patch)
tree403e868e6517b550ecdf81ff503e5975785ab7d7 /science
parent0c9cbf4cb27b7ccab5b886919dea648ef53e8a6b (diff)
downloadfreebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.tar.gz
freebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.tar.zst
freebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.zip
At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450
ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are currently broken. This is a temporary measure until we organically stop using := or someone(s) spend a lot of time changing all the ports over. Explicit duplication > := > = and this just moves ports one step to the left Approved by: portmgr
Diffstat (limited to 'science')
-rw-r--r--science/p5-Chemistry-MacroMol/Makefile2
-rw-r--r--science/p5-Geo-Coordinates-Converter/Makefile2
-rw-r--r--science/psychopy/Makefile2
-rw-r--r--science/py-hcluster/Makefile2
-rw-r--r--science/py-mlpy/Makefile2
-rw-r--r--science/py-scimath/Makefile2
-rw-r--r--science/pycdf/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/science/p5-Chemistry-MacroMol/Makefile b/science/p5-Chemistry-MacroMol/Makefile
index 865a1d9dd475..fc56aa63942d 100644
--- a/science/p5-Chemistry-MacroMol/Makefile
+++ b/science/p5-Chemistry-MacroMol/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= wenheping@gmail.com
COMMENT= Perl toolkit to describe macromolecules
BUILD_DEPENDS= p5-Chemistry-Mol>=0.37:${PORTSDIR}/science/p5-Chemistry-Mol
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/science/p5-Geo-Coordinates-Converter/Makefile b/science/p5-Geo-Coordinates-Converter/Makefile
index 1d3dc3bdb8d0..654c312926fa 100644
--- a/science/p5-Geo-Coordinates-Converter/Makefile
+++ b/science/p5-Geo-Coordinates-Converter/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= p5-Class-Accessor-Lite>0.0.5:${PORTSDIR}/devel/p5-Class-Accessor-
p5-Readonly>0:${PORTSDIR}/devel/p5-Readonly \
p5-String-CamelCase>0:${PORTSDIR}/textproc/p5-String-CamelCase \
p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/science/psychopy/Makefile b/science/psychopy/Makefile
index b0f228f57023..dd6645a23c61 100644
--- a/science/psychopy/Makefile
+++ b/science/psychopy/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.1.0:${PORTSDIR}/math/py-numpy \
${PYTHON_PKGNAMEPREFIX}pyglet>=1.1.2:${PORTSDIR}/graphics/py-pyglet \
${PYTHON_PKGNAMEPREFIX}wxPython>=2.8.7.1:${PORTSDIR}/x11-toolkits/py-wxPython28 \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_ZIP= yes
USE_PYTHON= 2.5+
diff --git a/science/py-hcluster/Makefile b/science/py-hcluster/Makefile
index c0dbb8a40bbb..c06599c90339 100644
--- a/science/py-hcluster/Makefile
+++ b/science/py-hcluster/Makefile
@@ -17,7 +17,7 @@ COMMENT= A Hierarchical Clustering Package For Scipy
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
index deba8de87166..fd79813a6d0e 100644
--- a/science/py-mlpy/Makefile
+++ b/science/py-mlpy/Makefile
@@ -18,7 +18,7 @@ COMMENT= High performance Python package for predictive modeling
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
cython>0:${PORTSDIR}/lang/cython
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
CFLAGS+= -I${LOCALBASE}/include -I${PYTHON_SITELIBDIR}/numpy/core
diff --git a/science/py-scimath/Makefile b/science/py-scimath/Makefile
index d76c6a8acb2c..20135997f396 100644
--- a/science/py-scimath/Makefile
+++ b/science/py-scimath/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= Scientific and Mathematical calculations
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traits>=3.6.0:${PORTSDIR}/devel/py-traits
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
PYEASYINSTALL_ARCHDEP= yes
diff --git a/science/pycdf/Makefile b/science/pycdf/Makefile
index 4efde108b1d0..89981edf91c5 100644
--- a/science/pycdf/Makefile
+++ b/science/pycdf/Makefile
@@ -16,7 +16,7 @@ COMMENT= A Python Interface to the Unidata NetCDF Library
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
${LOCALBASE}/lib/libnetcdf.so:${PORTSDIR}/science/netcdf
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
LDFLAGS+= "-L${LOCALBASE}/lib"