aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-04-25 03:55:43 +0800
committerthierry <thierry@FreeBSD.org>2006-04-25 03:55:43 +0800
commitee44e9672584297975c08a036be51795d7bebc50 (patch)
treee8949572fa0f88c1d88e9a122d421f3fa1d0e234 /science
parent4bc1b4cc178cd5fe2c59563fa732cddac7d8fbb3 (diff)
downloadfreebsd-ports-gnome-ee44e9672584297975c08a036be51795d7bebc50.tar.gz
freebsd-ports-gnome-ee44e9672584297975c08a036be51795d7bebc50.tar.zst
freebsd-ports-gnome-ee44e9672584297975c08a036be51795d7bebc50.zip
ElmerPost - the Visualization of Numerical Results.
The function of ElmerPost is to visualize the numerical results produced by ElmerSolver and other finite element programs. ElmerPost operates with the data specific to the unknown variables (temperature, velocity, pressure, displacement etc.) defined in the mathematical model. ElmerPost plots e.g. contours and vector fields, and can manipulate computed data into another form using the built-in MATC-language (for instance heat fluxes from temperature distributions). Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/elmerpost/Makefile45
-rw-r--r--science/elmerpost/distinfo3
-rw-r--r--science/elmerpost/pkg-descr11
-rw-r--r--science/elmerpost/pkg-plist286
5 files changed, 346 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 861a0fa1f43b..a9a042307833 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -24,6 +24,7 @@
SUBDIR += elmer-meshgen2d
SUBDIR += elmerfront
SUBDIR += elmergrid
+ SUBDIR += elmerpost
SUBDIR += euler
SUBDIR += fastcap
SUBDIR += fasthenry
diff --git a/science/elmerpost/Makefile b/science/elmerpost/Makefile
new file mode 100644
index 000000000000..b0fa8ef3ba82
--- /dev/null
+++ b/science/elmerpost/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: elmerpost
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= elmerpost
+PORTVERSION= 5.0.3
+CATEGORIES= science
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+
+MAINTAINER= giffunip@asme.org
+COMMENT= Visualization of Numerical Results in the ELMER FEM package
+
+BUILD_DEPENDS= ${FC}:${PORTSDIR}/lang/gfortran \
+ ${LOCALBASE}/lib/libmatc.a:${PORTSDIR}/science/elmer-matc \
+ wish8.4:${PORTSDIR}/x11-toolkits/tk84
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+# Elmer avoids the new C++ headers because they cause problems
+# on older systems (Irix)
+CXXFLAGS+= -Wno-deprecated
+
+USE_GL= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+ALL_TARGET=
+
+USE_GCC= 4.1+
+WITH_FORTRAN= yes
+FC= ${LOCALBASE}/bin/gfortran41
+F77= ${FC}
+CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS=${FCFLAGS}
+
+PLIST_SUB= ARCH=${MACHINE_ARCH}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+FFLAGS+= -fPIC
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/elmerpost/distinfo b/science/elmerpost/distinfo
new file mode 100644
index 000000000000..f49be54083f5
--- /dev/null
+++ b/science/elmerpost/distinfo
@@ -0,0 +1,3 @@
+MD5 (elmerpost-5.0.3.tar.gz) = c53025fd5a7788d254880517eb80e25d
+SHA256 (elmerpost-5.0.3.tar.gz) = 194c7811225aa13a9effcb6975be73edf8b5804dcc15fbf854ff5b41e64e029b
+SIZE (elmerpost-5.0.3.tar.gz) = 1412082
diff --git a/science/elmerpost/pkg-descr b/science/elmerpost/pkg-descr
new file mode 100644
index 000000000000..6ca1de8e9715
--- /dev/null
+++ b/science/elmerpost/pkg-descr
@@ -0,0 +1,11 @@
+ElmerPost - the Visualization of Numerical Results.
+
+The function of ElmerPost is to visualize the numerical results produced
+by ElmerSolver and other finite element programs. ElmerPost operates with
+the data specific to the unknown variables (temperature, velocity,
+pressure, displacement etc.) defined in the mathematical model. ElmerPost
+plots e.g. contours and vector fields, and can manipulate computed data
+into another form using the built-in MATC-language (for instance heat
+fluxes from temperature distributions).
+
+WWW: http://www.csc.fi/elmer/elmerpost/
diff --git a/science/elmerpost/pkg-plist b/science/elmerpost/pkg-plist
new file mode 100644
index 000000000000..fe1c370795cd
--- /dev/null
+++ b/science/elmerpost/pkg-plist
@@ -0,0 +1,286 @@
+bin/%%ARCH%%-portbld-freebsd%%OSREL%%-ElmerPost
+bin/%%ARCH%%-portbld-freebsd%%OSREL%%-QueryGLXExt
+bin/%%ARCH%%-portbld-freebsd%%OSREL%%-sico2elmer
+%%DATADIR%%/help/index.html
+%%DATADIR%%/help/http.tcl
+%%DATADIR%%/help/help.tcl
+%%DATADIR%%/help/gallery.html
+%%DATADIR%%/help/file.html
+%%DATADIR%%/help/edit.html
+%%DATADIR%%/help/mouse.html
+%%DATADIR%%/help/dspl.html
+%%DATADIR%%/help/matc.html
+%%DATADIR%%/help/main.html
+%%DATADIR%%/help/matc/img1.gif
+%%DATADIR%%/help/matc/img10.gif
+%%DATADIR%%/help/matc/img11.gif
+%%DATADIR%%/help/matc/img12.gif
+%%DATADIR%%/help/matc/img13.gif
+%%DATADIR%%/help/matc/img14.gif
+%%DATADIR%%/help/matc/img15.gif
+%%DATADIR%%/help/matc/img16.gif
+%%DATADIR%%/help/matc/img17.gif
+%%DATADIR%%/help/matc/img2.gif
+%%DATADIR%%/help/matc/img3.gif
+%%DATADIR%%/help/matc/img4.gif
+%%DATADIR%%/help/matc/img5.gif
+%%DATADIR%%/help/matc/img6.gif
+%%DATADIR%%/help/matc/img7.gif
+%%DATADIR%%/help/matc/img8.gif
+%%DATADIR%%/help/matc/img9.gif
+%%DATADIR%%/help/matc/kirja.html
+%%DATADIR%%/help/matc/node1.html
+%%DATADIR%%/help/matc/node10.html
+%%DATADIR%%/help/matc/node11.html
+%%DATADIR%%/help/matc/node12.html
+%%DATADIR%%/help/matc/node13.html
+%%DATADIR%%/help/matc/node14.html
+%%DATADIR%%/help/matc/node15.html
+%%DATADIR%%/help/matc/node16.html
+%%DATADIR%%/help/matc/node17.html
+%%DATADIR%%/help/matc/node18.html
+%%DATADIR%%/help/matc/node19.html
+%%DATADIR%%/help/matc/node2.html
+%%DATADIR%%/help/matc/node20.html
+%%DATADIR%%/help/matc/node21.html
+%%DATADIR%%/help/matc/node22.html
+%%DATADIR%%/help/matc/node23.html
+%%DATADIR%%/help/matc/node24.html
+%%DATADIR%%/help/matc/node25.html
+%%DATADIR%%/help/matc/node26.html
+%%DATADIR%%/help/matc/node27.html
+%%DATADIR%%/help/matc/node28.html
+%%DATADIR%%/help/matc/node29.html
+%%DATADIR%%/help/matc/node3.html
+%%DATADIR%%/help/matc/node30.html
+%%DATADIR%%/help/matc/node31.html
+%%DATADIR%%/help/matc/node32.html
+%%DATADIR%%/help/matc/node33.html
+%%DATADIR%%/help/matc/node34.html
+%%DATADIR%%/help/matc/node35.html
+%%DATADIR%%/help/matc/node36.html
+%%DATADIR%%/help/matc/node37.html
+%%DATADIR%%/help/matc/node38.html
+%%DATADIR%%/help/matc/node39.html
+%%DATADIR%%/help/matc/node4.html
+%%DATADIR%%/help/matc/node40.html
+%%DATADIR%%/help/matc/node41.html
+%%DATADIR%%/help/matc/node42.html
+%%DATADIR%%/help/matc/node43.html
+%%DATADIR%%/help/matc/node44.html
+%%DATADIR%%/help/matc/node45.html
+%%DATADIR%%/help/matc/node46.html
+%%DATADIR%%/help/matc/node47.html
+%%DATADIR%%/help/matc/node48.html
+%%DATADIR%%/help/matc/node49.html
+%%DATADIR%%/help/matc/node5.html
+%%DATADIR%%/help/matc/node50.html
+%%DATADIR%%/help/matc/node51.html
+%%DATADIR%%/help/matc/node6.html
+%%DATADIR%%/help/matc/node7.html
+%%DATADIR%%/help/matc/node8.html
+%%DATADIR%%/help/matc/node9.html
+%%DATADIR%%/help/matc/lh-figs/yellowball.gif
+%%DATADIR%%/help/matc/lh-figs/change_begin.gif
+%%DATADIR%%/help/matc/lh-figs/change_delete.gif
+%%DATADIR%%/help/matc/lh-figs/change_end.gif
+%%DATADIR%%/help/matc/lh-figs/contents_motif.gif
+%%DATADIR%%/help/matc/lh-figs/cross_ref_motif.gif
+%%DATADIR%%/help/matc/lh-figs/foot_motif.gif
+%%DATADIR%%/help/matc/lh-figs/greenball.gif
+%%DATADIR%%/help/matc/lh-figs/image.gif
+%%DATADIR%%/help/matc/lh-figs/index_motif.gif
+%%DATADIR%%/help/matc/lh-figs/left.gif
+%%DATADIR%%/help/matc/lh-figs/logo.gif
+%%DATADIR%%/help/matc/lh-figs/next_group_motif.gif
+%%DATADIR%%/help/matc/lh-figs/next_group_motif_gr.gif
+%%DATADIR%%/help/matc/lh-figs/next_motif.gif
+%%DATADIR%%/help/matc/lh-figs/next_motif_gr.gif
+%%DATADIR%%/help/matc/lh-figs/orangeball.gif
+%%DATADIR%%/help/matc/lh-figs/pinkball.gif
+%%DATADIR%%/help/matc/lh-figs/previous_motif.gif
+%%DATADIR%%/help/matc/lh-figs/previous_group_motif.gif
+%%DATADIR%%/help/matc/lh-figs/previous_group_motif_gr.gif
+%%DATADIR%%/help/matc/lh-figs/previous_motif_gr.gif
+%%DATADIR%%/help/matc/lh-figs/purpleball.gif
+%%DATADIR%%/help/matc/lh-figs/redball.gif
+%%DATADIR%%/help/matc/lh-figs/right.gif
+%%DATADIR%%/help/matc/lh-figs/up_motif.gif
+%%DATADIR%%/help/matc/lh-figs/up_motif_gr.gif
+%%DATADIR%%/help/matc/lh-figs/whiteball.gif
+%%DATADIR%%/help/matc/lh-figs/blueball.gif
+@dirrm %%DATADIR%%/help/matc/lh-figs
+@dirrm %%DATADIR%%/help/matc
+%%DATADIR%%/help/html_library-0.3/html_library.tcl
+%%DATADIR%%/help/html_library-0.3/license.terms
+@dirrm %%DATADIR%%/help/html_library-0.3
+%%DATADIR%%/help/figs/ylos.gif
+%%DATADIR%%/help/figs/a.log
+%%DATADIR%%/help/figs/background.gif
+%%DATADIR%%/help/figs/benzene_cut.gif
+%%DATADIR%%/help/figs/benzene_iso.gif
+%%DATADIR%%/help/figs/clip.gif
+%%DATADIR%%/help/figs/colormap.gif
+%%DATADIR%%/help/figs/cols.gif
+%%DATADIR%%/help/figs/cont.gif
+%%DATADIR%%/help/figs/crystal_flow.gif
+%%DATADIR%%/help/figs/crystal_stream.gif
+%%DATADIR%%/help/figs/crystal_temp.gif
+%%DATADIR%%/help/figs/diff.gif
+%%DATADIR%%/help/figs/elmer.gif
+%%DATADIR%%/help/figs/elmer_back.gif
+%%DATADIR%%/help/figs/elmer_general.gif
+%%DATADIR%%/help/figs/elmer_home.gif
+%%DATADIR%%/help/figs/elmer_who.gif
+%%DATADIR%%/help/figs/groups.gif
+%%DATADIR%%/help/figs/iso.gif
+%%DATADIR%%/help/figs/k1.gif
+%%DATADIR%%/help/figs/matc.gif
+%%DATADIR%%/help/figs/kide3d_cvec.gif
+%%DATADIR%%/help/figs/kide3d_part.gif
+%%DATADIR%%/help/figs/material.gif
+%%DATADIR%%/help/figs/mesh.gif
+%%DATADIR%%/help/figs/newshome.gif
+%%DATADIR%%/help/figs/particle.gif
+%%DATADIR%%/help/figs/putki3d.gif
+%%DATADIR%%/help/figs/putki3d_particles.gif
+%%DATADIR%%/help/figs/rb_temp.gif
+%%DATADIR%%/help/figs/rb_vect.gif
+%%DATADIR%%/help/figs/saab.gif
+%%DATADIR%%/help/figs/saab1.gif
+%%DATADIR%%/help/figs/saab2.gif
+%%DATADIR%%/help/figs/saab3.gif
+%%DATADIR%%/help/figs/saab4.gif
+%%DATADIR%%/help/figs/sic_geometry.jpg
+%%DATADIR%%/help/figs/sic_grid.jpg
+%%DATADIR%%/help/figs/sic_heating.jpg
+%%DATADIR%%/help/figs/sic_temperature.jpg
+%%DATADIR%%/help/figs/smelt_cut.gif
+%%DATADIR%%/help/figs/smelt_part.gif
+%%DATADIR%%/help/figs/spec1.gif
+%%DATADIR%%/help/figs/spec2.gif
+%%DATADIR%%/help/figs/sphere.gif
+%%DATADIR%%/help/figs/sub10h.jpg
+%%DATADIR%%/help/figs/sub10t.jpg
+%%DATADIR%%/help/figs/sub11h.jpg
+%%DATADIR%%/help/figs/sub11t.jpg
+%%DATADIR%%/help/figs/sub12a.gif
+%%DATADIR%%/help/figs/sub12a.jpg
+%%DATADIR%%/help/figs/sub12f.gif
+%%DATADIR%%/help/figs/sub12f.jpg
+%%DATADIR%%/help/figs/sub12h.gif
+%%DATADIR%%/help/figs/sub12h.jpg
+%%DATADIR%%/help/figs/sub12t.gif
+%%DATADIR%%/help/figs/sub12t.jpg
+%%DATADIR%%/help/figs/sub12v.gif
+%%DATADIR%%/help/figs/sub12v.jpg
+%%DATADIR%%/help/figs/sub13h.jpg
+%%DATADIR%%/help/figs/sub13t.jpg
+%%DATADIR%%/help/figs/sub14h.jpg
+%%DATADIR%%/help/figs/sub14t.jpg
+%%DATADIR%%/help/figs/sub1h.jpg
+%%DATADIR%%/help/figs/sub1t.jpg
+%%DATADIR%%/help/figs/sub2t.jpg
+%%DATADIR%%/help/figs/sub3t.jpg
+%%DATADIR%%/help/figs/sub4t.jpg
+%%DATADIR%%/help/figs/sub5t.jpg
+%%DATADIR%%/help/figs/sub6h.jpg
+%%DATADIR%%/help/figs/sub7h.jpg
+%%DATADIR%%/help/figs/sub8h.jpg
+%%DATADIR%%/help/figs/sub9h.jpg
+%%DATADIR%%/help/figs/sub9t.jpg
+%%DATADIR%%/help/figs/tausta.gif
+%%DATADIR%%/help/figs/timestep.gif
+%%DATADIR%%/help/figs/up.gif
+%%DATADIR%%/help/figs/up32.gif
+%%DATADIR%%/help/figs/vector.gif
+%%DATADIR%%/help/figs/camera.gif
+@dirrm %%DATADIR%%/help/figs
+@dirrm %%DATADIR%%/help
+%%DATADIR%%/lib/rgb.txt
+%%DATADIR%%/lib/mc.ini
+%%DATADIR%%/lib/cameras/default
+%%DATADIR%%/lib/cameras/koe.cam
+%%DATADIR%%/lib/cameras/four_view.cam
+%%DATADIR%%/lib/cameras/single_ortho.cam
+%%DATADIR%%/lib/cameras/single_view.cam
+%%DATADIR%%/lib/cameras/three_view.cam
+@dirrm %%DATADIR%%/lib/cameras
+%%DATADIR%%/lib/colormaps/white.cm
+%%DATADIR%%/lib/colormaps/Spectral_256.cm
+%%DATADIR%%/lib/colormaps/Spectral_32.cm
+%%DATADIR%%/lib/colormaps/Spectral_512.cm
+%%DATADIR%%/lib/colormaps/black.cm
+%%DATADIR%%/lib/colormaps/default.cm
+%%DATADIR%%/lib/colormaps/gray_16.cm
+%%DATADIR%%/lib/colormaps/gray_256.cm
+%%DATADIR%%/lib/colormaps/gray_32.cm
+%%DATADIR%%/lib/colormaps/gray_4.cm
+%%DATADIR%%/lib/colormaps/gray_512.cm
+%%DATADIR%%/lib/colormaps/gray_8.cm
+%%DATADIR%%/lib/colormaps/Spectral_16.cm
+@dirrm %%DATADIR%%/lib/colormaps
+%%DATADIR%%/lib/images/vect.gif
+%%DATADIR%%/lib/images/FILESAVE.BMP
+%%DATADIR%%/lib/images/WS_FTP.LOG
+%%DATADIR%%/lib/images/arrows.gif
+%%DATADIR%%/lib/images/cmesh.bmp
+%%DATADIR%%/lib/images/cmesh.gif
+%%DATADIR%%/lib/images/colscale.gif
+%%DATADIR%%/lib/images/cont.gif
+%%DATADIR%%/lib/images/down.gif
+%%DATADIR%%/lib/images/file.gif
+%%DATADIR%%/lib/images/fileopen.gif
+%%DATADIR%%/lib/images/isocont.gif
+%%DATADIR%%/lib/images/left.gif
+%%DATADIR%%/lib/images/lwait.cur
+%%DATADIR%%/lib/images/part.gif
+%%DATADIR%%/lib/images/play.gif
+%%DATADIR%%/lib/images/play.rgb
+%%DATADIR%%/lib/images/right.gif
+%%DATADIR%%/lib/images/rmx.gif
+%%DATADIR%%/lib/images/rmx_save.gif
+%%DATADIR%%/lib/images/rmy.gif
+%%DATADIR%%/lib/images/rpx.gif
+%%DATADIR%%/lib/images/rpy.gif
+%%DATADIR%%/lib/images/scaledown.gif
+%%DATADIR%%/lib/images/scaleup.gif
+%%DATADIR%%/lib/images/up.gif
+%%DATADIR%%/lib/images/FILEOPEN.BMP
+@dirrm %%DATADIR%%/lib/images
+@dirrm %%DATADIR%%/lib
+%%DATADIR%%/tcl/COPYRIGHT.tcl
+%%DATADIR%%/tcl/timestep.tcl
+%%DATADIR%%/tcl/text.tcl
+%%DATADIR%%/tcl/sphere.tcl
+%%DATADIR%%/tcl/saveimage.tcl
+%%DATADIR%%/tcl/readfile.tcl
+%%DATADIR%%/tcl/particle.tcl
+%%DATADIR%%/tcl/misc.tcl
+%%DATADIR%%/tcl/message.tcl
+%%DATADIR%%/tcl/mesh.tcl
+%%DATADIR%%/tcl/menu.tcl
+%%DATADIR%%/tcl/math.tcl
+%%DATADIR%%/tcl/material.tcl
+%%DATADIR%%/tcl/isosurface.tcl
+%%DATADIR%%/tcl/init_interrupt.tcl
+%%DATADIR%%/tcl/init.tcl
+%%DATADIR%%/tcl/group.tcl
+%%DATADIR%%/tcl/file.tcl
+%%DATADIR%%/tcl/dialog.tcl
+%%DATADIR%%/tcl/contours.tcl
+%%DATADIR%%/tcl/colorscale.tcl
+%%DATADIR%%/tcl/colormap.tcl
+%%DATADIR%%/tcl/clip.tcl
+%%DATADIR%%/tcl/camera.tcl
+%%DATADIR%%/tcl/args.tcl
+%%DATADIR%%/tcl/Makefile.in
+%%DATADIR%%/tcl/Makefile.am
+%%DATADIR%%/tcl/Makefile
+%%DATADIR%%/tcl/LoadSicopolis.tcl
+%%DATADIR%%/tcl/vectors.tcl
+@dirrm %%DATADIR%%/tcl
+%%DATADIR%%/modules/screensave.so
+%%DATADIR%%/modules/window.so
+@dirrm %%DATADIR%%/modules
+@dirrm %%DATADIR%%