aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committertijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commitd7b51d6e3b9874fae397ddfa8717c3be71d84edb (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /science
parent2739bac9ff93a8cdeb834d5da5f0c2720bad7903 (diff)
downloadfreebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.gz
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.zst
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'science')
-rw-r--r--science/colt/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/colt/Makefile b/science/colt/Makefile
index 2d88d567d086..d5bec5a20d3e 100644
--- a/science/colt/Makefile
+++ b/science/colt/Makefile
@@ -22,8 +22,8 @@ COMPILE_DESC= Install the pre-compiled .jar file
.if ${PORT_OPTIONS:MCOMPILE}
USE_ANT= yes
+USE_LOCALE= en_US.ISO8859-1
ALL_TARGET= build
-MAKE_ENV= LANG=en_US.ISO8859-1
.if ${PORT_OPTIONS:MDOCS}
ALL_TARGET+= javadoc
.endif