aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-05-14 01:14:13 +0800
committeryuri <yuri@FreeBSD.org>2018-05-14 01:14:13 +0800
commit04e7c32146e456b2325178014bea35ed435b39b5 (patch)
tree0f1e7739d43b637cb0537c16c467da55b5f69be5 /science
parentcd5c465b260319a3fb203f8268a67d15ca17db2c (diff)
downloadfreebsd-ports-gnome-04e7c32146e456b2325178014bea35ed435b39b5.tar.gz
freebsd-ports-gnome-04e7c32146e456b2325178014bea35ed435b39b5.tar.zst
freebsd-ports-gnome-04e7c32146e456b2325178014bea35ed435b39b5.zip
New port: science/py-mmtf-python: MMTF (Macromolecular Transmission Format) Python API
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-mmtf-python/Makefile29
-rw-r--r--science/py-mmtf-python/distinfo3
-rw-r--r--science/py-mmtf-python/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index e7a5c3a8f552..6f61c6a01c04 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -173,6 +173,7 @@
SUBDIR += py-hcluster
SUBDIR += py-mdp
SUBDIR += py-mlpy
+ SUBDIR += py-mmtf-python
SUBDIR += py-netCDF4
SUBDIR += py-obspy
SUBDIR += py-openpiv
diff --git a/science/py-mmtf-python/Makefile b/science/py-mmtf-python/Makefile
new file mode 100644
index 000000000000..a220342c0351
--- /dev/null
+++ b/science/py-mmtf-python/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= mmtf-python
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+CATEGORIES= science python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= MMTF (Macromolecular Transmission Format) Python API
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>0:devel/py-msgpack@${FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= rcsb
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+post-build:
+ @${RM} ${STAGEDIR}${PREFIX}/bin/sample
+
+post-plist:
+ @${REINPLACE_CMD} -e '|bin/sample|d' ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/science/py-mmtf-python/distinfo b/science/py-mmtf-python/distinfo
new file mode 100644
index 000000000000..98c0b80168ff
--- /dev/null
+++ b/science/py-mmtf-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526230432
+SHA256 (rcsb-mmtf-python-v1.1.0_GH0.tar.gz) = de2cc1692209e560002e11236070d5978a2db2faaaafa16371542b8fbd98ecac
+SIZE (rcsb-mmtf-python-v1.1.0_GH0.tar.gz) = 47054
diff --git a/science/py-mmtf-python/pkg-descr b/science/py-mmtf-python/pkg-descr
new file mode 100644
index 000000000000..6620b88af031
--- /dev/null
+++ b/science/py-mmtf-python/pkg-descr
@@ -0,0 +1,6 @@
+The python implementation of the MMTF API, decoder and encoder.
+
+The macromolecular transmission format (MMTF) is a binary encoding
+of biological structures.
+
+WWW: https://github.com/rcsb/mmtf-python