aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
commit12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5 (patch)
treeee1202c5a5464562474562e70212261185323b7d /science
parent82b2604cbc93a294ed39ce8da691d406c1342992 (diff)
downloadfreebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.gz
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.zst
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.zip
Fix build on gcc-based archs by updating USES.
Tested on powerpc64 and amd64 (for no regression). While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'science')
-rw-r--r--science/bddsolve/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/science/bddsolve/Makefile b/science/bddsolve/Makefile
index 92f9b99ba8d0..441ca5cf3a77 100644
--- a/science/bddsolve/Makefile
+++ b/science/bddsolve/Makefile
@@ -12,12 +12,11 @@ MAINTAINER= ed@FreeBSD.org
COMMENT= BDD-based satisfiability and reachability solver
BROKEN_powerpc= fails to compile due to running out of virtual memory
-BROKEN_powerpc64= fails to build: undefined reference to boost::program_options::options_description::options_description
LIB_DEPENDS+= libbdd.so:science/buddy \
libboost_program_options.so:devel/boost-libs
-USES= zip
+USES= compiler:c++11-lang zip
NO_WRKSUBDIR= yes
CFLAGS+= -I${LOCALBASE}/include -I${WRKSRC}/include
LDFLAGS+= -L${LOCALBASE}/lib -lbdd -lboost_program_options