aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2015-09-18 14:16:31 +0800
committerwen <wen@FreeBSD.org>2015-09-18 14:16:31 +0800
commit16de6639706ea6441ecd4b1d71b1a9016bf56d85 (patch)
tree8ed624404c7c9c4f7e3dbcb2cd85ceefa2a9390b /science
parentf692cf0f3e21b31609c0ba097c25364693cbc042 (diff)
downloadfreebsd-ports-gnome-16de6639706ea6441ecd4b1d71b1a9016bf56d85.tar.gz
freebsd-ports-gnome-16de6639706ea6441ecd4b1d71b1a9016bf56d85.tar.zst
freebsd-ports-gnome-16de6639706ea6441ecd4b1d71b1a9016bf56d85.zip
- Update to 0.9.r3
- Add LICENSE - Pet portlint
Diffstat (limited to 'science')
-rw-r--r--science/ghmm/Makefile18
-rw-r--r--science/ghmm/distinfo4
-rw-r--r--science/ghmm/pkg-descr2
-rw-r--r--science/ghmm/pkg-plist64
4 files changed, 44 insertions, 44 deletions
diff --git a/science/ghmm/Makefile b/science/ghmm/Makefile
index 38792e7d3da0..2fbe5d861e78 100644
--- a/science/ghmm/Makefile
+++ b/science/ghmm/Makefile
@@ -2,21 +2,23 @@
# $FreeBSD$
PORTNAME= ghmm
-PORTVERSION= 0.7.0b
-PORTREVISION= 1
+DISTVERSION= 0.9-rc3
CATEGORIES= science math
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= General Hidden Markov Model Library in C
+LICENSE= GPLv3
+
+#BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool
-USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-0.7.0
+USE_GNOME= libxml2
+USES= autoreconf libtool pkgconfig
+CONFIGURE_ARGS+= --without-python
-post-patch:
- @${REINPLACE_CMD} 's|tests doc VisualC|tests VisualC|' ${WRKSRC}/configure
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/science/ghmm/distinfo b/science/ghmm/distinfo
index 3809ff3e0409..a5835c854579 100644
--- a/science/ghmm/distinfo
+++ b/science/ghmm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ghmm-0.7.0b.tar.gz) = a1e5a6fbd2c03901da974e192780cf880feab78baa648e10f50b819801bea7ed
-SIZE (ghmm-0.7.0b.tar.gz) = 761628
+SHA256 (ghmm-0.9-rc3.tar.gz) = c42462ff4f87aadd5efe7bb6adb59657786ed71046ba924111bc28c7cbb588d0
+SIZE (ghmm-0.9-rc3.tar.gz) = 770526
diff --git a/science/ghmm/pkg-descr b/science/ghmm/pkg-descr
index 75d4acd35ea7..dae7561fbcb6 100644
--- a/science/ghmm/pkg-descr
+++ b/science/ghmm/pkg-descr
@@ -4,4 +4,4 @@ types of Hidden Markov Models and algorithms:
discrete, continous emissions, basic training,
HMM clustering, HMM mixtures.
-WWW: http://ghmm.sourceforge.net/
+WWW: http://ghmm.sourceforge.net/
diff --git a/science/ghmm/pkg-plist b/science/ghmm/pkg-plist
index 8bca96b0976b..6a7762e92e93 100644
--- a/science/ghmm/pkg-plist
+++ b/science/ghmm/pkg-plist
@@ -1,45 +1,43 @@
-bin/probdist
bin/cluster
+bin/ghmm-config
+bin/probdist
bin/scluster
bin/smix_hmm
-bin/ghmm-config
-include/ghmm/ghmm.h
+include/ghmm/cfbgibbs.h
+include/ghmm/cluster.h
+include/ghmm/discrime.h
+include/ghmm/fbgibbs.h
include/ghmm/foba.h
+include/ghmm/ghmm.h
+include/ghmm/ghmmconfig.h
+include/ghmm/gradescent.h
+include/ghmm/kbest.h
include/ghmm/model.h
-include/ghmm/cluster.h
-include/ghmm/scluster.h
-include/ghmm/root_finder.h
+include/ghmm/obsolete.h
+include/ghmm/pmodel.h
+include/ghmm/psequence.h
+include/ghmm/pviterbi.h
+include/ghmm/pviterbi_propagate.h
include/ghmm/reestimate.h
+include/ghmm/rng.h
+include/ghmm/scanner.h
+include/ghmm/scluster.h
+include/ghmm/sdfoba.h
+include/ghmm/sdmodel.h
include/ghmm/sequence.h
-include/ghmm/viterbi.h
include/ghmm/sfoba.h
-include/ghmm/sviterbi.h
-include/ghmm/smodel.h
-include/ghmm/sdmodel.h
-include/ghmm/sdfoba.h
-include/ghmm/sreestimate.h
include/ghmm/sgenerate.h
-include/ghmm/smixturehmm.h
-include/ghmm/scanner.h
-include/ghmm/gauss_tail.h
include/ghmm/smap_classify.h
-include/ghmm/kbest.h
-include/ghmm/gradescent.h
-include/ghmm/discrime.h
-include/ghmm/psequence.h
-include/ghmm/pmodel.h
-include/ghmm/linkedlist.h
-include/ghmm/pviterbi.h
-include/ghmm/pviterbi_propagate.h
-include/ghmm/vector.h
-include/ghmm/matrix.h
-include/ghmm/const.h
-include/ghmm/rng.h
-include/ghmm/mes.h
-include/ghmm/randvar.h
-include/ghmm/internal.h
+include/ghmm/smixturehmm.h
+include/ghmm/smodel.h
+include/ghmm/sreestimate.h
+include/ghmm/sviterbi.h
+include/ghmm/unsupported.h
+include/ghmm/viterbi.h
+include/ghmm/xmlreader.h
+include/ghmm/xmlwriter.h
lib/libghmm.a
lib/libghmm.so
-lib/libghmm.so.0
-lib/libghmm.so.0.0.7
-%%DATADIR%%/PHI_001_20.dat
+lib/libghmm.so.1
+lib/libghmm.so.1.0.0
+%%DATADIR%%/ghmm.dtd.1.0