aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-13 13:32:19 +0800
committeryuri <yuri@FreeBSD.org>2018-07-13 13:32:19 +0800
commit2ba55da188a834f05a295b33b347bb81bdde0a34 (patch)
treeccdf04793aed0fcb39bd01007a606ace00b4133d /science
parent935fc065b30e7ee07293fb1eb199d6168e615c2f (diff)
downloadfreebsd-ports-gnome-2ba55da188a834f05a295b33b347bb81bdde0a34.tar.gz
freebsd-ports-gnome-2ba55da188a834f05a295b33b347bb81bdde0a34.tar.zst
freebsd-ports-gnome-2ba55da188a834f05a295b33b347bb81bdde0a34.zip
science/openstructure: Fix build by using -std=c++98
The upstream recommended to use -std=c++98 to fix C++ errors on CURRENT. Also switch to USE_GITLAB. Reported by: fallout (build failure) Reported by: mat (USE_GITLAB use)
Diffstat (limited to 'science')
-rw-r--r--science/openstructure/Makefile10
-rw-r--r--science/openstructure/distinfo6
2 files changed, 10 insertions, 6 deletions
diff --git a/science/openstructure/Makefile b/science/openstructure/Makefile
index 10215238acd8..beb424be7b31 100644
--- a/science/openstructure/Makefile
+++ b/science/openstructure/Makefile
@@ -2,9 +2,8 @@
PORTNAME= openstructure
DISTVERSION= 1.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
-MASTER_SITES= https://git.scicore.unibas.ch/schwede/${PORTNAME}/repository/${DISTVERSION}/archive.tar.gz?dummy=/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Molecular modelling and visualization environment
@@ -22,6 +21,10 @@ RUN_DEPENDS= ${PYNUMPY} \
bash:shells/bash
USES= cmake:outsource eigen:3 python pyqt:4 qt:4 shebangfix
+USE_GITLAB= yes
+GL_SITE= https://git.scicore.unibas.ch/
+GL_ACCOUNT= schwede
+GL_COMMIT= ${DISTVERSION}
SHEBANG_FILES= scripts/dng.in scripts/ost.in scripts/ost_config.in
USE_QT= corelib gui network opengl xml qmake_build moc_build rcc_build uic_build
USE_PYQT= core gui
@@ -32,7 +35,8 @@ BINARY_ALIAS= python=${PYTHON_CMD}
CMAKE_ARGS= -DPYTHON_INCLUDE_PATH=${PYTHON_INCLUDEDIR} \
-DPYTHON_LIBRARIES=${PYTHON_LIBDIR} \
-DFREEBSD_BOOST_PYTHON_COMPONENT=python${PYTHON_VER:S/.//} \
- -DFREEBSD_PYTHON_LIBRARY=python${PYTHON_VER}
+ -DFREEBSD_PYTHON_LIBRARY=python${PYTHON_VER} \
+ -DCMAKE_CXX_FLAGS='-std=c++98' # c++98 is needed until 1.8.0 to prevent C++ code build breakage
post-extract:
@${MV} ${WRKSRC}-* ${WRKSRC}
diff --git a/science/openstructure/distinfo b/science/openstructure/distinfo
index 7f90ed4a2f5c..fdfc5b6d22ef 100644
--- a/science/openstructure/distinfo
+++ b/science/openstructure/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531159037
-SHA256 (openstructure-1.7.1.tar.gz) = a3715a921e3f992ae66ebdc19e6bcb161292bd83ac1302174ff33dc1fc98db50
-SIZE (openstructure-1.7.1.tar.gz) = 59275493
+TIMESTAMP = 1531459774
+SHA256 (schwede-openstructure-1.7.1_GL0.tar.gz) = a3715a921e3f992ae66ebdc19e6bcb161292bd83ac1302174ff33dc1fc98db50
+SIZE (schwede-openstructure-1.7.1_GL0.tar.gz) = 59275493