aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-04-25 03:49:57 +0800
committerthierry <thierry@FreeBSD.org>2006-04-25 03:49:57 +0800
commit615388a18961254627ee3ccd06b40aa5c41dd0c3 (patch)
tree1aea2c2f82373d4e4e07755bb0dcf0a51fc988f2 /science
parente33424deee6cffa20e395555c60af365ed048990 (diff)
downloadfreebsd-ports-gnome-615388a18961254627ee3ccd06b40aa5c41dd0c3.tar.gz
freebsd-ports-gnome-615388a18961254627ee3ccd06b40aa5c41dd0c3.tar.zst
freebsd-ports-gnome-615388a18961254627ee3ccd06b40aa5c41dd0c3.zip
Input/Output Data base interface for use in the ELMER FEM package.
Elmer is an open-source computational tool for multi-physics problems. Elmer includes physical models of fluid dynamics, structural mechanics, electromagnetics and heat transfer. These are described by partial differential equations which Elmer solves by the Finite Element Method (FEM) Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/elmer-eio/Makefile37
-rw-r--r--science/elmer-eio/distinfo3
-rw-r--r--science/elmer-eio/pkg-descr9
4 files changed, 50 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 9bea6900811c..02ea0612527a 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -17,6 +17,7 @@
SUBDIR += dcl
SUBDIR += devisor
SUBDIR += dft++
+ SUBDIR += elmer-eio
SUBDIR += elmer-meshgen2d
SUBDIR += elmergrid
SUBDIR += euler
diff --git a/science/elmer-eio/Makefile b/science/elmer-eio/Makefile
new file mode 100644
index 000000000000..48188807c228
--- /dev/null
+++ b/science/elmer-eio/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: elmer-eio
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eio
+PORTVERSION= 5.0.0
+CATEGORIES= science
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+PKGNAMEPREFIX= elmer-
+
+MAINTAINER= giffunip@asme.org
+COMMENT= ELMER FEM Package Data base Interface
+
+BUILD_DEPENDS= ${FC}:${PORTSDIR}/lang/gfortran
+
+USE_GCC= 4.1+
+WITH_FORTRAN= yes
+FC= ${LOCALBASE}/bin/gfortran41
+F77= ${FC}
+CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS=${FCFLAGS}
+
+GNU_CONFIGURE= yes
+ALL_TARGET=
+
+PLIST_FILES= include/eio_api.h lib/libeioc.a lib/libeiof.a
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+FCFLAGS+= -fPIC
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/elmer-eio/distinfo b/science/elmer-eio/distinfo
new file mode 100644
index 000000000000..23c2edd12bc6
--- /dev/null
+++ b/science/elmer-eio/distinfo
@@ -0,0 +1,3 @@
+MD5 (eio-5.0.0.tar.gz) = acc61263304b20fca85accbb81479d17
+SHA256 (eio-5.0.0.tar.gz) = 3b60e0e2989a687950b94b154fbd7ba4b1e980becd838a37686f11380aa43632
+SIZE (eio-5.0.0.tar.gz) = 147495
diff --git a/science/elmer-eio/pkg-descr b/science/elmer-eio/pkg-descr
new file mode 100644
index 000000000000..f149ad186a27
--- /dev/null
+++ b/science/elmer-eio/pkg-descr
@@ -0,0 +1,9 @@
+Input/Output Data base interface for use in the ELMER FEM package.
+
+Elmer is an open-source computational tool for multi-physics problems.
+
+Elmer includes physical models of fluid dynamics, structural mechanics,
+electromagnetics and heat transfer. These are described by partial
+differential equations which Elmer solves by the Finite Element Method (FEM)
+
+WWW: http://www.csc.fi/elmer/