aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-10-01 23:56:04 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-10-01 23:56:04 +0800
commit679e2f8a4cf02bf967ac9edb0202dfd5aab4da36 (patch)
tree3931ac6345b6992732d78e3f171393331b921def /science
parent77a0b04e070dc02934f1bbcaa6ef3720a29c4243 (diff)
downloadfreebsd-ports-gnome-679e2f8a4cf02bf967ac9edb0202dfd5aab4da36.tar.gz
freebsd-ports-gnome-679e2f8a4cf02bf967ac9edb0202dfd5aab4da36.tar.zst
freebsd-ports-gnome-679e2f8a4cf02bf967ac9edb0202dfd5aab4da36.zip
- Convert to new test framework
Diffstat (limited to 'science')
-rw-r--r--science/hdf5/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/science/hdf5/Makefile b/science/hdf5/Makefile
index c629f78b5f63..a4a821b79534 100644
--- a/science/hdf5/Makefile
+++ b/science/hdf5/Makefile
@@ -22,7 +22,7 @@ CONFLICTS_INSTALL= hdf-4.[0-9]* hdf5-1.6.[0-9]*
PORTSCOUT= skipv:1.8.15-patch1
OPTIONS_DEFINE= DEBUG EXAMPLES FORTRAN SZIP
-OPTIONS_DEFAULT=SZIP
+#OPTIONS_DEFAULT=SZIP
OPTIONS_SUB= yes
CONFIGURE_ARGS= --enable-cxx \
@@ -32,6 +32,7 @@ CONFIGURE_ARGS= --enable-cxx \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
+TEST_TARGET= check
USE_LDCONFIG= yes
USES= libtool tar:bzip2
@@ -58,7 +59,4 @@ post-patch:
`${FIND} ${WRKSRC} -regex '.*/examples/Makefile.in'`
@${REINPLACE_CMD} -e 's|\[ -a|\[ -f|g' `${FIND} ${WRKSRC} -name \*.sh\*`
-regression-test test: build
- cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
-
.include <bsd.port.mk>