aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-20 03:19:38 +0800
committeryuri <yuri@FreeBSD.org>2018-07-20 03:19:38 +0800
commit67ec5c375ad19d3b48c276f215a6be55493be6e5 (patch)
tree8cb4d9f176a81f190d4da050e6b1e03a868378ac /science
parent4a24d63931d729a694b508f48baa8e9db50921ac (diff)
downloadfreebsd-ports-gnome-67ec5c375ad19d3b48c276f215a6be55493be6e5.tar.gz
freebsd-ports-gnome-67ec5c375ad19d3b48c276f215a6be55493be6e5.tar.zst
freebsd-ports-gnome-67ec5c375ad19d3b48c276f215a6be55493be6e5.zip
New port: science/xcrysden: Crystalline and molecular structure visualisation program
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/xcrysden/Makefile33
-rw-r--r--science/xcrysden/distinfo3
-rw-r--r--science/xcrysden/files/Make.sys64
-rw-r--r--science/xcrysden/files/patch-Makefile50
-rw-r--r--science/xcrysden/pkg-descr5
-rw-r--r--science/xcrysden/pkg-plist374
7 files changed, 530 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 95c8616a2413..9be1b3e5a353 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -247,6 +247,7 @@
SUBDIR += v_sim
SUBDIR += vmd
SUBDIR += voro++
+ SUBDIR += xcrysden
SUBDIR += xfce4-equake-plugin
SUBDIR += xmakemol
diff --git a/science/xcrysden/Makefile b/science/xcrysden/Makefile
new file mode 100644
index 000000000000..516fe32ac48e
--- /dev/null
+++ b/science/xcrysden/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= xcrysden
+DISTVERSION= 1.5.60
+CATEGORIES= science
+MASTER_SITES= http://www.xcrysden.org/download/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Crystalline and molecular structure visualisation program
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfftw3.so:math/fftw3
+RUN_DEPENDS= bwidget>0:x11-toolkits/bwidget
+
+USES= fortran gmake localbase:ldflags tcl tk
+USE_GL= gl glu
+USE_XORG= x11 xmu
+
+BINARY_ALIAS= make=gmake gcc=cc gfortran=gfortran${GCC_DEFAULT}
+
+post-patch:
+ @${CP} ${FILESDIR}/Make.sys ${WRKSRC}
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/Make.sys
+ @${RM} -r ${WRKSRC}/external/src
+
+post-install:
+ @cd ${STAGEDIR}${PREFIX}/lib/${PORTNAME} && ${STRIP_CMD} xcrys xctclsh xsf2xsf
+ @${REINPLACE_CMD} -i '' -e 's|^\.|export LD_PRELOAD=/usr/local/lib/gcc${GCC_DEFAULT}/libgcc_s.so; .|' \
+ ${STAGEDIR}${PREFIX}/bin/xcrysden
+
+.include <bsd.port.mk>
diff --git a/science/xcrysden/distinfo b/science/xcrysden/distinfo
new file mode 100644
index 000000000000..18c0a8bff0d1
--- /dev/null
+++ b/science/xcrysden/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532024371
+SHA256 (xcrysden-1.5.60.tar.gz) = a695729f1bb3e486b86a74106c06a392c8aca048dc6b0f20785c3c311cfb2ef4
+SIZE (xcrysden-1.5.60.tar.gz) = 2287050
diff --git a/science/xcrysden/files/Make.sys b/science/xcrysden/files/Make.sys
new file mode 100644
index 000000000000..d238c0594a7c
--- /dev/null
+++ b/science/xcrysden/files/Make.sys
@@ -0,0 +1,64 @@
+#########################################################################
+#
+# System-dependent definitions suitable for compiling xcrysden using
+# a system shared libraries (needs Tcl/Tk/GL/GLU/FFTW libraries)
+#
+########################################################################
+
+
+#------------------------------------------------------------------------
+# if you have a GNU make it is better to set the MAKE variable to point
+# to gnu make
+#------------------------------------------------------------------------
+MAKE = make
+
+
+#------------------------------------------------------------------------
+# compilers & flags
+#------------------------------------------------------------------------
+CFLAGS = -ffast-math -funroll-loops -fPIC -DUSE_FONTS -pedantic -Wall -DUSE_INTERP_RESULT
+CC = gcc -g
+#LDLIB = -ldl
+MATH = -lm -lc
+
+FFLAGS =
+FC = gfortran -fdefault-double-8 -fdefault-real-8 -O2
+
+#-------------------------------------------
+#debug options
+#CFLAGS = -g
+#-------------------------------------------
+
+
+#------------------------------------------------------------------------
+# X-libraries & include files
+#------------------------------------------------------------------------
+X_LIB = -lXmu -lX11
+X_INCDIR =
+
+#------------------------------------------------------------------------
+#
+# Libraries
+#
+
+TCL_LIB = -L/usr/local/lib -ltcl86
+TK_LIB = -L/usr/local/lib -ltk86
+GLU_LIB = -L/usr/local/lib -lGLU
+GL_LIB = -L/usr/local/lib -lGL
+FFTW3_LIB = -L/usr/local/lib -lfftw3
+EXT_LIB = -L/usr/local/lib -lgl2ps
+# this is only used for some testing purposes
+#MESCHACH_LIB = -lmeschach
+
+#
+# Include directories
+#
+
+TCL_INCDIR = -I/usr/local/include/tcl8.6
+TK_INCDIR = -I/usr/local/include/tk8.6
+GL_INCDIR = -I/usr/local/include
+FFTW3_INCDIR = -I/usr/local/include
+# this is only used for some testing purposes
+#MESCHACH_INCDIR =
+
+#------------------------------------------------------------------------
diff --git a/science/xcrysden/files/patch-Makefile b/science/xcrysden/files/patch-Makefile
new file mode 100644
index 000000000000..7505e31b6054
--- /dev/null
+++ b/science/xcrysden/files/patch-Makefile
@@ -0,0 +1,50 @@
+--- Makefile.orig 2014-06-25 21:07:29 UTC
++++ Makefile
+@@ -228,7 +228,7 @@ BIN_FILES = bin/
+
+ prefix ?= /usr/local
+ version := $(shell cat version)
+-xcrysden = xcrysden-$(version)
++xcrysden = xcrysden
+
+ install: xcrysden
+ @echo
+@@ -238,27 +238,27 @@ install: xcrysden
+ @echo "# "
+ @echo "#-----"
+ @echo
+- install -m755 -d $(prefix)/share/$(xcrysden)
+- cp -a $(IRON_ITEMS) $(prefix)/share/$(xcrysden)
++ install -m755 -d $(DESTDIR)$(prefix)/share/$(xcrysden)
++ cp -a $(IRON_ITEMS) $(DESTDIR)$(prefix)/share/$(xcrysden)
+ \
+ for subdir in Awk examples $(EXTERNAL_LIB_BWIDGET) images scripts Tcl util; do \
+ if test -d $$subdir; then \
+- install -m755 -d $(prefix)/share/$(xcrysden)/$$subdir; \
+- cp -a $$subdir/* $(prefix)/share/$(xcrysden)/$$subdir; \
++ install -m755 -d $(DESTDIR)$(prefix)/share/$(xcrysden)/$$subdir; \
++ cp -a $$subdir/* $(DESTDIR)$(prefix)/share/$(xcrysden)/$$subdir; \
+ fi; \
+ done
+ \
+- install -m755 -d $(prefix)/share/man/man1
+- install -m644 $(MAN_FILES) $(prefix)/share/man/man1/
+- gzip -f $(addprefix $(prefix)/share/man/man1/,$(MAN_PAGES))
++ install -m755 -d $(DESTDIR)$(prefix)/man/man1
++ install -m644 $(MAN_FILES) $(DESTDIR)$(prefix)/man/man1/
++ gzip -f $(addprefix $(DESTDIR)$(prefix)/man/man1/,$(MAN_PAGES))
+ \
+- install -m755 -d $(prefix)/lib/$(xcrysden)
+- install -m755 bin/* $(prefix)/lib/$(xcrysden)/
++ install -m755 -d $(DESTDIR)$(prefix)/lib/$(xcrysden)
++ install -m755 bin/* $(DESTDIR)$(prefix)/lib/$(xcrysden)/
+ \
+ prefix=$(prefix) xcrysden=$(xcrysden) sh sys_utils/wrappers.sh
+- if test ! -d $(prefix)/bin; then install -m755 -d $(prefix)/bin; fi
++ if test ! -d $(DESTDIR)$(prefix)/bin; then install -m755 -d $(DESTDIR)$(prefix)/bin; fi
+ for prog in $(PROGS); do \
+- install -m755 $$prog.wrapper $(prefix)/bin/$$prog; \
++ install -m755 $$prog.wrapper $(DESTDIR)$(prefix)/bin/$$prog; \
+ done
+
+
diff --git a/science/xcrysden/pkg-descr b/science/xcrysden/pkg-descr
new file mode 100644
index 000000000000..8b7c2967b391
--- /dev/null
+++ b/science/xcrysden/pkg-descr
@@ -0,0 +1,5 @@
+XCrySDen is a crystalline and molecular structure visualisation program aiming
+at display of isosurfaces and contours, which can be superimposed on crystalline
+structures and interactively rotated and manipulated.
+
+WWW: http://www.xcrysden.org/
diff --git a/science/xcrysden/pkg-plist b/science/xcrysden/pkg-plist
new file mode 100644
index 000000000000..5ee893857657
--- /dev/null
+++ b/science/xcrysden/pkg-plist
@@ -0,0 +1,374 @@
+bin/ptable
+bin/pwi2xsf
+bin/pwo2xsf
+bin/unitconv
+bin/xcrysden
+lib/xcrysden/atomlab
+lib/xcrysden/calplane
+lib/xcrysden/cube2xsf
+lib/xcrysden/fhi_coord2xcr
+lib/xcrysden/fhi_inpini2ftn34
+lib/xcrysden/fracCoor
+lib/xcrysden/fsReadBXSF
+lib/xcrysden/ftnunit
+lib/xcrysden/gengeom
+lib/xcrysden/kPath
+lib/xcrysden/multislab
+lib/xcrysden/nn
+lib/xcrysden/pwKPath
+lib/xcrysden/pwi2xsf
+lib/xcrysden/pwi2xsf_old
+lib/xcrysden/recvec
+lib/xcrysden/savestruct
+lib/xcrysden/str2xcr
+lib/xcrysden/wn_readbakgen
+lib/xcrysden/wn_readbands
+lib/xcrysden/xcrys
+lib/xcrysden/xctclsh
+lib/xcrysden/xsf2xsf
+man/man1/ptable.1.gz
+man/man1/pwi2xsf.1.gz
+man/man1/pwo2xsf.1.gz
+man/man1/unitconv.1.gz
+man/man1/xcrysden.1.gz
+%%DATADIR%%/Awk/getOV.awk
+%%DATADIR%%/Awk/ginp.awk
+%%DATADIR%%/Awk/in1.awk
+%%DATADIR%%/Awk/pwo_coortype.awk
+%%DATADIR%%/Tcl/Grapher.tcl
+%%DATADIR%%/Tcl/Makefile
+%%DATADIR%%/Tcl/Viewer.tcl
+%%DATADIR%%/Tcl/Xcrysden_resources
+%%DATADIR%%/Tcl/addOption.tcl
+%%DATADIR%%/Tcl/advGeom.tcl
+%%DATADIR%%/Tcl/advGeom2.tcl
+%%DATADIR%%/Tcl/atomLabels.tcl
+%%DATADIR%%/Tcl/auxil.tcl
+%%DATADIR%%/Tcl/band.tcl
+%%DATADIR%%/Tcl/bar.tcl
+%%DATADIR%%/Tcl/bwid.tcl
+%%DATADIR%%/Tcl/bxsfOpen.tcl
+%%DATADIR%%/Tcl/bz.tcl
+%%DATADIR%%/Tcl/check_package.tcl
+%%DATADIR%%/Tcl/colormenu.tcl
+%%DATADIR%%/Tcl/colors.tcl
+%%DATADIR%%/Tcl/configGrapher.tcl
+%%DATADIR%%/Tcl/custom-definitions
+%%DATADIR%%/Tcl/cxxAdvGeom.tcl
+%%DATADIR%%/Tcl/cygwin.tcl
+%%DATADIR%%/Tcl/difIsoSurf.tcl
+%%DATADIR%%/Tcl/dispModes.tcl
+%%DATADIR%%/Tcl/dos.tcl
+%%DATADIR%%/Tcl/dumpWindow.tcl
+%%DATADIR%%/Tcl/edit.tcl
+%%DATADIR%%/Tcl/fhiPreset.tcl
+%%DATADIR%%/Tcl/fileselect.tcl
+%%DATADIR%%/Tcl/find_package.tcl
+%%DATADIR%%/Tcl/fontWidget.tcl
+%%DATADIR%%/Tcl/forces.tcl
+%%DATADIR%%/Tcl/fs/FS_Main.tcl
+%%DATADIR%%/Tcl/fs/FS_Multi.tcl
+%%DATADIR%%/Tcl/fs/Makefile
+%%DATADIR%%/Tcl/fs/bandselect.tcl
+%%DATADIR%%/Tcl/fs/bandwidths.tcl
+%%DATADIR%%/Tcl/fs/genFSInit.tcl
+%%DATADIR%%/Tcl/fs/header.tcl
+%%DATADIR%%/Tcl/fs/interpolate.tcl
+%%DATADIR%%/Tcl/fs/tclIndex
+%%DATADIR%%/Tcl/fs/toolbox.tcl
+%%DATADIR%%/Tcl/fs/wnFS.tcl
+%%DATADIR%%/Tcl/fs/wnFSInit.tcl
+%%DATADIR%%/Tcl/fs/wnReadStruct.tcl
+%%DATADIR%%/Tcl/g98.tcl
+%%DATADIR%%/Tcl/genWidget.tcl
+%%DATADIR%%/Tcl/gengeom.tcl
+%%DATADIR%%/Tcl/gifAnim.tcl
+%%DATADIR%%/Tcl/glLight.tcl
+%%DATADIR%%/Tcl/glModParam.tcl
+%%DATADIR%%/Tcl/go2crys.tcl
+%%DATADIR%%/Tcl/grid.tcl
+%%DATADIR%%/Tcl/groupSel.tcl
+%%DATADIR%%/Tcl/groups.tcl
+%%DATADIR%%/Tcl/gzmat.tcl
+%%DATADIR%%/Tcl/hbonds.tcl
+%%DATADIR%%/Tcl/header.tcl
+%%DATADIR%%/Tcl/isoControl.tcl
+%%DATADIR%%/Tcl/isoRender.tcl
+%%DATADIR%%/Tcl/isoStuff.tcl
+%%DATADIR%%/Tcl/kLabels.tcl
+%%DATADIR%%/Tcl/kPath.tcl
+%%DATADIR%%/Tcl/loadAttributes.tcl
+%%DATADIR%%/Tcl/menu.tcl
+%%DATADIR%%/Tcl/modAtomAtrib.tcl
+%%DATADIR%%/Tcl/modify.tcl
+%%DATADIR%%/Tcl/movieEncoders.tcl
+%%DATADIR%%/Tcl/movieMaker.tcl
+%%DATADIR%%/Tcl/mpegParam.tcl
+%%DATADIR%%/Tcl/multiWid.tcl
+%%DATADIR%%/Tcl/newInput.tcl
+%%DATADIR%%/Tcl/number.tcl
+%%DATADIR%%/Tcl/openExtStruct.tcl
+%%DATADIR%%/Tcl/openGLpar.tcl
+%%DATADIR%%/Tcl/openInput.tcl
+%%DATADIR%%/Tcl/parseComLinArg.tcl
+%%DATADIR%%/Tcl/parseDataGrid.tcl
+%%DATADIR%%/Tcl/planeselect.tcl
+%%DATADIR%%/Tcl/popupMenu.tcl
+%%DATADIR%%/Tcl/print.tcl
+%%DATADIR%%/Tcl/printCanvas.tcl
+%%DATADIR%%/Tcl/propC95.tcl
+%%DATADIR%%/Tcl/propInit.tcl
+%%DATADIR%%/Tcl/propertyPlane.tcl
+%%DATADIR%%/Tcl/pseudoDen.tcl
+%%DATADIR%%/Tcl/ptable.tcl
+%%DATADIR%%/Tcl/pwPreset.tcl
+%%DATADIR%%/Tcl/read25.tcl
+%%DATADIR%%/Tcl/readParam.tcl
+%%DATADIR%%/Tcl/runC95.tcl
+%%DATADIR%%/Tcl/sInfo.tcl
+%%DATADIR%%/Tcl/saveState.tcl
+%%DATADIR%%/Tcl/scripting.tcl
+%%DATADIR%%/Tcl/scriptingAtomicLabels.tcl
+%%DATADIR%%/Tcl/scriptingFilter.tcl
+%%DATADIR%%/Tcl/scriptingMakeMovie.tcl
+%%DATADIR%%/Tcl/scriptingScalarField2D.tcl
+%%DATADIR%%/Tcl/scriptingScalarField3D.tcl
+%%DATADIR%%/Tcl/scroll.tcl
+%%DATADIR%%/Tcl/selection.tcl
+%%DATADIR%%/Tcl/setIsosurfArray.tcl
+%%DATADIR%%/Tcl/sizes.tcl
+%%DATADIR%%/Tcl/state.tcl
+%%DATADIR%%/Tcl/stereo.tcl
+%%DATADIR%%/Tcl/tclIndex
+%%DATADIR%%/Tcl/test.tcl
+%%DATADIR%%/Tcl/thermometer.tcl
+%%DATADIR%%/Tcl/toglZoom.tcl
+%%DATADIR%%/Tcl/undoAdvGeom.tcl
+%%DATADIR%%/Tcl/unmapWin.tcl
+%%DATADIR%%/Tcl/wigner.tcl
+%%DATADIR%%/Tcl/wnDensity.tcl
+%%DATADIR%%/Tcl/wnDetComOpt.tcl
+%%DATADIR%%/Tcl/wnKPath.tcl
+%%DATADIR%%/Tcl/wnMultiSlab.tcl
+%%DATADIR%%/Tcl/wnOpen.tcl
+%%DATADIR%%/Tcl/wnRunWIEN.tcl
+%%DATADIR%%/Tcl/wnSaveSFile.tcl
+%%DATADIR%%/Tcl/xcAbout.tcl
+%%DATADIR%%/Tcl/xcInit.tcl
+%%DATADIR%%/Tcl/xcInitLib.tcl
+%%DATADIR%%/Tcl/xctr.tcl
+%%DATADIR%%/Tcl/xsfAnim.tcl
+%%DATADIR%%/Tcl/xsfOpen.tcl
+%%DATADIR%%/Tcl/xyz.tcl
+%%DATADIR%%/examples/CRYSTALxx_input_files/Pt322.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/Pt_fcc.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/ZnS.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/argonite.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/calcite.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/chabazite.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/cluster.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/corundum.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/cuprite.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/graphite.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/mgo.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/polymer.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/pyrite.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/rutile.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/urea.r1
+%%DATADIR%%/examples/CRYSTALxx_input_files/zro2.r1
+%%DATADIR%%/examples/FHI98MD_files/GaAsSurface_coord.out
+%%DATADIR%%/examples/FHI98MD_files/GaAsSurface_inp.ini
+%%DATADIR%%/examples/FHI98MD_files/GaAs_inp.ini
+%%DATADIR%%/examples/FermiSurface/MgB2.bxsf.gz
+%%DATADIR%%/examples/FermiSurface/RhBulkFcc.bxsf.gz
+%%DATADIR%%/examples/GAUSSIAN_files/N2O_homo+lumo.cube.gz
+%%DATADIR%%/examples/GAUSSIAN_files/benzene-6CH3-OCH3.g98
+%%DATADIR%%/examples/GAUSSIAN_files/benzene.g98_out
+%%DATADIR%%/examples/Makefile
+%%DATADIR%%/examples/PDB/bucky.pdb
+%%DATADIR%%/examples/PDB/cluster.pdb
+%%DATADIR%%/examples/PDB/mol2.pdb
+%%DATADIR%%/examples/PWSCF_files/CH3Rh111.inp
+%%DATADIR%%/examples/PWSCF_files/CH3Rh111.out
+%%DATADIR%%/examples/PWSCF_files/EthAl001-2x2.inp
+%%DATADIR%%/examples/PWSCF_files/EthAl001-2x2.out
+%%DATADIR%%/examples/README
+%%DATADIR%%/examples/Scripting/ZnS_molsurf.xcrysden
+%%DATADIR%%/examples/Scripting/animation.tcl
+%%DATADIR%%/examples/Scripting/atomic_labels.tcl
+%%DATADIR%%/examples/Scripting/build_crystal.tcl
+%%DATADIR%%/examples/Scripting/build_crystal.tcl.bck
+%%DATADIR%%/examples/Scripting/colorplane_animation.tcl
+%%DATADIR%%/examples/Scripting/colorplane_animation.tcl.bck
+%%DATADIR%%/examples/Scripting/contours.tcl
+%%DATADIR%%/examples/Scripting/contours.tcl.bck
+%%DATADIR%%/examples/Scripting/g98cube.tcl
+%%DATADIR%%/examples/Scripting/g98cube_multiScript.tcl
+%%DATADIR%%/examples/Scripting/isosurface+colorplane+print.tcl
+%%DATADIR%%/examples/Scripting/isosurface+colorplane+print.tcl.bck
+%%DATADIR%%/examples/Scripting/movie.tcl
+%%DATADIR%%/examples/Scripting/multiScript.tcl
+%%DATADIR%%/examples/Scripting/multiScript.tcl.bck
+%%DATADIR%%/examples/Scripting/plot_all_MO.sh
+%%DATADIR%%/examples/Scripting/pw_filters.tcl
+%%DATADIR%%/examples/Scripting/pwofilter.tcl
+%%DATADIR%%/examples/WIEN_struct_files/a-quartz.struct
+%%DATADIR%%/examples/WIEN_struct_files/al2o3.struct
+%%DATADIR%%/examples/WIEN_struct_files/b12.struct
+%%DATADIR%%/examples/WIEN_struct_files/bi.struct
+%%DATADIR%%/examples/WIEN_struct_files/cab6.struct
+%%DATADIR%%/examples/WIEN_struct_files/cd16te15sb.struct
+%%DATADIR%%/examples/WIEN_struct_files/cd8te7sb.struct
+%%DATADIR%%/examples/WIEN_struct_files/coo.struct
+%%DATADIR%%/examples/WIEN_struct_files/cos2.struct
+%%DATADIR%%/examples/WIEN_struct_files/cr2o3.struct
+%%DATADIR%%/examples/WIEN_struct_files/crb2.struct
+%%DATADIR%%/examples/WIEN_struct_files/fe2p.struct
+%%DATADIR%%/examples/WIEN_struct_files/fe4n.struct
+%%DATADIR%%/examples/WIEN_struct_files/fecl2.struct
+%%DATADIR%%/examples/WIEN_struct_files/fef2.struct
+%%DATADIR%%/examples/WIEN_struct_files/ferrocen.struct
+%%DATADIR%%/examples/WIEN_struct_files/gaas.struct
+%%DATADIR%%/examples/WIEN_struct_files/in2o3.struct
+%%DATADIR%%/examples/WIEN_struct_files/mos2.struct
+%%DATADIR%%/examples/WIEN_struct_files/pt.struct
+%%DATADIR%%/examples/WIEN_struct_files/si111.struct
+%%DATADIR%%/examples/WIEN_struct_files/tellur.struct
+%%DATADIR%%/examples/WIEN_struct_files/ybco7.struct
+%%DATADIR%%/examples/WIEN_struct_files/yfe2.struct
+%%DATADIR%%/examples/XSF_Files/1.xsf
+%%DATADIR%%/examples/XSF_Files/1symb.xsf
+%%DATADIR%%/examples/XSF_Files/2.xsf
+%%DATADIR%%/examples/XSF_Files/ANIM.axsf
+%%DATADIR%%/examples/XSF_Files/ANIMsymb.axsf
+%%DATADIR%%/examples/XSF_Files/CO_homo.xsf.gz
+%%DATADIR%%/examples/XSF_Files/CO_lumo.xsf.gz
+%%DATADIR%%/examples/XSF_Files/GaAsH.xsf
+%%DATADIR%%/examples/XSF_Files/README
+%%DATADIR%%/examples/XSF_Files/ZnS.xsf
+%%DATADIR%%/examples/XSF_Files/ZnS_variable-cell.axsf
+%%DATADIR%%/examples/XSF_Files/bucky.xsf
+%%DATADIR%%/examples/XSF_Files/c2h4:Ag001.xsf
+%%DATADIR%%/examples/XSF_Files/fcc-410-1x1.xsf
+%%DATADIR%%/examples/XSF_Files/mol-urea.xsf.gz
+%%DATADIR%%/examples/XSF_Files/mol-urea2D.xsf
+%%DATADIR%%/examples/XSF_Files/oxirane_homo.xsf.gz
+%%DATADIR%%/examples/XSF_Files/vector_field.xsf
+%%DATADIR%%/examples/XSF_Files/zro2cluster.xsf
+%%DATADIR%%/examples/XYZ/anim.xyz
+%%DATADIR%%/examples/XYZ/bucky.xyz
+%%DATADIR%%/examples/XYZ/mol1.xyz
+%%DATADIR%%/examples/XYZ/mol2.xyz
+%%DATADIR%%/images/ak.gif
+%%DATADIR%%/images/backward.gif
+%%DATADIR%%/images/ballsticks1_2d.gif
+%%DATADIR%%/images/ballsticks2_2d.gif
+%%DATADIR%%/images/ballsticks_3d.gif
+%%DATADIR%%/images/bold.xbm
+%%DATADIR%%/images/bz.gif
+%%DATADIR%%/images/camera-photo.gif
+%%DATADIR%%/images/cell.gif
+%%DATADIR%%/images/center1.gif
+%%DATADIR%%/images/center_nice.gif
+%%DATADIR%%/images/datagrid.gif
+%%DATADIR%%/images/dm_anaglyph.gif
+%%DATADIR%%/images/dm_flat.gif
+%%DATADIR%%/images/dm_smooth.gif
+%%DATADIR%%/images/dm_solid.gif
+%%DATADIR%%/images/dm_stereo.gif
+%%DATADIR%%/images/dm_wire.gif
+%%DATADIR%%/images/dot1x3H.bmp
+%%DATADIR%%/images/dot1x3V.bmp
+%%DATADIR%%/images/dotH.bmp
+%%DATADIR%%/images/dotV.bmp
+%%DATADIR%%/images/down.gif
+%%DATADIR%%/images/down1.gif
+%%DATADIR%%/images/first.gif
+%%DATADIR%%/images/forward.gif
+%%DATADIR%%/images/italic.xbm
+%%DATADIR%%/images/jpaint.gif
+%%DATADIR%%/images/last.gif
+%%DATADIR%%/images/left1.gif
+%%DATADIR%%/images/mini-colors.gif
+%%DATADIR%%/images/next.gif
+%%DATADIR%%/images/nocell.gif
+%%DATADIR%%/images/nocrop.gif
+%%DATADIR%%/images/overstrike.xbm
+%%DATADIR%%/images/pause.gif
+%%DATADIR%%/images/pipeballs_2d.gif
+%%DATADIR%%/images/pipeballs_3d.gif
+%%DATADIR%%/images/pointlines_2d.gif
+%%DATADIR%%/images/previous.gif
+%%DATADIR%%/images/printer.gif
+%%DATADIR%%/images/rep_asym.gif
+%%DATADIR%%/images/rep_unit.gif
+%%DATADIR%%/images/right.gif
+%%DATADIR%%/images/right1.gif
+%%DATADIR%%/images/rotAB.gif
+%%DATADIR%%/images/rotAC.gif
+%%DATADIR%%/images/rotBC.gif
+%%DATADIR%%/images/rotXY1.gif
+%%DATADIR%%/images/rotXZ1.gif
+%%DATADIR%%/images/rotXmin.gif
+%%DATADIR%%/images/rotXplus.gif
+%%DATADIR%%/images/rotYZ1.gif
+%%DATADIR%%/images/rotYmin.gif
+%%DATADIR%%/images/rotYplus.gif
+%%DATADIR%%/images/rotZmin.gif
+%%DATADIR%%/images/rotZplus.gif
+%%DATADIR%%/images/solidcell.gif
+%%DATADIR%%/images/solidwirecell.gif
+%%DATADIR%%/images/spacefills_2d.gif
+%%DATADIR%%/images/spacefills_3d.gif
+%%DATADIR%%/images/sticks_3d.gif
+%%DATADIR%%/images/stop.gif
+%%DATADIR%%/images/underline.xbm
+%%DATADIR%%/images/unmap-C95output.gif
+%%DATADIR%%/images/unmap-empty.gif
+%%DATADIR%%/images/unmap-isosurface.gif
+%%DATADIR%%/images/unmap.gif
+%%DATADIR%%/images/up.gif
+%%DATADIR%%/images/up1.gif
+%%DATADIR%%/images/wait.xbm
+%%DATADIR%%/images/wirecell.gif
+%%DATADIR%%/images/wireframes_2d.gif
+%%DATADIR%%/images/xcAbout.gif
+%%DATADIR%%/images/xcMenuEntry_down.xbm
+%%DATADIR%%/images/xcMenuEntry_up.xbm
+%%DATADIR%%/images/xcPrintCanvas_left.xbm
+%%DATADIR%%/images/xcPrintCanvas_right.xbm
+%%DATADIR%%/images/xcrysden-welcome.gif
+%%DATADIR%%/images/xcrysden.gif
+%%DATADIR%%/images/xcrysden.png
+%%DATADIR%%/images/xcrysden.xbm
+%%DATADIR%%/images/xcrysden.xpm
+%%DATADIR%%/images/xcrysden_big.gif
+%%DATADIR%%/images/xcrysden_kpath.gif
+%%DATADIR%%/images/xcrysden_mask.xbm
+%%DATADIR%%/images/zoomdown.gif
+%%DATADIR%%/images/zoomup.gif
+%%DATADIR%%/images/zoomup.xbm
+%%DATADIR%%/scripts/dummy.sh
+%%DATADIR%%/scripts/g98toxsf.sh
+%%DATADIR%%/scripts/gzmat2xsf.sh
+%%DATADIR%%/scripts/launch.sh
+%%DATADIR%%/scripts/pwGetNC.sh
+%%DATADIR%%/scripts/pwLib_old.sh
+%%DATADIR%%/scripts/pwd.sh
+%%DATADIR%%/scripts/pwi2xsf.sh
+%%DATADIR%%/scripts/pwo2xsf.sh
+%%DATADIR%%/scripts/pwo2xsf_anim.awk
+%%DATADIR%%/scripts/pwo2xsf_neb.awk
+%%DATADIR%%/scripts/pwo2xsf_old.sh
+%%DATADIR%%/scripts/pwo2xsf_opt.awk
+%%DATADIR%%/scripts/xcConfigure.sh
+%%DATADIR%%/scripts/xcConfigure_definitions.sh
+%%DATADIR%%/scripts/xcConfigure_updateProfile.sh
+%%DATADIR%%/scripts/xcLib.sh
+%%DATADIR%%/scripts/xc_cleanscratch
+%%DATADIR%%/usage
+%%DATADIR%%/util/ptable
+%%DATADIR%%/util/tcl_index
+%%DATADIR%%/util/unitconv
+%%DATADIR%%/version
+%%DATADIR%%/xcrysden