aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-13 17:24:52 +0800
committeryuri <yuri@FreeBSD.org>2018-07-13 17:24:52 +0800
commit7078f8c8c8814e339d01eed09b2516bbe9c57d69 (patch)
tree8a26871586111eb8dca5d236c70768819d20cc96 /science
parent58f4e274636130e281f74b0d9668d712d583a11a (diff)
downloadfreebsd-ports-gnome-7078f8c8c8814e339d01eed09b2516bbe9c57d69.tar.gz
freebsd-ports-gnome-7078f8c8c8814e339d01eed09b2516bbe9c57d69.tar.zst
freebsd-ports-gnome-7078f8c8c8814e339d01eed09b2516bbe9c57d69.zip
science/openstructure: Add USE_CXXSTD=c++98; Use MASTER_SITES instead of USE_GITLAB
USE_GITLAB doesn't work in this case because it requires GL_COMMIT while only DISTVERSION should be sufficient. USE_CXXSTD=c++98 is used because -DCMAKE_CXX_FLAGS='-std=c++98' os overridden. Reported by: tobik
Diffstat (limited to 'science')
-rw-r--r--science/openstructure/Makefile12
-rw-r--r--science/openstructure/distinfo6
2 files changed, 8 insertions, 10 deletions
diff --git a/science/openstructure/Makefile b/science/openstructure/Makefile
index beb424be7b31..d1c4eeafcc6e 100644
--- a/science/openstructure/Makefile
+++ b/science/openstructure/Makefile
@@ -2,8 +2,9 @@
PORTNAME= openstructure
DISTVERSION= 1.7.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science
+MASTER_SITES= https://git.scicore.unibas.ch/schwede/${PORTNAME}/repository/${DISTVERSION}/archive.tar.gz?dummy=/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Molecular modelling and visualization environment
@@ -21,10 +22,6 @@ RUN_DEPENDS= ${PYNUMPY} \
bash:shells/bash
USES= cmake:outsource eigen:3 python pyqt:4 qt:4 shebangfix
-USE_GITLAB= yes
-GL_SITE= https://git.scicore.unibas.ch/
-GL_ACCOUNT= schwede
-GL_COMMIT= ${DISTVERSION}
SHEBANG_FILES= scripts/dng.in scripts/ost.in scripts/ost_config.in
USE_QT= corelib gui network opengl xml qmake_build moc_build rcc_build uic_build
USE_PYQT= core gui
@@ -35,8 +32,9 @@ BINARY_ALIAS= python=${PYTHON_CMD}
CMAKE_ARGS= -DPYTHON_INCLUDE_PATH=${PYTHON_INCLUDEDIR} \
-DPYTHON_LIBRARIES=${PYTHON_LIBDIR} \
-DFREEBSD_BOOST_PYTHON_COMPONENT=python${PYTHON_VER:S/.//} \
- -DFREEBSD_PYTHON_LIBRARY=python${PYTHON_VER} \
- -DCMAKE_CXX_FLAGS='-std=c++98' # c++98 is needed until 1.8.0 to prevent C++ code build breakage
+ -DFREEBSD_PYTHON_LIBRARY=python${PYTHON_VER}
+
+USE_CXXSTD=c++98 # c++98 is needed until 1.8.0 to prevent C++ code build breakage
post-extract:
@${MV} ${WRKSRC}-* ${WRKSRC}
diff --git a/science/openstructure/distinfo b/science/openstructure/distinfo
index fdfc5b6d22ef..158018f0973f 100644
--- a/science/openstructure/distinfo
+++ b/science/openstructure/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531459774
-SHA256 (schwede-openstructure-1.7.1_GL0.tar.gz) = a3715a921e3f992ae66ebdc19e6bcb161292bd83ac1302174ff33dc1fc98db50
-SIZE (schwede-openstructure-1.7.1_GL0.tar.gz) = 59275493
+TIMESTAMP = 1531473520
+SHA256 (openstructure-1.7.1.tar.gz) = a3715a921e3f992ae66ebdc19e6bcb161292bd83ac1302174ff33dc1fc98db50
+SIZE (openstructure-1.7.1.tar.gz) = 59275493