aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
committermat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
commit79c3ac81e82fba101ce34956c5de634b8ed032d0 (patch)
treeaa20f69168c1d6c9e0dbf200cc417eb6ea9147ca /science
parent89ac30bfd79e5d0fe14f37fae8ce263170a2af2d (diff)
downloadfreebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.gz
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.zst
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.zip
Remove all := from BUILD_DEPENDS, here are never needed.
While there, cleanup, and sort depends. When build and run dependencies are the same, there are three ways to avoid duplicating the list while not adding the framework added BUILD_DEPENDS to the RUN_DEPENDS. In order of preference, they are: 1) use RUN_DEPENDS to set BUILD_DEPENDS: BUILD_DEPENDS= ${RUN_DEPENDS} RUN_DEPENDS= foo:bar/baz 2) create another variable and use it: MY_DEPENDS= foo:bar/baz BUILD_DEPENDS= ${MY_DEPENDS} RUN_DEPENDS= ${MY_DEPENDS} 3) use BUILD_DEPENDS to set RUN_DEPENDS and force evaluation: BUILD_DEPENDS= foo:bar/baz RUN_DEPENDS:= ${BUILD_DEPENDS} Sponsored by: Absolight
Diffstat (limited to 'science')
-rw-r--r--science/py-veusz/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/py-veusz/Makefile b/science/py-veusz/Makefile
index 3d3e0804994c..009ce9b26d11 100644
--- a/science/py-veusz/Makefile
+++ b/science/py-veusz/Makefile
@@ -14,8 +14,8 @@ COMMENT= Scientific plotting package
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= ${PYNUMPY}
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= python pyqt:4 qt:4 shebangfix
USE_PYQT= gui svg