aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-07 11:18:42 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-07 11:18:42 +0800
commit7f34c0bef9526cc4c7c8665f7c012d457a750d07 (patch)
tree7beddb80b9e19fbcc70bbf788061d06de8eb8eb4 /science
parent341e9b3cf5055cd0a1fb4c8f8f307168c51d547e (diff)
downloadfreebsd-ports-gnome-7f34c0bef9526cc4c7c8665f7c012d457a750d07.tar.gz
freebsd-ports-gnome-7f34c0bef9526cc4c7c8665f7c012d457a750d07.tar.zst
freebsd-ports-gnome-7f34c0bef9526cc4c7c8665f7c012d457a750d07.zip
- Add LICENSE
- Fix library installation - Pet portlint
Diffstat (limited to 'science')
-rw-r--r--science/svmlight/Makefile10
-rw-r--r--science/svmlight/pkg-descr2
2 files changed, 9 insertions, 3 deletions
diff --git a/science/svmlight/Makefile b/science/svmlight/Makefile
index 3010f303b59c..29176dc0ef95 100644
--- a/science/svmlight/Makefile
+++ b/science/svmlight/Makefile
@@ -3,6 +3,7 @@
PORTNAME= svmlight
PORTVERSION= 6.02
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://osmot.cs.cornell.edu/svm_light/v${PORTVERSION}/
DISTNAME= svm_light
@@ -11,6 +12,11 @@ PATCH_SITES= http://cpansearch.perl.org/src/KWILLIAMS/Algorithm-SVMLight-0.09/
PATCHFILES= SVMLight.patch
PATCH_DIST_STRIP=-p1
+LICENSE= SVM-Light
+LICENSE_NAME= SVM-Light license
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_PERMS= # none
+
MAINTAINER= ports@FreeBSD.org
COMMENT= Implementation of Support Vector Machines (SVMs) in C
@@ -31,8 +37,8 @@ do-install:
.for file in svm_classify svm_learn
${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${INSTALL_DATA} ${WRKSRC}/libsvmlight.* ${STAGEDIR}${PREFIX}/lib
- ${MV} ${STAGEDIR}${PREFIX}/lib/libsvmlight.so ${STAGEDIR}${PREFIX}/lib/libsvmlight.so.1
+ ${INSTALL_DATA} ${WRKSRC}/libsvmlight.a ${STAGEDIR}${PREFIX}/lib/
+ ${INSTALL_LIB} ${WRKSRC}/libsvmlight.so ${STAGEDIR}${PREFIX}/lib/libsvmlight.so.1
${LN} -s libsvmlight.so.1 ${STAGEDIR}${PREFIX}/lib/libsvmlight.so
# It's license request, do not remove
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/science/svmlight/pkg-descr b/science/svmlight/pkg-descr
index d8720ac619ea..8f73662107aa 100644
--- a/science/svmlight/pkg-descr
+++ b/science/svmlight/pkg-descr
@@ -15,4 +15,4 @@ unbiased estimates provides leave-one-out testing. SVMlight exploits
that the results of most leave-one-outs (often more than 99%) are
predetermined and need not be computed [Joachims, 2002a].
-WWW: http://svmlight.joachims.org/
+WWW: http://svmlight.joachims.org/