aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-07-21 05:23:16 +0800
committertcberner <tcberner@FreeBSD.org>2018-07-21 05:23:16 +0800
commit821ad3068ac103a94e5adfe3ba3e27a05926c972 (patch)
treec81738007324cc6ca8a269952c91ed8c20058142 /science
parent0863a558c0f3b2d629dd5b64834a3e00cd3041f4 (diff)
downloadfreebsd-ports-gnome-821ad3068ac103a94e5adfe3ba3e27a05926c972.tar.gz
freebsd-ports-gnome-821ad3068ac103a94e5adfe3ba3e27a05926c972.tar.zst
freebsd-ports-gnome-821ad3068ac103a94e5adfe3ba3e27a05926c972.zip
science/paraview: Add patch to fix build with upcomeing cmake-3.12
The behaviour of cmake's copy_directory was changed, so that it now fails if the source directory does not exist. Further add missing dependency on xmlpatterns. PR: 229854 Reported by: antoine
Diffstat (limited to 'science')
-rw-r--r--science/paraview/Makefile3
-rw-r--r--science/paraview/files/patch-CMake_ParaViewMacros.cmake12
2 files changed, 14 insertions, 1 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 3a76db318b30..2b415671574a 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -3,6 +3,7 @@
PORTNAME= paraview
DISTVERSION= 5.5.1
+PORTREVISION= 1
CATEGORIES= science graphics
MASTER_SITES= http://www.paraview.org/files/v${VERMAJORMINOR}/
DISTNAME= ParaView-v${PORTVERSION}
@@ -32,7 +33,7 @@ RUN_DEPENDS= bash:shells/bash \
${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:math/py-matplotlib@${PY_FLAVOR}
USES= alias cmake:outsource jpeg localbase python:2.7 qt:5 shebangfix
-USE_QT= core gui help network sql widgets x11extras buildtools_build qmake_build
+USE_QT= core gui help network sql widgets x11extras xmlpatterns buildtools_build qmake_build
USE_GL= gl glu
USE_XORG= x11 xt xext ice xdmcp xau xcb xfixes xdamage xxf86vm xrender sm dri3proto
USE_LDCONFIG= yes
diff --git a/science/paraview/files/patch-CMake_ParaViewMacros.cmake b/science/paraview/files/patch-CMake_ParaViewMacros.cmake
new file mode 100644
index 000000000000..f107f593ca4c
--- /dev/null
+++ b/science/paraview/files/patch-CMake_ParaViewMacros.cmake
@@ -0,0 +1,12 @@
+Prior to 3.12 cmake silently created an empty destination directory if the origin of the copy_directory does not exist.
+
+--- CMake/ParaViewMacros.cmake.orig 2018-07-20 20:59:05 UTC
++++ CMake/ParaViewMacros.cmake
+@@ -382,6 +382,7 @@ function(build_help_project name)
+ set (copy_directory_command
+ # copy all htmls from source to destination directory (same location where the
+ # qhp file is present.
++ COMMAND ${CMAKE_COMMAND} -E make_directory "${arg_DOCUMENTATION_SOURCE_DIR}"
+ COMMAND ${CMAKE_COMMAND} -E copy_directory
+ "${arg_DOCUMENTATION_SOURCE_DIR}"
+ "${arg_DESTINATION_DIRECTORY}"