aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-04-22 00:43:14 +0800
committerswills <swills@FreeBSD.org>2016-04-22 00:43:14 +0800
commit846d8199972dd0559fe10d7173837b7a0309069b (patch)
tree216cef2d134f1181f622a8119ac12546632249a7 /science
parentf97534c6d089592928edeaa9e985d3493fe41f63 (diff)
downloadfreebsd-ports-gnome-846d8199972dd0559fe10d7173837b7a0309069b.tar.gz
freebsd-ports-gnome-846d8199972dd0559fe10d7173837b7a0309069b.tar.zst
freebsd-ports-gnome-846d8199972dd0559fe10d7173837b7a0309069b.zip
many ports: mark broken on powerpc64
Diffstat (limited to 'science')
-rw-r--r--science/bddsolve/Makefile2
-rw-r--r--science/hdf/Makefile2
-rw-r--r--science/openbabel/Makefile2
-rw-r--r--science/orthanc/Makefile2
-rw-r--r--science/simlib/Makefile2
5 files changed, 10 insertions, 0 deletions
diff --git a/science/bddsolve/Makefile b/science/bddsolve/Makefile
index be88cfe6a2cb..75b46d56f45c 100644
--- a/science/bddsolve/Makefile
+++ b/science/bddsolve/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= ed@FreeBSD.org
COMMENT= BDD-based satisfiability and reachability solver
+BROKEN_powerpc64= Does not build
+
LIB_DEPENDS+= libbdd.so:science/buddy \
libboost_program_options.so:devel/boost-libs
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index a1c3b289089a..80917e1efef6 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -11,6 +11,8 @@ MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/HDF${PORTVERSION}/src/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Hierarchical Data Format library (from NCSA)
+BROKEN_powerpc64= Does not build
+
LIB_DEPENDS= libsz.so:science/szip
CONFLICTS_INSTALL= netcdf-4.[0-9]*
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index 81abb3110261..28124feccaeb 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF
MAINTAINER= makc@FreeBSD.org
COMMENT= Chemistry file translation program
+BROKEN_powerpc64= Does not build
+
BUILD_DEPENDS= ${LOCALBASE}/include/eigen3/Eigen/Eigen:math/eigen3
CONFLICTS_INSTALL= babel-*
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index 3675ee246f42..813c41d629b2 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -17,6 +17,8 @@ COMMENT= RESTful DICOM server for healthcare and medical research
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= Does not build
+
BUILD_DEPENDS= gtest-config:devel/googletest
LIB_DEPENDS= libcurl.so:ftp/curl \
libjsoncpp.so:devel/jsoncpp \
diff --git a/science/simlib/Makefile b/science/simlib/Makefile
index d780c19f9231..7b8dbf81663c 100644
--- a/science/simlib/Makefile
+++ b/science/simlib/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-20111030
MAINTAINER= ports@FreeBSD.org
COMMENT= SIMulation LIBrary for C++ programming language
+BROKEN_powerpc64= Does not build
+
USES= gmake
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}