aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-19 05:47:12 +0800
committeryuri <yuri@FreeBSD.org>2018-07-19 05:47:12 +0800
commit8b4cef4a49e3ad96d2f90962f604c5fe3e369543 (patch)
treecc78048926e7d3d2e1e0f63f6b144930d413e529 /science
parent63f68d55c7161d1ab754ec3bf62ae69d79e01b63 (diff)
downloadfreebsd-ports-gnome-8b4cef4a49e3ad96d2f90962f604c5fe3e369543.tar.gz
freebsd-ports-gnome-8b4cef4a49e3ad96d2f90962f604c5fe3e369543.tar.zst
freebsd-ports-gnome-8b4cef4a49e3ad96d2f90962f604c5fe3e369543.zip
New port: science/quantum-espresso: Package for research in electronic structure, simulation, optimization
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/quantum-espresso/Makefile58
-rw-r--r--science/quantum-espresso/distinfo3
-rw-r--r--science/quantum-espresso/files/patch-clib_stack.c12
-rw-r--r--science/quantum-espresso/files/patch-install_extlibs__makefile15
-rw-r--r--science/quantum-espresso/pkg-descr14
-rw-r--r--science/quantum-espresso/pkg-plist78
7 files changed, 181 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 64fd4af78798..95c8616a2413 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -218,6 +218,7 @@
SUBDIR += pynn
SUBDIR += qcl
SUBDIR += qtresistors
+ SUBDIR += quantum-espresso
SUBDIR += rdkit
SUBDIR += rmf
SUBDIR += rubygem-ai4r
diff --git a/science/quantum-espresso/Makefile b/science/quantum-espresso/Makefile
new file mode 100644
index 000000000000..af29db8fc528
--- /dev/null
+++ b/science/quantum-espresso/Makefile
@@ -0,0 +1,58 @@
+# $FreeBSD$
+
+PORTNAME= quantum-espresso
+DISTVERSIONPREFIX= qe-
+DISTVERSION= 6.3
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Package for research in electronic structure, simulation, optimization
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/License
+
+BUILD_DEPENDS= fox-xml>0:textproc/fox-xml \
+ bash:shells/bash
+LIB_DEPENDS= libmpich.so:net/mpich2 \
+ libblas.so:math/blas \
+ liblapack.so:math/lapack
+
+USES= fortran gmake python shebangfix
+SHEBANG_FILES= configure PW/tools/cell2ibrav.py
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= QEF
+GH_PROJECT= q-e
+ALL_TARGET= all
+
+MAKE_ARGS= TOPDIR=${WRKSRC}
+BINARY_ALIAS= make=gmake cpp=/usr/local/bin/cpp${GCC_DEFAULT}
+FFLAGS+= -x f95-cpp-input
+LDFLAGS+= ${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgfortran.so -lm
+
+MAKE_JOBS_UNSAFE= yes # https://github.com/QEF/q-e/issues/9
+
+post-extract:
+ @${RM} ${WRKSRC}/archive/lapack-3.6.1.tgz
+
+post-patch:
+ @cd ${WRKSRC} && ${MKDIR} FoX && ${LN} -s ${LOCALBASE}/include FoX/finclude
+
+pre-build:
+ @${REINPLACE_CMD} -i '' -e ' \
+ s|$$(CPP) $$(CPPFLAGS)|$$(CPP) -P -traditional $$(CPPFLAGS)| ; \
+ s|LD *=.*|LD=${CC}| ; \
+ s|LAPACK_LIBS *=.*|LAPACK_LIBS=-L${LOCALBASE}/lib -llapack -lblas|' \
+ ${WRKSRC}/make.inc
+
+do-install:
+ cd ${WRKSRC}/bin && \
+ for e in `ls`; do \
+ if [ $$e = "cell2ibrav.x" -o $$e = "iotk" ]; then \
+ ${INSTALL_SCRIPT} $$e ${STAGEDIR}${PREFIX}/bin; \
+ else \
+ ${INSTALL_PROGRAM} $$e ${STAGEDIR}${PREFIX}/bin; \
+ fi; \
+ done;
+
+.include <bsd.port.mk>
diff --git a/science/quantum-espresso/distinfo b/science/quantum-espresso/distinfo
new file mode 100644
index 000000000000..ecacd1ca2c05
--- /dev/null
+++ b/science/quantum-espresso/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531687710
+SHA256 (QEF-q-e-qe-6.3_GH0.tar.gz) = 4067c8fffa957aabbd5cf2439e2fcb6cf3752325393c67a17d99fd09edf8689c
+SIZE (QEF-q-e-qe-6.3_GH0.tar.gz) = 86418701
diff --git a/science/quantum-espresso/files/patch-clib_stack.c b/science/quantum-espresso/files/patch-clib_stack.c
new file mode 100644
index 000000000000..a6fcf7db9c19
--- /dev/null
+++ b/science/quantum-espresso/files/patch-clib_stack.c
@@ -0,0 +1,12 @@
+--- clib/stack.c.orig 2018-07-18 19:43:55 UTC
++++ clib/stack.c
+@@ -11,6 +11,9 @@
+
+ #if !defined(__WIN32)
+ #include <sys/resource.h>
++#if defined(__FreeBSD__)
++#include <sys/types.h>
++#endif
+
+ void remove_stack_limit_(void) {
+
diff --git a/science/quantum-espresso/files/patch-install_extlibs__makefile b/science/quantum-espresso/files/patch-install_extlibs__makefile
new file mode 100644
index 000000000000..bc0f925c359c
--- /dev/null
+++ b/science/quantum-espresso/files/patch-install_extlibs__makefile
@@ -0,0 +1,15 @@
+--- install/extlibs_makefile.orig 2018-07-18 09:59:27 UTC
++++ install/extlibs_makefile
+@@ -62,12 +62,6 @@ fake_lapack_external :
+ -rm fake_liblapack.a
+
+ liblapack_internal:
+- $(call download_and_unpack,$(LAPACK_NETLIB_NAME),$(LAPACK_NETLIB_URL),LAPACK,LAPACK)
+- if test ! -e ../LAPACK/liblapack.a && test -e make_lapack.inc; then \
+- (cp make_lapack.inc ../LAPACK/make.inc; \
+- cd ../LAPACK; $(MAKE) blaslib lapacklib); else \
+- (echo "no configuration file found for lapack"; \
+- echo "run configure from main QE dir"; exit); fi
+
+ libiotk:
+ if test ! -d ../S3DE; then \
diff --git a/science/quantum-espresso/pkg-descr b/science/quantum-espresso/pkg-descr
new file mode 100644
index 000000000000..581e4914a9e4
--- /dev/null
+++ b/science/quantum-espresso/pkg-descr
@@ -0,0 +1,14 @@
+Quantum ESPRESSO is an integrated suite of open-source computer codes
+for electronic-structure calculations and materials modeling at the nanoscale.
+It is based on density-functional theory, plane waves, and pseudopotentials.
+
+Quantum ESPRESSO has evolved into a distribution of independent and
+inter-operable codes in the spirit of an open-source project. The Quantum
+ESPRESSO distribution consists of a "historical" core set of components, and
+a set of plug-ins that perform more advanced tasks, plus a number of third-party
+packages designed to be inter-operable with the core components. Researchers
+active in the field of electronic-structure calculations are encouraged to
+participate in the project by contributing their own codes or by implementing
+their own ideas into existing codes.
+
+WWW: https://www.quantum-espresso.org/
diff --git a/science/quantum-espresso/pkg-plist b/science/quantum-espresso/pkg-plist
new file mode 100644
index 000000000000..aa7ddd786340
--- /dev/null
+++ b/science/quantum-espresso/pkg-plist
@@ -0,0 +1,78 @@
+bin/alpha2f.x
+bin/average.x
+bin/bands.x
+bin/bgw2pw.x
+bin/bse_main.x
+bin/cell2ibrav.x
+bin/cp.x
+bin/cppp.x
+bin/dist.x
+bin/dos.x
+bin/dynmat.x
+bin/epa.x
+bin/epsilon.x
+bin/ev.x
+bin/fd.x
+bin/fd_ef.x
+bin/fd_ifc.x
+bin/fermi_proj.x
+bin/fermi_velocity.x
+bin/fqha.x
+bin/fs.x
+bin/generate_rVV10_kernel_table.x
+bin/generate_vdW_kernel_table.x
+bin/gww.x
+bin/gww_fit.x
+bin/head.x
+bin/ibrav2cell.x
+bin/importexport_binary.x
+bin/initial_state.x
+bin/iotk
+bin/iotk.x
+bin/iotk_print_kinds.x
+bin/kpoints.x
+bin/lambda.x
+bin/ld1.x
+bin/manycp.x
+bin/manypw.x
+bin/matdyn.x
+bin/molecularnexafs.x
+bin/molecularpdos.x
+bin/neb.x
+bin/open_grid.x
+bin/path_interpolation.x
+bin/ph.x
+bin/phcg.x
+bin/plan_avg.x
+bin/plotband.x
+bin/plotproj.x
+bin/plotrho.x
+bin/pmw.x
+bin/pp.x
+bin/projwfc.x
+bin/pw.x
+bin/pw2bgw.x
+bin/pw2gw.x
+bin/pw2wannier90.x
+bin/pw4gww.x
+bin/pw_export.x
+bin/pwcond.x
+bin/pwi2xsf.x
+bin/q2qstar.x
+bin/q2r.x
+bin/q2trans.x
+bin/q2trans_fd.x
+bin/simple.x
+bin/simple_bse.x
+bin/simple_ip.x
+bin/spectra_correction.x
+bin/sumpdos.x
+bin/turbo_davidson.x
+bin/turbo_eels.x
+bin/turbo_lanczos.x
+bin/turbo_spectrum.x
+bin/wannier_ham.x
+bin/wannier_plot.x
+bin/wfck2r.x
+bin/wfdd.x
+bin/xspectra.x