aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2010-12-18 17:24:21 +0800
committernivit <nivit@FreeBSD.org>2010-12-18 17:24:21 +0800
commitaf9d6af4405ada537d8af5364bbadf64b0c0e6c9 (patch)
tree3ae86116d744d5ead459542ecefbb1e743ccecf2 /science
parent83937df9c0358e0d21e16b49e7bb54649c64c50f (diff)
downloadfreebsd-ports-gnome-af9d6af4405ada537d8af5364bbadf64b0c0e6c9.tar.gz
freebsd-ports-gnome-af9d6af4405ada537d8af5364bbadf64b0c0e6c9.tar.zst
freebsd-ports-gnome-af9d6af4405ada537d8af5364bbadf64b0c0e6c9.zip
- Add files/patch-bin_vmd.csh, files/patch-bin_vmd.sh
to fix a runtime error (the "ARCH" value is not set) - Bump PORTREVISION - Remove MD5 checksum from distinfo - Set ONLY_FOR_ARCHS (i386 and amd64) PR: ports/152955 Submitted by: Benjamin Kaduk <kaduk-fbsd at mit.edu> (maintainer)
Diffstat (limited to 'science')
-rw-r--r--science/vmd/Makefile4
-rw-r--r--science/vmd/distinfo3
-rw-r--r--science/vmd/files/patch-bin_vmd.csh14
-rw-r--r--science/vmd/files/patch-bin_vmd.sh15
4 files changed, 32 insertions, 4 deletions
diff --git a/science/vmd/Makefile b/science/vmd/Makefile
index a9bde3f014d2..971c61d7e2f0 100644
--- a/science/vmd/Makefile
+++ b/science/vmd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vmd
PORTVERSION= 1.8.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science graphics python tcl tk
MASTER_SITES= http://jedi.ks.uiuc.edu/~johns/raytracer/files/0.98.7/:tachyon \
http://www.ks.uiuc.edu/Research/vmd/extsrcs/:stride
@@ -31,6 +31,8 @@ USE_GMAKE= yes
USE_GL= glu
USE_PYTHON= yes
+ONLY_FOR_ARCHS= i386 amd64
+
RESTRICTED= License has restrictions
VMD_DIST= ${PORTNAME}-${PORTVERSION}.src.tar.gz
diff --git a/science/vmd/distinfo b/science/vmd/distinfo
index 92d082e7ccf6..434b34b20e8e 100644
--- a/science/vmd/distinfo
+++ b/science/vmd/distinfo
@@ -1,9 +1,6 @@
-MD5 (vmd-1.8.7.src.tar.gz) = e8da2f2a5ffd5b4b2562eec77bbea8a3
SHA256 (vmd-1.8.7.src.tar.gz) = 72fe2fb7eff4c805a886ea929c7e143a3a1be57cc817b5d1719d29e591d80316
SIZE (vmd-1.8.7.src.tar.gz) = 23853864
-MD5 (tachyon-0.98.7.tar.gz) = 17b41c7042a2d3a75531a4979f643d15
SHA256 (tachyon-0.98.7.tar.gz) = f22b86ed8c85bb12abc20c703f01238bce676c097dae66c81a6bbb7c08a60341
SIZE (tachyon-0.98.7.tar.gz) = 3269840
-MD5 (Stride_src.tar.Z) = 96507c2bdc16d4b152278ad7a0cb0389
SHA256 (Stride_src.tar.Z) = c40f7de64947ebab7ec49511c0d264b08bc0fcbc703014bdc85d83a7389be230
SIZE (Stride_src.tar.Z) = 100329
diff --git a/science/vmd/files/patch-bin_vmd.csh b/science/vmd/files/patch-bin_vmd.csh
new file mode 100644
index 000000000000..a13d8716deb3
--- /dev/null
+++ b/science/vmd/files/patch-bin_vmd.csh
@@ -0,0 +1,14 @@
+--- bin/vmd.csh.orig 2010-12-08 20:55:17.000000000 -0500
++++ bin/vmd.csh 2010-12-08 21:10:21.000000000 -0500
+@@ -218,6 +218,11 @@
+ # The standard options
+ if (`uname -m` == "i386") then
+ set ARCH=FREEBSD
++ else if (`uname -m` == "amd64") then
++ set ARCH=FREEBSDAMD64
++ else
++ echo "Error: unsupported FreeBSD version $MACHVER"
++ exit 1
+ endif
+ set VMD_WINTERM=xterm
+ set VMD_WINOPTS='-sb -sl 1000 -e'
diff --git a/science/vmd/files/patch-bin_vmd.sh b/science/vmd/files/patch-bin_vmd.sh
new file mode 100644
index 000000000000..5689cfdf44cc
--- /dev/null
+++ b/science/vmd/files/patch-bin_vmd.sh
@@ -0,0 +1,15 @@
+--- bin/vmd.sh.orig 2010-12-08 21:07:16.000000000 -0500
++++ bin/vmd.sh 2010-12-08 21:15:46.000000000 -0500
+@@ -256,6 +256,12 @@
+ if [ `uname -m` = "i386" ]
+ then
+ ARCH=FREEBSD
++ elif [ `uname -m` = "amd64" ]
++ then
++ ARCH=FREEBSDAMD64
++ else
++ echo "Error: unsupported FreeBSD version $MACHVER"
++ exit 1
+ fi
+ VMD_WINTERM=xterm
+ VMD_WINOPTS='-sb -sl 1000 -e'