aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
committereadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
commitcdabc54ad469c80d08327c0d32dfa55c640cff2a (patch)
treeeba3c1f7e94497327507881e3b0eb623013d377e /science
parent3e5b766396a89930130c8530a30308b48d239d4b (diff)
downloadfreebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.gz
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.zst
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.zip
This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.
If a port used other USE_GNOME items it was untouched. The ports that used other USES were fixed by hand. PR: ports/177081 Reviewed by: bapt Approved by: portmgr (miwi)
Diffstat (limited to 'science')
-rw-r--r--science/cdo/Makefile2
-rw-r--r--science/libghemical/Makefile2
-rw-r--r--science/liboglappth/Makefile2
-rw-r--r--science/netcdf4/Makefile2
-rw-r--r--science/peekabot/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 1dd7bddec83f..2bc439fe4df7 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -22,7 +22,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --enable-cdi-lib --program-transform-name="" --with-zlib=/usr
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
HDF5_VER?= 18
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index d874367e620f..6d08fd611996 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS+= mpqc:${PORTSDIR}/science/mpqc \
f2c:${PORTSDIR}/lang/f2c
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/science/liboglappth/Makefile b/science/liboglappth/Makefile
index d3e43881d949..379a06b866b0 100644
--- a/science/liboglappth/Makefile
+++ b/science/liboglappth/Makefile
@@ -16,7 +16,7 @@ COMMENT= Support libraries of science/ghemical port
GNU_CONFIGURE= yes
USE_GL= glut
-USE_GNOME= gnomehack
+USES= pathfix
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index b5a0057781c8..170714f0cf4a 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18
MAKE_ENV= INFODIR="${PREFIX}/${INFO_PATH}" MAKEINFOFLAGS="--no-split"
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index 7936ec5f238e..1b95444ce337 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs \
gtkglextmm-x11-1.2:${PORTSDIR}/x11-toolkits/gtkglextmm
USE_BZIP2= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_GCC= 4.6+
USE_GMAKE= yes
GNU_CONFIGURE= yes