aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-08-31 14:45:27 +0800
committeryuri <yuri@FreeBSD.org>2018-08-31 14:45:27 +0800
commitd0e33f92f08d897c97e4a747af786bdcf7f8dd62 (patch)
tree1fb47fecb033a4c3cc046c24d72b698aa4f12a0a /science
parent393b35128e7f630df2531b3de811fa4df617111a (diff)
downloadfreebsd-ports-gnome-d0e33f92f08d897c97e4a747af786bdcf7f8dd62.tar.gz
freebsd-ports-gnome-d0e33f92f08d897c97e4a747af786bdcf7f8dd62.tar.zst
freebsd-ports-gnome-d0e33f92f08d897c97e4a747af786bdcf7f8dd62.zip
New port: science/qbox: First-principles molecular dynamics code
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/qbox/Makefile42
-rw-r--r--science/qbox/distinfo3
-rw-r--r--science/qbox/files/freebsd.mk.in43
-rw-r--r--science/qbox/pkg-descr7
5 files changed, 96 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index a9819eb7a084..77571766e2e2 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -223,6 +223,7 @@
SUBDIR += pybrain
SUBDIR += pycdf
SUBDIR += pynn
+ SUBDIR += qbox
SUBDIR += qcl
SUBDIR += qmcpack
SUBDIR += qtresistors
diff --git a/science/qbox/Makefile b/science/qbox/Makefile
new file mode 100644
index 000000000000..0a38fc76a156
--- /dev/null
+++ b/science/qbox/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= qbox
+DISTVERSIONPREFIX= rel
+DISTVERSION= 1_65_0
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= First-principles molecular dynamics code
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libblas.so:math/blas \
+ libcurl.so:ftp/curl \
+ libfftw3.so:math/fftw3 \
+ libgcc_s.so:lang/gcc7 \
+ liblapack.so:math/lapack \
+ libmpich.so:net/mpich2 \
+ libscalapack.so:math/scalapack \
+ libuuid.so:misc/e2fsprogs-libuuid \
+ libxerces-c.so:textproc/xerces-c3
+
+USES= gmake iconv:wchar_t localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= qboxcode
+GH_PROJECT= qbox-public
+ALL_TARGET= qb
+
+WRKSRC_SUBDIR= src
+
+MAKE_ARGS= TARGET=freebsd
+LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${GCC_DEFAULT} ${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgcc_s.so
+
+PLIST_FILES= bin/qb
+
+post-extract:
+ @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|; s|%%CXXFLAGS%%|${CXXFLAGS}|; s|%%LDFLAGS%%|${LDFLAGS}|' < ${FILESDIR}/freebsd.mk.in > ${WRKSRC}/freebsd.mk
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qb ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/science/qbox/distinfo b/science/qbox/distinfo
new file mode 100644
index 000000000000..b2cc366e3716
--- /dev/null
+++ b/science/qbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1535696295
+SHA256 (qboxcode-qbox-public-rel1_65_0_GH0.tar.gz) = b31308e604ee00ffbf35ac41295900278b598640551a60879ea69da810c488bc
+SIZE (qboxcode-qbox-public-rel1_65_0_GH0.tar.gz) = 667533
diff --git a/science/qbox/files/freebsd.mk.in b/science/qbox/files/freebsd.mk.in
new file mode 100644
index 000000000000..7b4915e040e2
--- /dev/null
+++ b/science/qbox/files/freebsd.mk.in
@@ -0,0 +1,43 @@
+#
+# Copyright (c) 2014 The Regents of the University of California
+#
+# This file is part of Qbox
+#
+# Qbox is distributed under the terms of the GNU General Public License
+# as published by the Free Software Foundation, either version 2 of
+# the License, or (at your option) any later version.
+# See the file COPYING in the root directory of this distribution
+# or <http://www.gnu.org/licenses/>.
+#
+#-------------------------------------------------------------------------------
+#
+# macosx_openmpi.mk
+#
+#-------------------------------------------------------------------------------
+#
+ PLT=FreeBSD
+#-------------------------------------------------------------------------------
+ SCALAPACKDIR=%%LOCALBASE%%/lib
+ LAPACKDIR=%%LOCALBASE%%/lib
+ BLASDIR=%%LOCALBASE%%/lib
+
+ PLTOBJECTS = readTSC.o
+
+ LD=$(CXX)
+
+ PLTFLAGS += -DIA32 -DUSE_MPI -DUSE_FFTW3 -D_LARGEFILE_SOURCE \
+ -D_FILE_OFFSET_BITS=64 -DADD_ \
+ -DAPP_NO_THREADS -DXML_USE_NO_THREADS -DUSE_XERCES -DXERCESC_3 \
+ -DSCALAPACK -DUSE_UUID
+
+ INCLUDE = -I$(FFTWDIR)
+
+ CXXFLAGS= %%CXXFLAGS%% -Wunused -D$(PLT) $(INCLUDE) $(PLTFLAGS) $(DFLAGS)
+
+ LIBPATH = -L$(SCALAPACKDIR) -L$(LAPACKDIR) -L$(BLASDIR)
+
+ LIBS = -lfftw3 -lscalapack -llapack -lblas -lm \
+ -lxerces-c -lpthread -lmpichcxx -lstdc++ -lcurl -liconv -luuid -lmpich
+
+ LDFLAGS = %%LDFLAGS%% $(LIBPATH) $(LIBS)
+#-------------------------------------------------------------------------------
diff --git a/science/qbox/pkg-descr b/science/qbox/pkg-descr
new file mode 100644
index 000000000000..1dd239aecbdb
--- /dev/null
+++ b/science/qbox/pkg-descr
@@ -0,0 +1,7 @@
+Qbox is a C++/MPI scalable parallel implementation of first-principles molecular
+dynamics (FPMD) based on the plane-wave, pseudopotential formalism. Qbox is
+designed for operation on large parallel computers.
+
+Qbox is developed in Gygi Research Group at UC Davis.
+
+WWW: http://qboxcode.org/