aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-06-29 17:04:22 +0800
committeryuri <yuri@FreeBSD.org>2018-06-29 17:04:22 +0800
commitdbdb5df895f1025538d397378bf0a76ccd725beb (patch)
tree1a72777e4be433321bcf757a59d24495e075ffb0 /science
parent3fde6e61ec0790e4586da20cd5defbc79e453a2b (diff)
downloadfreebsd-ports-gnome-dbdb5df895f1025538d397378bf0a76ccd725beb.tar.gz
freebsd-ports-gnome-dbdb5df895f1025538d397378bf0a76ccd725beb.tar.zst
freebsd-ports-gnome-dbdb5df895f1025538d397378bf0a76ccd725beb.zip
New port: science/rmf: Library to support reading and writing of Rich Molecular Format files
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/rmf/Makefile26
-rw-r--r--science/rmf/distinfo9
-rw-r--r--science/rmf/files/patch-CMakeLists.txt45
-rw-r--r--science/rmf/pkg-descr6
-rw-r--r--science/rmf/pkg-plist98
6 files changed, 185 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index b12b4061e09a..5ca73af1e20c 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -212,6 +212,7 @@
SUBDIR += qcl
SUBDIR += qtresistors
SUBDIR += rdkit
+ SUBDIR += rmf
SUBDIR += rubygem-ai4r
SUBDIR += rubygem-cdo
SUBDIR += rubygem-rgeo
diff --git a/science/rmf/Makefile b/science/rmf/Makefile
new file mode 100644
index 000000000000..20ea99e9575d
--- /dev/null
+++ b/science/rmf/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= rmf
+DISTVERSION= g20180614
+CATEGORIES= science graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library to support reading and writing of Rich Molecular Format files
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libhdf5.so:science/hdf5 \
+ libsz.so:science/szip
+
+USES= cmake:outsource python:build shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= salilab
+GH_TAGNAME= f917cf2
+SHEBANG_GLOB= *.py
+USE_LDCONFIG= yes
+
+BINARY_ALIAS= python=${PYTHON_CMD}
+
+.include <bsd.port.mk>
diff --git a/science/rmf/distinfo b/science/rmf/distinfo
new file mode 100644
index 000000000000..f854bedcc4ae
--- /dev/null
+++ b/science/rmf/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1530254926
+SHA256 (salilab-rmf-g20180614-f917cf2_GH0.tar.gz) = 9c877539b8c7a6af38b3d7155522a90b16b3e28596ec27ac941c7f812f1a1c6f
+SIZE (salilab-rmf-g20180614-f917cf2_GH0.tar.gz) = 15087905
+SHA256 (salilab-cmake_modules-412ee17_GH0.tar.gz) = ea4867f9239f68c235183e5397804091a528af94a28de93e93bca4a3d5bc1202
+SIZE (salilab-cmake_modules-412ee17_GH0.tar.gz) = 25035
+SHA256 (salilab-developer_tools-91e94c7_GH0.tar.gz) = 6e512ca15c89803828daaa6dfc44aa836fbf4f7f72aa5240f0b3709c17d85521
+SIZE (salilab-developer_tools-91e94c7_GH0.tar.gz) = 34682
+SHA256 (salilab-avrocpp-10f7084_GH0.tar.gz) = 0d8501103ddd22c06b1f973fd48d2bbd616b4c01a1214c06412cc5d0d371361c
+SIZE (salilab-avrocpp-10f7084_GH0.tar.gz) = 123182
diff --git a/science/rmf/files/patch-CMakeLists.txt b/science/rmf/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..6df7a51d65e3
--- /dev/null
+++ b/science/rmf/files/patch-CMakeLists.txt
@@ -0,0 +1,45 @@
+--- CMakeLists.txt.orig 2018-06-15 00:56:51 UTC
++++ CMakeLists.txt
+@@ -4,15 +4,15 @@ project(RMF)
+ # needs to be in main CMakeLists.txt
+ enable_testing()
+
+-execute_process(COMMAND python setup_git.py
+- RESULT_VARIABLE setup
+- OUTPUT_VARIABLE toutput
+- ERROR_VARIABLE error
+- WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
+- OUTPUT_STRIP_TRAILING_WHITESPACE)
+-if(NOT ${setup} EQUAL 0)
+- message(FATAL_ERROR " Failed to run setup_git.py: ${setup}; ${error}")
+-endif()
++#execute_process(COMMAND python setup_git.py
++# RESULT_VARIABLE setup
++# OUTPUT_VARIABLE toutput
++# ERROR_VARIABLE error
++# WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
++# OUTPUT_STRIP_TRAILING_WHITESPACE)
++#if(NOT ${setup} EQUAL 0)
++# message(FATAL_ERROR " Failed to run setup_git.py: ${setup}; ${error}")
++#endif()
+
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/cmake_modules)
+
+@@ -140,12 +140,12 @@ else()
+ endif()
+
+
+-add_subdirectory(swig)
++#add_subdirectory(swig)
+
+-add_subdirectory(test)
+-add_subdirectory(examples)
+-add_subdirectory(benchmark)
+-add_subdirectory(doc)
++#add_subdirectory(test)
++#add_subdirectory(examples)
++#add_subdirectory(benchmark)
++#add_subdirectory(doc)
+
+ add_custom_target(RMF DEPENDS ${RMF_BINS} ${RMF_SWIG} ${RMF_TESTS} ${RMF_VMD} RMF-decorators)
+ set_property(TARGET "RMF" PROPERTY FOLDER "RMF")
diff --git a/science/rmf/pkg-descr b/science/rmf/pkg-descr
new file mode 100644
index 000000000000..0325d8ab7356
--- /dev/null
+++ b/science/rmf/pkg-descr
@@ -0,0 +1,6 @@
+The library provides support for the Rich Molecular Format (RMF) file format for
+storing hierarchical molecular data (such as atomic or coarse grained
+representations of proteins), along with markup, including geometry and score
+data.
+
+WWW: https://integrativemodeling.org/rmf/
diff --git a/science/rmf/pkg-plist b/science/rmf/pkg-plist
new file mode 100644
index 000000000000..b7db19bfa0ea
--- /dev/null
+++ b/science/rmf/pkg-plist
@@ -0,0 +1,98 @@
+bin/rmf3_dump
+bin/rmf_cat
+bin/rmf_frames
+bin/rmf_info
+bin/rmf_interpolate
+bin/rmf_pdb
+bin/rmf_show
+bin/rmf_signature
+bin/rmf_slice
+bin/rmf_transform
+bin/rmf_update
+bin/rmf_validate
+bin/rmf_xml
+include/RMF/BufferConstHandle.h
+include/RMF/BufferHandle.h
+include/RMF/CoordinateTransformer.h
+include/RMF/Decorator.h
+include/RMF/Enum.h
+include/RMF/FileConstHandle.h
+include/RMF/FileHandle.h
+include/RMF/HDF5.h
+include/RMF/HDF5/ConstAttributes.h
+include/RMF/HDF5/ConstDataSetD.h
+include/RMF/HDF5/ConstFile.h
+include/RMF/HDF5/ConstGroup.h
+include/RMF/HDF5/DataSetAccessPropertiesD.h
+include/RMF/HDF5/DataSetCreationPropertiesD.h
+include/RMF/HDF5/DataSetD.h
+include/RMF/HDF5/DataSetIndexD.h
+include/RMF/HDF5/File.h
+include/RMF/HDF5/Group.h
+include/RMF/HDF5/MutableAttributes.h
+include/RMF/HDF5/Object.h
+include/RMF/HDF5/handle.h
+include/RMF/HDF5/infrastructure_macros.h
+include/RMF/HDF5/internal/types.h
+include/RMF/HDF5/types.h
+include/RMF/ID.h
+include/RMF/Label.h
+include/RMF/NodeConstHandle.h
+include/RMF/NodeHandle.h
+include/RMF/Nullable.h
+include/RMF/RestoreCurrentFrame.h
+include/RMF/SetCurrentFrame.h
+include/RMF/TraverseHelper.h
+include/RMF/Vector.h
+include/RMF/compiler_macros.h
+include/RMF/config.h
+include/RMF/constants.h
+include/RMF/decorator/alias.h
+include/RMF/decorator/alternatives.h
+include/RMF/decorator/bond.h
+include/RMF/decorator/external.h
+include/RMF/decorator/feature.h
+include/RMF/decorator/labels.h
+include/RMF/decorator/physics.h
+include/RMF/decorator/provenance.h
+include/RMF/decorator/publication.h
+include/RMF/decorator/reference.h
+include/RMF/decorator/representation.h
+include/RMF/decorator/sequence.h
+include/RMF/decorator/shape.h
+include/RMF/decorators.h
+include/RMF/enums.h
+include/RMF/exceptions.h
+include/RMF/info.h
+include/RMF/infrastructure_macros.h
+include/RMF/internal/SharedData.h
+include/RMF/internal/SharedDataCategory.h
+include/RMF/internal/SharedDataData.h
+include/RMF/internal/SharedDataData_impl.h
+include/RMF/internal/SharedDataFile.h
+include/RMF/internal/SharedDataFrames.h
+include/RMF/internal/SharedDataHierarchy.h
+include/RMF/internal/SharedDataKeys.h
+include/RMF/internal/SharedDataUserData.h
+include/RMF/internal/SharedData_impl.h
+include/RMF/internal/Transform.h
+include/RMF/internal/errors.h
+include/RMF/internal/hash.h
+include/RMF/internal/irange.h
+include/RMF/internal/large_set_map.h
+include/RMF/internal/paths.h
+include/RMF/internal/shared_data_factories.h
+include/RMF/internal/shared_data_ranges.h
+include/RMF/internal/small_set_map.h
+include/RMF/internal/swig_helpers.h
+include/RMF/internal/use.h
+include/RMF/keys.h
+include/RMF/log.h
+include/RMF/names.h
+include/RMF/show_hierarchy.h
+include/RMF/signature.h
+include/RMF/traits.h
+include/RMF/types.h
+include/RMF/utility.h
+include/RMF/validate.h
+lib/libRMF.so