aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-07-09 19:11:44 +0800
committerbf <bf@FreeBSD.org>2012-07-09 19:11:44 +0800
commitdeed5e01fdd95315c9916898c4e4df970e927517 (patch)
treeb4e677a0a626001da519b1e8b0bf211afdcc1c7b /science
parentdb274a3231bbeb8a0d981e20555844539d52d4b4 (diff)
downloadfreebsd-ports-gnome-deed5e01fdd95315c9916898c4e4df970e927517.tar.gz
freebsd-ports-gnome-deed5e01fdd95315c9916898c4e4df970e927517.tar.zst
freebsd-ports-gnome-deed5e01fdd95315c9916898c4e4df970e927517.zip
add math/metis4 to math/Makefile; update math/metis to 5.0.2; add appropriate
CONFLICTS, LATEST_LINK, and PORTSCOUT; adjust dependent ports; explicitly note the restrictive license of the metis ports (while here, append the MPI port to *DEPENDS in math/parmetis, rather than using an assignment) PR: 169578
Diffstat (limited to 'science')
-rw-r--r--science/ecs/Makefile6
-rw-r--r--science/mbdyn/Makefile4
2 files changed, 5 insertions, 5 deletions
diff --git a/science/ecs/Makefile b/science/ecs/Makefile
index 883d4c0e2517..921fd9b391b0 100644
--- a/science/ecs/Makefile
+++ b/science/ecs/Makefile
@@ -67,11 +67,11 @@ MAN1= cs_io_dump.1 cs_partition.1 cs_preprocess-config.1 cs_preprocess.1
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/bin/partdmesh)
-# The regular metis is there, cannot depends on metis-edf
-LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis
+# The regular metis is present, so we cannot depend on metis-edf
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
.else
# Prefer metis-edf to avoid conflict with Code_Aster
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis-edf
+BUILD_DEPENDS+= ${LOCALBASE}/bin/onmetis.exe:${PORTSDIR}/math/metis-edf
.endif
.if ${ARCH} == "i386"
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 87b4f36fe46d..2bcf129fbaa2 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -67,7 +67,7 @@ CONFIGURE_ARGS+= --with-mpi=no
.endif
.if defined(WITH_METIS)
-LIB_DEPENDS+= metis:${PORTSDIR}/math/metis
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
CONFIGURE_ARGS+= --with-metis=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
.else
@@ -82,7 +82,7 @@ CONFIGURE_ARGS+= --with-chaco=no
.endif
.if defined(WITH_GINAC)
-LIB_DEPENDS+= metis:${PORTSDIR}/math/metis \
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4 \
ginac:${PORTSDIR}/math/GiNaC
CONFIGURE_ARGS+= --with-ginac=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis