aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-10-25 00:50:42 +0800
committermva <mva@FreeBSD.org>2014-10-25 00:50:42 +0800
commitec8b5f2cdebe3e3f03e78fc0466783bf71a24e4d (patch)
tree13162908585c4f1c4a190de09a7b7dd8f6e58eb2 /science
parent74a3c07b695eef5aba924290f7d537c710b1233e (diff)
downloadfreebsd-ports-gnome-ec8b5f2cdebe3e3f03e78fc0466783bf71a24e4d.tar.gz
freebsd-ports-gnome-ec8b5f2cdebe3e3f03e78fc0466783bf71a24e4d.tar.zst
freebsd-ports-gnome-ec8b5f2cdebe3e3f03e78fc0466783bf71a24e4d.zip
- Convert ports of science/ and security to new USES=python
Approved by: portmgr (implicit)
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/Makefile2
-rw-r--r--science/brian/Makefile6
-rw-r--r--science/gramps/Makefile3
-rw-r--r--science/libsvm/Makefile2
-rw-r--r--science/mei/Makefile3
-rw-r--r--science/openbabel/Makefile2
-rw-r--r--science/py-DendroPy/Makefile4
-rw-r--r--science/py-coards/Makefile5
-rw-r--r--science/py-h5py/Makefile6
-rw-r--r--science/py-hcluster/Makefile5
-rw-r--r--science/py-mdp/Makefile5
-rw-r--r--science/py-mlpy/Makefile5
-rw-r--r--science/py-netCDF4/Makefile5
-rw-r--r--science/py-paida/Makefile5
-rw-r--r--science/py-pupynere/Makefile5
-rw-r--r--science/py-pyaixi/Makefile6
-rw-r--r--science/py-pydap/Makefile5
-rw-r--r--science/py-pydicom/Makefile5
-rw-r--r--science/py-scikit-learn/Makefile6
-rw-r--r--science/py-scimath/Makefile5
-rw-r--r--science/py-ws2300/Makefile5
-rw-r--r--science/pybrain/Makefile5
-rw-r--r--science/pycdf/Makefile5
-rw-r--r--science/pynn/Makefile4
-rw-r--r--science/pyteomics.biolccc/Makefile5
-rw-r--r--science/pyteomics/Makefile5
-rw-r--r--science/sigrok-firmware-utils/Makefile2
-rw-r--r--science/veusz/Makefile6
28 files changed, 50 insertions, 77 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index f929ff96ae49..3c8459476439 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -35,7 +35,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2
+USES+= python:2
BUILD_DEPENDS+= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:${PORTSDIR}/devel/py-sip
LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
diff --git a/science/brian/Makefile b/science/brian/Makefile
index 6dd6cb88262b..b24d6859430f 100644
--- a/science/brian/Makefile
+++ b/science/brian/Makefile
@@ -15,9 +15,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.1.0:${PORTSDIR}/math/py-numpy \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= zip
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python zip
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/gramps/Makefile b/science/gramps/Makefile
index ad775b27781a..fec7aef74f91 100644
--- a/science/gramps/Makefile
+++ b/science/gramps/Makefile
@@ -18,8 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb \
${PYXML}
USE_BDB= 5+
-USE_PYTHON= yes
-USES= desktop-file-utils gettext shared-mime-info gmake
+USES= desktop-file-utils gettext shared-mime-info gmake python
USE_GNOME= pygtk2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-mime-install
diff --git a/science/libsvm/Makefile b/science/libsvm/Makefile
index afd98caa6734..05617e10f9b0 100644
--- a/science/libsvm/Makefile
+++ b/science/libsvm/Makefile
@@ -25,7 +25,7 @@ ALL_TARGET= all lib
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX} == "-python"
CATEGORIES+= python
-USE_PYTHON= yes
+USES+= python
MAKE_ARGS= PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR}
diff --git a/science/mei/Makefile b/science/mei/Makefile
index 1be84d870a31..fbfe271b4c83 100644
--- a/science/mei/Makefile
+++ b/science/mei/Makefile
@@ -15,9 +15,8 @@ LICENSE= LGPL21
LIB_DEPENDS= libbft.so:${PORTSDIR}/science/bft
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
-USES= libtool
+USES= libtool python
USE_LDCONFIG= yes
-USE_PYTHON= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_PYEXE=${PYTHON_CMD}
CONFIGURE_ARGS= --with-bft=${LOCALBASE}
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index 237f36ad2efd..905ccdec49b9 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -32,7 +32,7 @@ CAIRO_USES= pkgconfig
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
CMAKE_ARGS+= -DPYTHON_BINDINGS=on
.endif
diff --git a/science/py-DendroPy/Makefile b/science/py-DendroPy/Makefile
index 95f32d3909ee..52f9aeffe927 100644
--- a/science/py-DendroPy/Makefile
+++ b/science/py-DendroPy/Makefile
@@ -13,8 +13,8 @@ COMMENT= Phylogenetic computing library
LICENSE= BSD3CLAUSE
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/science/py-coards/Makefile b/science/py-coards/Makefile
index 5bd5694e387e..3153c9b4bba1 100644
--- a/science/py-coards/Makefile
+++ b/science/py-coards/Makefile
@@ -12,8 +12,7 @@ COMMENT= COARDS compliant time parser
LICENSE= MIT
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index 57db7afb3138..2c13436227b4 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -22,10 +22,8 @@ GH_ACCOUNT= h5py
GH_COMMIT= c8c63eb
GH_TAGNAME= ${GH_COMMIT}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
PORTDOCS= README.rst
PORTEXAMPLES= multiprocessing_example.py \
diff --git a/science/py-hcluster/Makefile b/science/py-hcluster/Makefile
index de3923e7fab8..5ac1166b4a3b 100644
--- a/science/py-hcluster/Makefile
+++ b/science/py-hcluster/Makefile
@@ -15,8 +15,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-mdp/Makefile b/science/py-mdp/Makefile
index 3add2fd279ea..225467f07dff 100644
--- a/science/py-mdp/Makefile
+++ b/science/py-mdp/Makefile
@@ -16,9 +16,8 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYNUMPY}
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
index 13b3ba3920a6..ed3c65a48656 100644
--- a/science/py-mlpy/Makefile
+++ b/science/py-mlpy/Makefile
@@ -21,8 +21,7 @@ LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -I${PYTHON_SITELIBDIR}/numpy/core
LDFLAGS+= -L${LOCALBASE}/lib
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
index b56afb786914..a59e4f099ca6 100644
--- a/science/py-netCDF4/Makefile
+++ b/science/py-netCDF4/Makefile
@@ -24,9 +24,8 @@ GH_PROJECT= netcdf4-python
GH_TAGNAME= v${PORTVERSION}rel
GH_COMMIT= 1344040
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
diff --git a/science/py-paida/Makefile b/science/py-paida/Makefile
index c91179b28523..6dd2fbc9b1fb 100644
--- a/science/py-paida/Makefile
+++ b/science/py-paida/Makefile
@@ -14,8 +14,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkin
MAINTAINER= ports@FreeBSD.org
COMMENT= Pure Python scientific analysis package
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-pupynere/Makefile b/science/py-pupynere/Makefile
index cb056599c9f9..2f3068d144c7 100644
--- a/science/py-pupynere/Makefile
+++ b/science/py-pupynere/Makefile
@@ -16,8 +16,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-pyaixi/Makefile b/science/py-pyaixi/Makefile
index bbdc1ffb8ca0..3356b5e8ba46 100644
--- a/science/py-pyaixi/Makefile
+++ b/science/py-pyaixi/Makefile
@@ -16,10 +16,8 @@ LICENSE_NAME= Creative Commons Attribution-ShareAlike 3.0 \
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= auto-accept dist-mirror pkg-mirror pkg-sell dist-sell
-USES= dos2unix
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= dos2unix python:2
+USE_PYTHON= distutils autoplist
PORTDOCS= changelog.txt \
todo.txt
diff --git a/science/py-pydap/Makefile b/science/py-pydap/Makefile
index b934c327f3a2..93262f048ff0 100644
--- a/science/py-pydap/Makefile
+++ b/science/py-pydap/Makefile
@@ -25,9 +25,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>0:${PORTSDIR}/www/py-httplib2 \
OPTIONS_DEFINE= DOCS
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
PORTDOCS= * .buildinfo
diff --git a/science/py-pydicom/Makefile b/science/py-pydicom/Makefile
index e55a7272db76..bcd9a781468b 100644
--- a/science/py-pydicom/Makefile
+++ b/science/py-pydicom/Makefile
@@ -12,8 +12,7 @@ COMMENT= Read, modify, and write DICOM files with Python code
LICENSE= MIT
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-scikit-learn/Makefile b/science/py-scikit-learn/Makefile
index 2079784b9655..b6b068647fcd 100644
--- a/science/py-scikit-learn/Makefile
+++ b/science/py-scikit-learn/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0.8.0:${PORTSDIR}/science/py-scipy
-USES= fortran
+USES= fortran python
OPTIONS_SINGLE= BLAS
OPTIONS_SINGLE_BLAS= CBLAS ATLAS
@@ -29,8 +29,6 @@ ATLAS_LIB_DEPENDS= libcblas.so:${PORTSDIR}/math/atlas
LATEST_LINK= py-${PORTNAME}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-scimath/Makefile b/science/py-scimath/Makefile
index 9d5742e0e7f3..48882fa74b1f 100644
--- a/science/py-scimath/Makefile
+++ b/science/py-scimath/Makefile
@@ -17,8 +17,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traits>=3.6.0:${PORTSDIR}/devel/py-traits
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-ws2300/Makefile b/science/py-ws2300/Makefile
index 4e00dac57ffa..cf331cc2055e 100644
--- a/science/py-ws2300/Makefile
+++ b/science/py-ws2300/Makefile
@@ -12,9 +12,8 @@ COMMENT= Driver for the LaCrosse WS-2300 weather station
LICENSE= AGPLv3
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/ws2300 ${STAGEDIR}${PREFIX}/bin/ws2300
diff --git a/science/pybrain/Makefile b/science/pybrain/Makefile
index bc114f93d305..c2374d5a9990 100644
--- a/science/pybrain/Makefile
+++ b/science/pybrain/Makefile
@@ -19,8 +19,7 @@ GH_COMMIT= a56fafc
USE_GITHUB= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/pycdf/Makefile b/science/pycdf/Makefile
index 368756886216..9bba30cfd41b 100644
--- a/science/pycdf/Makefile
+++ b/science/pycdf/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
LDFLAGS+= "-L${LOCALBASE}/lib"
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
WRKSRC= ${WRKDIR}/${DISTNAME}
.include <bsd.port.mk>
diff --git a/science/pynn/Makefile b/science/pynn/Makefile
index 25d51b541c48..5939106608bd 100644
--- a/science/pynn/Makefile
+++ b/science/pynn/Makefile
@@ -15,8 +15,8 @@ COMMENT= Simulator-independent language for building neuronal network models
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= PyNN
.include <bsd.port.mk>
diff --git a/science/pyteomics.biolccc/Makefile b/science/pyteomics.biolccc/Makefile
index eb82566a10fa..b634a7b79b4b 100644
--- a/science/pyteomics.biolccc/Makefile
+++ b/science/pyteomics.biolccc/Makefile
@@ -9,8 +9,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= makc@FreeBSD.org
COMMENT= Python bindings for BioLCCC
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/pyteomics/Makefile b/science/pyteomics/Makefile
index 7573c9177836..f48b9b45ce08 100644
--- a/science/pyteomics/Makefile
+++ b/science/pyteomics/Makefile
@@ -14,8 +14,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0:${PORTSDIR}/math/py-matplotlib \
${PYNUMPY}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/sigrok-firmware-utils/Makefile b/science/sigrok-firmware-utils/Makefile
index e25be0791548..4818e5b9d46b 100644
--- a/science/sigrok-firmware-utils/Makefile
+++ b/science/sigrok-firmware-utils/Makefile
@@ -14,7 +14,7 @@ COMMENT= Sigrok firmware extraction utils
LICENSE= GPLv2
-USE_PYTHON= 3
+USES= python:3
NO_BUILD= yes
PORTDOCS= README.parsepe
diff --git a/science/veusz/Makefile b/science/veusz/Makefile
index ec35e3668470..433706a86846 100644
--- a/science/veusz/Makefile
+++ b/science/veusz/Makefile
@@ -17,10 +17,8 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}qt4-svg>0:${PORTSDIR}/graphics/py-qt4-svg
BUILD_DEPENDS:= ${RUN_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-
+USES= python
+USE_PYTHON= distutils autoplist
post-patch:
@${REINPLACE_CMD} \