aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-04-14 19:43:16 +0800
committerijliao <ijliao@FreeBSD.org>2001-04-14 19:43:16 +0800
commitee30e52f85853f43ec0ca1d07106f6344e05e505 (patch)
treeff0341a877e590fce6e9a95d4ae2a9928824c088 /science
parent9e81a1303c860e73c84434122fa8de1c1c3f3436 (diff)
downloadfreebsd-ports-gnome-ee30e52f85853f43ec0ca1d07106f6344e05e505.tar.gz
freebsd-ports-gnome-ee30e52f85853f43ec0ca1d07106f6344e05e505.tar.zst
freebsd-ports-gnome-ee30e52f85853f43ec0ca1d07106f6344e05e505.zip
- Support CC/CFLAGS/MAKE properly
- Support install macros - Fix install error PR: 26557 Submitted by: tkato@prontomail.ne.jp
Diffstat (limited to 'science')
-rw-r--r--science/chemtool/files/patch-Makefile23
-rw-r--r--science/chemtool/files/patch-src-cht::Makefile8
2 files changed, 29 insertions, 2 deletions
diff --git a/science/chemtool/files/patch-Makefile b/science/chemtool/files/patch-Makefile
index 92bf6d66fbfb..a1192f632ba1 100644
--- a/science/chemtool/files/patch-Makefile
+++ b/science/chemtool/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Wed Feb 7 02:52:54 2001
-+++ Makefile Sat Mar 31 03:10:38 2001
+--- Makefile.orig Wed Feb 7 03:52:54 2001
++++ Makefile Sat Apr 14 02:34:58 2001
@@ -1,7 +1,4 @@
-PREFIX=/usr/local
-LOCALEDIR=/usr/share/locale
@@ -20,3 +20,22 @@
all: chemtool cht
+@@ -20,14 +17,14 @@
+ ${CC} ${OBJS} ${SYS_LIBRARIES} -o chemtool
+
+ cht: src-cht/cht-1.3.c
+- cd src-cht;make
++ cd src-cht;${MAKE}
+ .c.o:
+ ${CC} ${CFLAGS} ${EXTRA_INCLUDES} -c ${SRCS}
+
+ install: chemtool src-cht/cht
+- ${CP} chemtool src-cht/cht ${PREFIX}/bin
+- ${CP} chemtool.1 ${PREFIX}/man/man1
+- for L in `ls locales`; do ${CP} locales/$$L/chemtool.mo ${LOCALEDIR}/$$L/LC_MESSAGES;done
++ ${BSD_INSTALL_PROGRAM} chemtool src-cht/cht ${PREFIX}/bin
++ ${BSD_INSTALL_MAN} chemtool.1 ${PREFIX}/man/man1
++ for L in `ls locales`; do mkdir -p ${LOCALEDIR}/$$L/LC_MESSAGES; ${BSD_INSTALL_DATA} locales/$$L/chemtool.mo ${LOCALEDIR}/$$L/LC_MESSAGES;done
+
+ clean:
+ ${RM} *.o *~ src-cht/*.o src-cht/*~ chemtool src-cht/cht
diff --git a/science/chemtool/files/patch-src-cht::Makefile b/science/chemtool/files/patch-src-cht::Makefile
new file mode 100644
index 000000000000..193d47274874
--- /dev/null
+++ b/science/chemtool/files/patch-src-cht::Makefile
@@ -0,0 +1,8 @@
+--- src-cht/Makefile.orig Wed Feb 7 03:38:54 2001
++++ src-cht/Makefile Sat Apr 14 02:13:38 2001
+@@ -1,4 +1,4 @@
+ default: cht
+
+ cht: cht-1.3.c
+- gcc -O cht-1.3.c -lm -o cht
++ ${CC} ${CFLAGS} cht-1.3.c -lm -o cht