aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-06-09 13:07:54 +0800
committerxmj <xmj@FreeBSD.org>2014-06-09 13:07:54 +0800
commit0de9c52de1192f40479e220ba91dc792ef8ae028 (patch)
tree258b1a0734d95b8d947e197a27fa4769a05a7a8f /science
parente47b45117653b302b94c81c2e3ef0c73da1b59f0 (diff)
downloadfreebsd-ports-gnome-0de9c52de1192f40479e220ba91dc792ef8ae028.tar.gz
freebsd-ports-gnome-0de9c52de1192f40479e220ba91dc792ef8ae028.tar.zst
freebsd-ports-gnome-0de9c52de1192f40479e220ba91dc792ef8ae028.zip
science/py-h5py: Upgrade to 2.3.0
- Update to 2.3.0 - Remove BROKEN mark Approved by: swills (mentor)
Diffstat (limited to 'science')
-rw-r--r--science/py-h5py/Makefile18
-rw-r--r--science/py-h5py/distinfo4
-rw-r--r--science/py-h5py/files/patch-setup.py13
3 files changed, 10 insertions, 25 deletions
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index 2dbe5255d484..5faecd9012ce 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= h5py
-PORTVERSION= 2.2.1
-PORTREVISION= 2
+PORTVERSION= 2.3.0
CATEGORIES= science python
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= xmj@chaot.net
@@ -13,12 +11,16 @@ COMMENT= General-purpose Python interface to the HDF5 library
LICENSE= BSD
-BROKEN= Does not build
-
-BUILD_DEPENDS= ${PYNUMPY}
+BUILD_DEPENDS= ${PYNUMPY} \
+ cython:${PORTSDIR}/lang/cython
RUN_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
+USE_GITHUB= yes
+GH_ACCOUNT= h5py
+GH_COMMIT= c8c63eb
+GH_TAGNAME= ${GH_COMMIT}
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -30,10 +32,6 @@ PORTEXAMPLES= multiprocessing_example.py \
OPTIONS_DEFINE= DOCS EXAMPLES
-post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${WRKSRC}/setup.py
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/science/py-h5py/distinfo b/science/py-h5py/distinfo
index a5227215a1c3..9b2bd37e2a93 100644
--- a/science/py-h5py/distinfo
+++ b/science/py-h5py/distinfo
@@ -1,2 +1,2 @@
-SHA256 (h5py-2.2.1.tar.gz) = b4510cb74aef332847dc88e3df6910d7af68c709b3556fc960a687c56ba6a4cb
-SIZE (h5py-2.2.1.tar.gz) = 978796
+SHA256 (h5py-2.3.0.tar.gz) = 1f3e236487213564d8654c6a83a2c75770028f5e79b3752e1ad703fdeab8c802
+SIZE (h5py-2.3.0.tar.gz) = 219342
diff --git a/science/py-h5py/files/patch-setup.py b/science/py-h5py/files/patch-setup.py
deleted file mode 100644
index f28953eb0430..000000000000
--- a/science/py-h5py/files/patch-setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./setup.py.orig 2013-09-04 02:32:03.000000000 +0300
-+++ ./setup.py 2013-10-30 23:46:03.668134592 +0200
-@@ -136,8 +136,8 @@
- COMPILER_SETTINGS['include_dirs'] += ['/usr/local/include'] # homebrew
- COMPILER_SETTINGS['library_dirs'] += ['/usr/local/lib'] # homebrew
- elif sys.platform.startswith('freebsd'):
-- COMPILER_SETTINGS['include_dirs'] += ['/usr/local/include'] # homebrew
-- COMPILER_SETTINGS['library_dirs'] += ['/usr/local/lib'] # homebrew
-+ COMPILER_SETTINGS['include_dirs'] += ['%%LOCALBASE%%/include'] # homebrew
-+ COMPILER_SETTINGS['library_dirs'] += ['%%LOCALBASE%%/lib'] # homebrew
- if MPI:
- COMPILER_SETTINGS['include_dirs'] += [mpi4py.get_include()]
- COMPILER_SETTINGS['runtime_library_dirs'] = [op.abspath(x) for x in COMPILER_SETTINGS['library_dirs']]