aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-05-31 21:14:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-05-31 21:14:30 +0800
commit1454680ab5c0074f34cc5c5a343ba0622a66fb6c (patch)
tree413b22183cd73d99d654b6363d657620c2acd7e8 /science
parent280be33b334fb16b3310eed2b4564c455f067f87 (diff)
downloadfreebsd-ports-gnome-1454680ab5c0074f34cc5c5a343ba0622a66fb6c.tar.gz
freebsd-ports-gnome-1454680ab5c0074f34cc5c5a343ba0622a66fb6c.tar.zst
freebsd-ports-gnome-1454680ab5c0074f34cc5c5a343ba0622a66fb6c.zip
- Fix shebangs
- Strip library Approved by: portmgr blanket MFH: 2015Q2
Diffstat (limited to 'science')
-rw-r--r--science/p5-Geo-BUFR/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/science/p5-Geo-BUFR/Makefile b/science/p5-Geo-BUFR/Makefile
index 090dea7e941b..a099814a51a7 100644
--- a/science/p5-Geo-BUFR/Makefile
+++ b/science/p5-Geo-BUFR/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Geo-BUFR
PORTVERSION= 1.31
+PORTREVISION= 1
CATEGORIES= science perl5 geography
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:PSANNES
@@ -12,8 +13,15 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for handling of WMO BUFR files
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENCE
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= *.pl
USE_PERL5= configure
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Geo/BUFR/BUFR.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Geo/BUFR/BUFR.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Geo/BUFR/BUFR.so
+
.include <bsd.port.mk>