aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-26 02:47:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-26 02:47:55 +0800
commit1f7f15532c23f14a5e46760b66b334ecf91886ab (patch)
tree5deaa62a75cef25189f27c192d9e52cf25debd8c /science
parent28757a018095e47b288358997d70a330caaa9f5c (diff)
downloadfreebsd-ports-gnome-1f7f15532c23f14a5e46760b66b334ecf91886ab.tar.gz
freebsd-ports-gnome-1f7f15532c23f14a5e46760b66b334ecf91886ab.tar.zst
freebsd-ports-gnome-1f7f15532c23f14a5e46760b66b334ecf91886ab.zip
- Add SWIG option
PR: ports/172660 Submitted by: Rainer Hurling <rhurlin@gwdg.de>
Diffstat (limited to 'science')
-rw-r--r--science/libkml/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
index 69e12205f50c..e5afc6a9404e 100644
--- a/science/libkml/Makefile
+++ b/science/libkml/Makefile
@@ -15,13 +15,18 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${LOCALBASE}/bin/curl-config:${PORTSDIR}/ftp/curl \
${LOCALBASE}/include/expat.h:${PORTSDIR}/textproc/expat2
-CONFIGURE_ARGS= --disable-java --disable-python --disable-swig \
+OPTIONS_DEFINE= SWIG
+
+CONFIGURE_ARGS= --disable-java --disable-python \
--with-expat-include-dir=${LOCALBASE}/include \
--with-expat-lib-dir=${LOCALBASE}/lib
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= gmake libtool
+SWIG_BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+SWIG_CONFIGURE_OFF= --disable-swig
+
post-patch:
@${REINPLACE_CMD} -e '/SWIG_VERSION:4/ s|:4|#*.*.|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} 's|-Werror||; s| -ansi -pedantic||' '{}' \;