aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-05 04:03:50 +0800
committermiwi <miwi@FreeBSD.org>2007-06-05 04:03:50 +0800
commit30aa8b9df40af77fe001fbf83303c161c518aa49 (patch)
treea5547837f64b869860fd8349cb0b979a0c794539 /science
parentda1b52e25c4d3d4b68b0633459a7e9f891c4b643 (diff)
downloadfreebsd-ports-gnome-30aa8b9df40af77fe001fbf83303c161c518aa49.tar.gz
freebsd-ports-gnome-30aa8b9df40af77fe001fbf83303c161c518aa49.tar.zst
freebsd-ports-gnome-30aa8b9df40af77fe001fbf83303c161c518aa49.zip
- Unbreak
- Fix build with gcc4 PR: 113303 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'science')
-rw-r--r--science/euler/Makefile4
-rw-r--r--science/euler/files/patch-src__command.c11
2 files changed, 11 insertions, 4 deletions
diff --git a/science/euler/Makefile b/science/euler/Makefile
index 40e2cf4f1d64..de2cf5cad013 100644
--- a/science/euler/Makefile
+++ b/science/euler/Makefile
@@ -22,10 +22,6 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g ; \
/^install-data-am/s|install-eulerdocDATA||g' ${WRKSRC}/Makefile.in
diff --git a/science/euler/files/patch-src__command.c b/science/euler/files/patch-src__command.c
new file mode 100644
index 000000000000..62f4817a1983
--- /dev/null
+++ b/science/euler/files/patch-src__command.c
@@ -0,0 +1,11 @@
+--- src/command.c.orig Mon Oct 24 09:38:24 2005
++++ src/command.c Sun May 27 14:08:14 2007
+@@ -732,7 +732,7 @@
+ }
+
+
+-static int command_count;
++int command_count;
+
+ commandtyp command_list[] = {
+ {"quit",c_quit,do_quit},