aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-06-16 03:08:39 +0800
committermandree <mandree@FreeBSD.org>2013-06-16 03:08:39 +0800
commit3e7d54f818cc65c2b690265caa00f7a37d0a7f3f (patch)
treea7dd21edb72861b4ec5ffce8d404d69bab72a607 /science
parent8182dca82cb15ab64e0c41d9edb78552a5d36e86 (diff)
downloadfreebsd-ports-gnome-3e7d54f818cc65c2b690265caa00f7a37d0a7f3f.tar.gz
freebsd-ports-gnome-3e7d54f818cc65c2b690265caa00f7a37d0a7f3f.tar.zst
freebsd-ports-gnome-3e7d54f818cc65c2b690265caa00f7a37d0a7f3f.zip
Add new port science/py-coards:
Coards is a parser for time values represented using the COADS convention. WWW: https://pypi.python.org/pypi/coards PR: ports/179576 Submitted by: Johannes Meixner <xmj@chaot.net>
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-coards/Makefile19
-rw-r--r--science/py-coards/distinfo2
-rw-r--r--science/py-coards/pkg-descr3
-rw-r--r--science/py-coards/pkg-plist13
5 files changed, 38 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 0549c3a8ff6f..66b6c2828cac 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -152,6 +152,7 @@
SUBDIR += psi3
SUBDIR += psychopy
SUBDIR += py-DendroPy
+ SUBDIR += py-coards
SUBDIR += py-h5py
SUBDIR += py-hcluster
SUBDIR += py-mdp
diff --git a/science/py-coards/Makefile b/science/py-coards/Makefile
new file mode 100644
index 000000000000..9af6ef765511
--- /dev/null
+++ b/science/py-coards/Makefile
@@ -0,0 +1,19 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= coards
+PORTVERSION= 1.0.5
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= A COADS compliant time parser
+
+LICENSE= MIT
+
+USE_PYTHON= 2.7
+USE_PYDISTUTILS= easy_install
+#PYDISTUTILS_NOEGGINFO= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-coards/distinfo b/science/py-coards/distinfo
new file mode 100644
index 000000000000..1ddda7e06e0d
--- /dev/null
+++ b/science/py-coards/distinfo
@@ -0,0 +1,2 @@
+SHA256 (coards-1.0.5.tar.gz) = f870b614288e7f93c8f545cb21ec27fd5abd0c0e25ab1f4677524a95ba7bcfd7
+SIZE (coards-1.0.5.tar.gz) = 4658
diff --git a/science/py-coards/pkg-descr b/science/py-coards/pkg-descr
new file mode 100644
index 000000000000..6ecb93479dc2
--- /dev/null
+++ b/science/py-coards/pkg-descr
@@ -0,0 +1,3 @@
+Coards is a parser for time values represented using the COADS convention.
+
+WWW: https://pypi.python.org/pypi/coards
diff --git a/science/py-coards/pkg-plist b/science/py-coards/pkg-plist
new file mode 100644
index 000000000000..c7e6b622e4f9
--- /dev/null
+++ b/science/py-coards/pkg-plist
@@ -0,0 +1,13 @@
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/coards/__init__.py
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/coards/__init__.pyc
+%%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/coards/__init__.pyo
+bin/coards
+@dirrmtry %%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/coards
+@dirrmtry %%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg/EGG-INFO
+@dirrmtry %%PYTHON_SITELIBDIR%%/coards-1.0.5-py2.7.egg