aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-05-23 00:19:03 +0800
committermakc <makc@FreeBSD.org>2010-05-23 00:19:03 +0800
commit4da68648d82bc2084aa70f61fc94373f2f827b46 (patch)
treef9352f1bb3d70d862df062cfbe8dec1b6c830d75 /science
parent55530eab54a1457415504ac3267f17f61b745c96 (diff)
downloadfreebsd-ports-gnome-4da68648d82bc2084aa70f61fc94373f2f827b46.tar.gz
freebsd-ports-gnome-4da68648d82bc2084aa70f61fc94373f2f827b46.tar.zst
freebsd-ports-gnome-4da68648d82bc2084aa70f61fc94373f2f827b46.zip
Add optional dependency on kdebase3
Diffstat (limited to 'science')
-rw-r--r--science/kst/Makefile9
-rw-r--r--science/kst2/Makefile9
2 files changed, 14 insertions, 4 deletions
diff --git a/science/kst/Makefile b/science/kst/Makefile
index 036ba51dec48..e9ebb211cbd7 100644
--- a/science/kst/Makefile
+++ b/science/kst/Makefile
@@ -24,8 +24,9 @@ USE_LDCONFIG= yes
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= NETCDF "Enable netcdf file support" off \
- CDF "Enable cdf file support" off
+OPTIONS= NETCDF "Enable netcdf data support" off \
+ CDF "Enable cdf data support" off \
+ KDEBASE "Enable JavaScript console" off
MAN1= kst.1
@@ -48,6 +49,10 @@ CONFIGURE_ARGS+= --without-cdf
PLIST_SUB+= CDF="@comment "
.endif
+.if defined(WITH_KDEBASE)
+RUN_DEPENDS+= ${KDE_PREFIX}/lib/kde3/libkonsolepart.so:${PORTSDIR}/x11/kdebase3
+.endif
+
pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${SH} admin/cvs.sh dist)
@${REINPLACE_CMD} -e 's|@kde_widgetdir@|@prefix@/lib/kde3/plugins/designer|' \
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 036ba51dec48..e9ebb211cbd7 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -24,8 +24,9 @@ USE_LDCONFIG= yes
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= NETCDF "Enable netcdf file support" off \
- CDF "Enable cdf file support" off
+OPTIONS= NETCDF "Enable netcdf data support" off \
+ CDF "Enable cdf data support" off \
+ KDEBASE "Enable JavaScript console" off
MAN1= kst.1
@@ -48,6 +49,10 @@ CONFIGURE_ARGS+= --without-cdf
PLIST_SUB+= CDF="@comment "
.endif
+.if defined(WITH_KDEBASE)
+RUN_DEPENDS+= ${KDE_PREFIX}/lib/kde3/libkonsolepart.so:${PORTSDIR}/x11/kdebase3
+.endif
+
pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${SH} admin/cvs.sh dist)
@${REINPLACE_CMD} -e 's|@kde_widgetdir@|@prefix@/lib/kde3/plugins/designer|' \