aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-03-06 20:18:15 +0800
committermaho <maho@FreeBSD.org>2007-03-06 20:18:15 +0800
commit5722a6017e14f9f62935f915c244fb255ee2e649 (patch)
tree1948f3cfc9e9392b2c12155e5a3816e0402b45e8 /science
parentb9329abd6b0fa9d2df7f3dc7612ebee7e3552266 (diff)
downloadfreebsd-ports-gnome-5722a6017e14f9f62935f915c244fb255ee2e649.tar.gz
freebsd-ports-gnome-5722a6017e14f9f62935f915c244fb255ee2e649.tar.zst
freebsd-ports-gnome-5722a6017e14f9f62935f915c244fb255ee2e649.zip
Build fix.
Spotted by: pointyhat
Diffstat (limited to 'science')
-rw-r--r--science/elmer-fem/Makefile16
-rw-r--r--science/elmer-fem/files/patch-configure.in8
-rw-r--r--science/elmer-fem/pkg-plist10
3 files changed, 24 insertions, 10 deletions
diff --git a/science/elmer-fem/Makefile b/science/elmer-fem/Makefile
index af63f8a1eb32..244548667a88 100644
--- a/science/elmer-fem/Makefile
+++ b/science/elmer-fem/Makefile
@@ -18,7 +18,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libmatc.a:${PORTSDIR}/science/elmer-matc \
${LOCALBASE}/lib/libeiof.a:${PORTSDIR}/science/elmer-eio \
${LOCALBASE}/lib/libhuti.a:${PORTSDIR}/science/elmer-hutiter \
${LOCALBASE}/lib/libumfpack_elmer.a:${PORTSDIR}/math/elmer-umfpack
-
RUN_DEPENDS= ElmerGrid:${PORTSDIR}/science/elmergrid \
Mesh2D:${PORTSDIR}/science/elmer-meshgen2d
@@ -62,12 +61,17 @@ CFLAGS+= -fPIC
FCFLAGS+= -fPIC
FFLAGS+= -fPIC ${FCFLAGS}
.endif
-CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FCFLAGS="${FCFLAGS}"
-CONFIGURE_ARGS+= --with-umfpack="-L${LOCALBASE}/lib -lumfpack_elmer" \
- --with-blas="-L${LOCALBASE}/lib ${BLAS}" \
- --with-lapack="-L${LOCALBASE}/lib ${LAPACK}" \
- --with-eiof="-L${LOCALBASE}/lib -leiof"
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FCFLAGS="${FCFLAGS}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" CFLAGS="${CFLAGS}"
+CONFIGURE_ARGS+= --with-umfpack="-lumfpack_elmer" \
+ --with-blas="${BLAS}" \
+ --with-lapack="${LAPACK}" \
+ --with-eiof="-leiof" \
+ --with-matc="-lmatc -lm"
pre-configure:
${REINPLACE_CMD} -e 's|make|${GMAKE}|g' ${WRKSRC}/tests/runtests.in
diff --git a/science/elmer-fem/files/patch-configure.in b/science/elmer-fem/files/patch-configure.in
index 3db42222e6a3..6fd49a53af6b 100644
--- a/science/elmer-fem/files/patch-configure.in
+++ b/science/elmer-fem/files/patch-configure.in
@@ -1,11 +1,11 @@
--- configure.in.orig Wed Feb 15 18:56:07 2006
+++ configure.in Wed Feb 15 18:56:45 2006
-@@ -68,7 +68,7 @@
- FCFLAGS="$FCFLAGS -I."
- FFLAGS="$FCFLAGS -I."
+@@ -69,7 +69,7 @@
+ FCFLAGS="$FCFLAGS -I. ${INCLUDE_MODULE_FLAG}binio"
+ FFLAGS="$FFLAGS -I."
ELMER_HOME="$prefix"
-FCPPFLAGS="-P $TRADITIONAL_CPP_FLAGS -I. -I$prefix/include -DFULL_INDUCTION -DUSE_ARPACK"
-+FCPPFLAGS="-P -traditional -I. -I$prefix/include -DFULL_INDUCTION -DUSE_ARPACK"
++FCPPFLAGS="-P -traditional -I. $CPPFLAGS -I$prefix/include -DFULL_INDUCTION -DUSE_ARPACK"
TESTS_FCFLAGS=""
ELMER_LIBERRORMSG="wasn't found, make sure it is in the prefix, or CFLAGS and LIBS are correct if they are somewhere else."
diff --git a/science/elmer-fem/pkg-plist b/science/elmer-fem/pkg-plist
index 9ead7d9bc50f..8a144ab36a18 100644
--- a/science/elmer-fem/pkg-plist
+++ b/science/elmer-fem/pkg-plist
@@ -4,6 +4,7 @@ bin/GebhardtFactors
bin/ViewFactors
bin/elmerf90
lib/libelmersolver.so
+include/binio.mod
%%DATADIR%%/include/adaptive.mod
%%DATADIR%%/include/bandmatrix.mod
%%DATADIR%%/include/bandwidthoptimize.mod
@@ -56,6 +57,10 @@ lib/libelmersolver.so
%%DATADIR%%/include/timeintegrate.mod
%%DATADIR%%/include/types.mod
%%DATADIR%%/include/viewfactorglobals.mod
+%%DATADIR%%/include/dxfile.mod
+%%DATADIR%%/include/exchangecorrelations.mod
+%%DATADIR%%/include/harmonicsolve.mod
+%%DATADIR%%/include/vtklegacyfile.mod
%%DATADIR%%/lib/AdvectionDiffusion.so
%%DATADIR%%/lib/ArteryOutlet.so
%%DATADIR%%/lib/ArtificialCompressibility.so
@@ -95,6 +100,11 @@ lib/libelmersolver.so
%%DATADIR%%/lib/TransportEquation.so
%%DATADIR%%/lib/elements.def
%%DATADIR%%/lib/libelmersolver.so
+%%DATADIR%%/lib/DFTSolver.so
+%%DATADIR%%/lib/FlowSolve.so
+%%DATADIR%%/lib/HeatSolve.so
+%%DATADIR%%/lib/MeshSolve.so
+%%DATADIR%%/lib/ShellSolve.so
@dirrm %%DATADIR%%/lib
@dirrm %%DATADIR%%/include
@dirrm %%DATADIR%%