aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-09-06 05:09:25 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-09-06 05:09:25 +0800
commit7e4df7f77be72c7a83810a760754605d3c1eb7a4 (patch)
tree951e99527457a8746cc3808144048996c56bf2ed /science
parent0997105edddb7d6dd6c276321370968df04fcc24 (diff)
downloadfreebsd-ports-gnome-7e4df7f77be72c7a83810a760754605d3c1eb7a4.tar.gz
freebsd-ports-gnome-7e4df7f77be72c7a83810a760754605d3c1eb7a4.tar.zst
freebsd-ports-gnome-7e4df7f77be72c7a83810a760754605d3c1eb7a4.zip
- Add experimental option for Chaco.
- Remove BROKEN for Metis option: it builds fine - Remove BROKENness for 4.x, we don't check that anymore. PR: 126696 Submitted by: Pedro Giffuni <pfgshield-freebsd at yahoo dot com>
Diffstat (limited to 'science')
-rw-r--r--science/mbdyn/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index e8dd0e62b97a..4afb76549d35 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mbdyn
PORTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.aero.polimi.it/~masarati/Download/mbdyn/
@@ -34,6 +35,7 @@ MAN1= mbdyn.1
OPTIONS= MPI "Enable mpich-support" off \
METIS "Enable metis-support" off \
+ CHACO "Enable chaco-support" off \
GINAC "Enable GiNaC-support (not implemented yet)" off \
TCL "Enable tcl-support (not implemented yet)" off
@@ -64,7 +66,6 @@ CONFIGURE_ARGS+= --with-mpi=no
.endif
.if defined(WITH_METIS)
-BROKEN= Does not compile with metis enabled
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
CONFIGURE_ARGS+= --with-metis=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
@@ -72,6 +73,13 @@ CPPFLAGS+= -I${LOCALBASE}/include/metis
CONFIGURE_ARGS+= --with-metis=no
.endif
+.if defined(WITH_CHACO)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libchaco.a:${PORTSDIR}/math/chaco
+CONFIGURE_ARGS+= --with-chaco=yes
+.else
+CONFIGURE_ARGS+= --with-chaco=no
+.endif
+
.if defined(WITH_GINAC)
IGNORE= you enabled GiNaC-support, which is not implemented yet
#BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
@@ -94,8 +102,4 @@ CONFIGURE_ARGS+= --with-tcl=no
BROKEN= Does not compile
.endif
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
.include <bsd.port.post.mk>