aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-28 17:46:15 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-28 17:46:15 +0800
commiteb1469cfdd934ec4332e3a09fdc295c2fcfe80c2 (patch)
tree6b7869be0ff931f5c76e267290a4763ddc1f5099 /science
parent92d8451007a3b28886c512060a5e7d97e7393bf4 (diff)
downloadfreebsd-ports-gnome-eb1469cfdd934ec4332e3a09fdc295c2fcfe80c2.tar.gz
freebsd-ports-gnome-eb1469cfdd934ec4332e3a09fdc295c2fcfe80c2.tar.zst
freebsd-ports-gnome-eb1469cfdd934ec4332e3a09fdc295c2fcfe80c2.zip
- Tighten Makefile header and COMMENT
- Convert to OptionsNG (docs, examples) - Unbreak parallel builds (-jX) - Minor Makefile and pkg-descr cleanups Reported by: pointyhat-west
Diffstat (limited to 'science')
-rw-r--r--science/fastcap/Makefile35
-rw-r--r--science/fastcap/pkg-descr6
2 files changed, 22 insertions, 19 deletions
diff --git a/science/fastcap/Makefile b/science/fastcap/Makefile
index 34051281d94a..f94f6612dffb 100644
--- a/science/fastcap/Makefile
+++ b/science/fastcap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: FastCap
-# Date created: 5 Jan 2006
-# Whom: Pedro Giffuni <giffunip@asme.org>
-#
+# Created by: Pedro Giffuni <giffunip@asme.org>
# $FreeBSD$
-#
PORTNAME= fastcap
DISTVERSION= 2.0wr-011109
@@ -11,7 +7,7 @@ CATEGORIES= science cad
MASTER_SITES= http://www.wrcad.com/ftp/pub/ LOCAL/bf
MAINTAINER= bf@FreeBSD.org
-COMMENT= A three-dimensional capacitance extraction program
+COMMENT= Three-dimensional capacitance extraction program
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
@@ -19,31 +15,38 @@ WRKSRC = ${WRKDIR}/fastcap-2.0wr
BINFILES= busgen capgen cubegen fastcap pipedgen pyragen
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,TYPE=other,TYPE=4,' \
${WRKSRC}/config
@${REINPLACE_CMD} -Ee '/CFLAGS =/{s/=/+=/;s/-O[[:digit:]]*//;}' \
${WRKSRC}/src/Makefile.4
-#minimal changes to fix the clang build (there should be a more thorough
-#clean-up, to correct types of functions, remove implicit declarations, fix
-#formatting, add missing returns, etc.)
+# Minimal changes to fix the Clang build (there should be a more thorough
+# clean-up, to correct types of functions, remove implicit declarations, fix
+# formatting, add missing returns, etc.)
@${REINPLACE_CMD} -E -e 's,^mul(Up|Down),void &,' \
${WRKSRC}/src/mulDo.c
@${REINPLACE_CMD} -e 's,^mulMatUp,void &,' \
${WRKSRC}/src/mulMats.c
@${REINPLACE_CMD} -e 's,^static getnbrs,static void getnbrs,' \
${WRKSRC}/src/mulSetup.c
+# Change "cd foo ; $(MAKE)" into "$(MAKE) -C foo" to unbreak parallel builds
+ @${REINPLACE_CMD} -E 's,cd (.+) ; (\$$\(MAKE\)),\2 -C \1,' \
+ ${WRKSRC}/Makefile
+# Avoid clashing of generated temporary files, crucial for parallel builds
+ @${REINPLACE_CMD} -e 's,temp\.out,$$@.&,' ${WRKSRC}/src/Makefile*
do-install:
-.for b in ${BINFILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/${b} ${PREFIX}/bin/
-.endfor
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/bin/,} ${PREFIX}/bin
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
${CAT} ${WRKSRC}/README ${WRKSRC}/README.mit > ${DOCSDIR}/readme
${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${DOCSDIR}
${GZIP_CMD} ${DOCSDIR}/*
diff --git a/science/fastcap/pkg-descr b/science/fastcap/pkg-descr
index 324fd8bfcae3..58a0738eca67 100644
--- a/science/fastcap/pkg-descr
+++ b/science/fastcap/pkg-descr
@@ -12,9 +12,9 @@ from the boundary-element discretization is solved using a
generalized conjugate residual algorithm with a fast multipole
algorithm to efficiently compute the iterates.
----------------------
+---------------------
This version of fastcap has been cleaned up and enhanced by Stephen R.
Whiteley of Whitleley Research Inc.
----------------------
+---------------------
-WWW: http://www.rle.mit.edu/cpg/research_codes.htm
+WWW: http://www.rle.mit.edu/cpg/research_codes.htm