aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-05-31 12:51:46 +0800
committernovel <novel@FreeBSD.org>2006-05-31 12:51:46 +0800
commitec1f5d3443cc4711fc90043234014ae2afe73015 (patch)
tree3b547e7b61af2ab4d7941519051dd78405045e07 /science
parent8aa1b2289ff6a2fdf89cc9a3e843b14b13b4ac23 (diff)
downloadfreebsd-ports-gnome-ec1f5d3443cc4711fc90043234014ae2afe73015.tar.gz
freebsd-ports-gnome-ec1f5d3443cc4711fc90043234014ae2afe73015.tar.zst
freebsd-ports-gnome-ec1f5d3443cc4711fc90043234014ae2afe73015.zip
Add WITH_OPTIMIZED_FLAGS knob.
PR: 98124 Submitted by: Pedro F. Giffuni (maintainer)
Diffstat (limited to 'science')
-rw-r--r--science/elmer-fem/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/science/elmer-fem/Makefile b/science/elmer-fem/Makefile
index caafaef05332..6c539913b40d 100644
--- a/science/elmer-fem/Makefile
+++ b/science/elmer-fem/Makefile
@@ -29,9 +29,13 @@ WITH_FORTRAN= yes
FC= ${LOCALBASE}/bin/gfortran41
F77= ${FC}
+.ifdef WITH_OPTIMIZED_FLAGS
+FCFLAGS+= -O3 -ffast-math -funroll-loops
+.endif
+
USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS=${FCFLAGS}
+CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS="${FCFLAGS}"
USE_GMAKE= yes
ALL_TARGET=
INSTALLS_SHLIB= yes