aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-07 22:36:55 +0800
committermiwi <miwi@FreeBSD.org>2013-02-07 22:36:55 +0800
commitf2d0c0617027be263d88a1fd26494d897f35549e (patch)
tree4300b5acd73b899da0dc1322ac1abb90b3a34cee /science
parent422737a797e9bb26409b73b2730ae57d0d4a0849 (diff)
downloadfreebsd-ports-gnome-f2d0c0617027be263d88a1fd26494d897f35549e.tar.gz
freebsd-ports-gnome-f2d0c0617027be263d88a1fd26494d897f35549e.tar.zst
freebsd-ports-gnome-f2d0c0617027be263d88a1fd26494d897f35549e.zip
- Fix build with clang
PR: 175022 Submitted by: Ports Fury
Diffstat (limited to 'science')
-rw-r--r--science/linsmith/Makefile14
-rw-r--r--science/linsmith/files/patch-src__element.c10
-rw-r--r--science/linsmith/files/patch-src__remote.c11
-rw-r--r--science/linsmith/pkg-plist3
4 files changed, 35 insertions, 3 deletions
diff --git a/science/linsmith/Makefile b/science/linsmith/Makefile
index e96574469fe3..fc09e26a4604 100644
--- a/science/linsmith/Makefile
+++ b/science/linsmith/Makefile
@@ -3,26 +3,34 @@
PORTNAME= linsmith
PORTVERSION= 0.99.24
+PORTREVISION= 1
CATEGORIES= science hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Smith charting program
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv2 # (or later)
USE_GNOME= libgnomeui libxml2
USE_ICONV= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-USE_GCC= any
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${CP} ${FILESDIR}/carg.c ${WRKSRC}/src
+ @${REINPLACE_CMD} -e \
+ '/^Icon/s|=.*|=linsmith_icon|' ${WRKSRC}/linsmith.desktop
+
+post-install:
+ @${MKDIR} ${DESKTOPDIR}
+ (cd ${WRKSRC} \
+ && ${INSTALL_DATA} linsmith.desktop ${DESKTOPDIR})
+ (cd ${WRKSRC} \
+ && ${INSTALL_DATA} linsmith_icon.xpm ${PREFIX}/share/pixmaps)
.include <bsd.port.mk>
diff --git a/science/linsmith/files/patch-src__element.c b/science/linsmith/files/patch-src__element.c
new file mode 100644
index 000000000000..1fb63328b900
--- /dev/null
+++ b/science/linsmith/files/patch-src__element.c
@@ -0,0 +1,10 @@
+--- src/element.c.orig 2011-06-23 01:10:42.000000000 +0900
++++ src/element.c 2012-10-21 04:47:51.000000000 +0900
+@@ -306,6 +306,7 @@
+ }
+
+
++void
+ clear_element_lnlist(chart_lnlist *lnlst)
+ {
+ GList *l;
diff --git a/science/linsmith/files/patch-src__remote.c b/science/linsmith/files/patch-src__remote.c
new file mode 100644
index 000000000000..97cfd317541b
--- /dev/null
+++ b/science/linsmith/files/patch-src__remote.c
@@ -0,0 +1,11 @@
+--- src/remote.c.orig 2007-11-12 12:09:03.000000000 +0900
++++ src/remote.c 2012-10-21 04:50:16.000000000 +0900
+@@ -36,7 +36,7 @@
+ remove_fifos(gpointer data)
+ {
+ // if not even enabled manually, just go away
+- if (pref.rem_mode != REMOTE_SOCK) return;
++ if (pref.rem_mode != REMOTE_SOCK) return 0;
+
+ printf("Removing the remote pipes\n");
+ close(pref.inpipe);
diff --git a/science/linsmith/pkg-plist b/science/linsmith/pkg-plist
index 4241d68ea1f3..377779dd9cd3 100644
--- a/science/linsmith/pkg-plist
+++ b/science/linsmith/pkg-plist
@@ -1,4 +1,5 @@
bin/linsmith
+share/applications/linsmith.desktop
%%DATADIR%%/6-1.circ
%%DATADIR%%/6-4.circ
%%DATADIR%%/6-4.load
@@ -20,7 +21,9 @@ share/locale/hu/LC_MESSAGES/linsmith.mo
share/locale/it/LC_MESSAGES/linsmith.mo
share/locale/sv/LC_MESSAGES/linsmith.mo
share/locale/zh/LC_MESSAGES/linsmith.mo
+share/pixmaps/linsmith_icon.xpm
share/pixmaps/linsmith/smith4.png
share/pixmaps/linsmith/smithent.png
@dirrm share/pixmaps/linsmith
@dirrm %%DATADIR%%
+@dirrmtry share/applications