aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2007-02-11 02:41:54 +0800
committernivit <nivit@FreeBSD.org>2007-02-11 02:41:54 +0800
commitf456de1599e55bc6b207aaac19ba241ca66be9da (patch)
tree075109124709846ea7c71af6cf0f3f684bc02de6 /science
parent8d8815422854d4ba03a0453dc12c57ca8954f8fe (diff)
downloadfreebsd-ports-gnome-f456de1599e55bc6b207aaac19ba241ca66be9da.tar.gz
freebsd-ports-gnome-f456de1599e55bc6b207aaac19ba241ca66be9da.tar.zst
freebsd-ports-gnome-f456de1599e55bc6b207aaac19ba241ca66be9da.zip
- Fixed build after objformat removal
PR: ports/108982 Submitted by: CHAO Shin <quake at cn.freebsd.org> Approved by: alexbl (mentor, implicit), Quincey Koziol <koziol at hdfgroup.org> (maintainer)
Diffstat (limited to 'science')
-rw-r--r--science/hdf5-18/Makefile7
-rw-r--r--science/hdf5/Makefile7
2 files changed, 12 insertions, 2 deletions
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index 16b597eb7688..9fef5beb71a6 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= ftp://hdf.ncsa.uiuc.edu/pub/outgoing/hdf5/${PORTVERSION}/
MAINTAINER= koziol@ncsa.uiuc.edu
COMMENT= Hierarchical Data Format library (from NCSA)
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
LIBTOOLFILES= configure c++/configure
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -21,7 +23,6 @@ CONFIGURE_ARGS= --enable-cxx --enable-production \
--enable-threadsafe --disable-debug \
--with-pthread
ALL_TARGET= lib progs
-INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -34,6 +35,10 @@ post-patch:
s|[\$$]LDFLAGS -pthread|\$$LDFLAGS ${PTHREAD_LIBS}|g' \
${WRKSRC}/c++/config/freebsd
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/config/gnu-flags
+ @${REINPLACE_CMD} -e 's|objformat=|#objformat=|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|objformat=|#objformat=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/version_type=freebsd-/s|=.*|=freebsd-elf|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e '/version_type=freebsd-/s|=.*|=freebsd-elf|g' ${WRKSRC}/configure
post-install:
.for i in gif2h5 h52gif h5debug h5diff h5dump h5import h5ls h5repart h5jam h5unjam
diff --git a/science/hdf5/Makefile b/science/hdf5/Makefile
index 16b597eb7688..9fef5beb71a6 100644
--- a/science/hdf5/Makefile
+++ b/science/hdf5/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= ftp://hdf.ncsa.uiuc.edu/pub/outgoing/hdf5/${PORTVERSION}/
MAINTAINER= koziol@ncsa.uiuc.edu
COMMENT= Hierarchical Data Format library (from NCSA)
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
LIBTOOLFILES= configure c++/configure
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -21,7 +23,6 @@ CONFIGURE_ARGS= --enable-cxx --enable-production \
--enable-threadsafe --disable-debug \
--with-pthread
ALL_TARGET= lib progs
-INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -34,6 +35,10 @@ post-patch:
s|[\$$]LDFLAGS -pthread|\$$LDFLAGS ${PTHREAD_LIBS}|g' \
${WRKSRC}/c++/config/freebsd
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/config/gnu-flags
+ @${REINPLACE_CMD} -e 's|objformat=|#objformat=|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|objformat=|#objformat=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/version_type=freebsd-/s|=.*|=freebsd-elf|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e '/version_type=freebsd-/s|=.*|=freebsd-elf|g' ${WRKSRC}/configure
post-install:
.for i in gif2h5 h52gif h5debug h5diff h5dump h5import h5ls h5repart h5jam h5unjam