aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
commitf6763c3cd1541b5d51cd003610210be9e3f57b92 (patch)
treec9a458d29164af55be5bf3330f3f659428ac04ac /science
parentffc02588e890cf8d01b2305cfb96dbb0eaf038a8 (diff)
downloadfreebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.gz
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.zst
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Diffstat (limited to 'science')
-rw-r--r--science/clhep/Makefile10
-rw-r--r--science/libxc/Makefile9
-rw-r--r--science/meep/Makefile4
3 files changed, 2 insertions, 21 deletions
diff --git a/science/clhep/Makefile b/science/clhep/Makefile
index 75483ce3b3fe..a11426377a8b 100644
--- a/science/clhep/Makefile
+++ b/science/clhep/Makefile
@@ -15,20 +15,12 @@ LICENSE_COMB= multi
WRKSRC= ${WRKDIR}/${PORTVERSION}/${PORTNAME:tu}
-USES= cmake:outsource perl5 tar:tgz
+USES= cmake:outsource compiler:openmp perl5 tar:tgz
USE_PERL5= build
USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} < 1000000
-USES+= compiler:c++11-lib
-.else
-USES+= compiler:openmp
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
'/DESTINATION/s|lib$${LIB_SUFFIX}|libdata|' \
diff --git a/science/libxc/Makefile b/science/libxc/Makefile
index 7c83d4a0502f..3587abff5f3c 100644
--- a/science/libxc/Makefile
+++ b/science/libxc/Makefile
@@ -24,11 +24,4 @@ post-patch:
@${REINPLACE_CMD} -e '/^pkgconfigdir =/s,libdir),prefix)/libdata,' \
${WRKSRC}/build/Makefile.in
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000034
-LIB_DEPENDS+= libml.so:math/ldouble
-LDFLAGS+= -lml
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/meep/Makefile b/science/meep/Makefile
index 1668d61d39bf..fcc5e8f90b4b 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -33,11 +33,7 @@ OPENMPI_DESC= MPI support (with OpenMPI)
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD
-. if ${OSVERSION} < 1000000
-MPI_DEFAULT= OPENMPI
-. else
MPI_DEFAULT= MPICH2
-. endif
.endif
.if ${PORT_OPTIONS:MMPICH2} || ${PORT_OPTIONS:MOPENMPI}