aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2007-05-27 11:03:31 +0800
committerkris <kris@FreeBSD.org>2007-05-27 11:03:31 +0800
commit3ee20a81fbe38cbba4000ad893e1ac81e953f2eb (patch)
tree965567cbb664ce2d1956915bd4daa13e8e6e1241 /science
parent0ccd4067feff5266b8b5bc29943d9c4ca415e847 (diff)
downloadfreebsd-ports-gnome-3ee20a81fbe38cbba4000ad893e1ac81e953f2eb.tar.gz
freebsd-ports-gnome-3ee20a81fbe38cbba4000ad893e1ac81e953f2eb.tar.zst
freebsd-ports-gnome-3ee20a81fbe38cbba4000ad893e1ac81e953f2eb.zip
BROKEN with gcc 4.2
Diffstat (limited to 'science')
-rw-r--r--science/euler/Makefile8
-rw-r--r--science/oof/Makefile4
2 files changed, 11 insertions, 1 deletions
diff --git a/science/euler/Makefile b/science/euler/Makefile
index 68dbbf54d978..40e2cf4f1d64 100644
--- a/science/euler/Makefile
+++ b/science/euler/Makefile
@@ -20,6 +20,12 @@ COMMENT= A program computes with real and complex numbers and matrices
USE_GNOME= gnometarget gtk20
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g ; \
/^install-data-am/s|install-eulerdocDATA||g' ${WRKSRC}/Makefile.in
@@ -36,4 +42,4 @@ post-install:
@${FIND} ${DOCSDIR} -type d | ${XARGS} ${CHMOD} ${BINMODE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/oof/Makefile b/science/oof/Makefile
index be5925e84a3f..1f240e8f818d 100644
--- a/science/oof/Makefile
+++ b/science/oof/Makefile
@@ -54,6 +54,10 @@ PLIST_FILES+= bin/oof2abaqus
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if ${ARCH}==sparc64
BROKEN= does not compile on ${ARCH}
.endif