aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorpkubaj <pkubaj@FreeBSD.org>2019-04-27 17:30:30 +0800
committerpkubaj <pkubaj@FreeBSD.org>2019-04-27 17:30:30 +0800
commit3efcb49af1dc8fdad05e9c80505dcffe890e8c03 (patch)
treed458cd1744afc20e4f01e45808c1763bd43dc00d /science
parentdcf3a4eb49cc7780022a63a37e39a2d69d1c9bcd (diff)
downloadfreebsd-ports-gnome-3efcb49af1dc8fdad05e9c80505dcffe890e8c03.tar.gz
freebsd-ports-gnome-3efcb49af1dc8fdad05e9c80505dcffe890e8c03.tar.zst
freebsd-ports-gnome-3efcb49af1dc8fdad05e9c80505dcffe890e8c03.zip
science/ALPSCore: fix build with GCC-based architectures
CMake Error at common/cmake/ALPSCommonModuleDefinitions.cmake:194 (target_compile_features): target_compile_features The compiler feature "cxx_std_11" is not known to CXX compiler "GNU" version 4.2.1. Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D20049
Diffstat (limited to 'science')
-rw-r--r--science/ALPSCore/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/ALPSCore/Makefile b/science/ALPSCore/Makefile
index a7530f973c92..a52dbdefa1ff 100644
--- a/science/ALPSCore/Makefile
+++ b/science/ALPSCore/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libhdf5.so:science/hdf5 \
libsz.so:science/szip
-USES= cmake eigen:3
+USES= cmake compiler:c++11-lang eigen:3
USE_GITHUB= yes
USE_LDCONFIG= yes
TEST_TARGET= test # 2 to 3 tests fail: https://github.com/ALPSCore/ALPSCore/issues/388