aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-02-07 17:44:24 +0800
committerkoobs <koobs@FreeBSD.org>2016-02-07 17:44:24 +0800
commit47fb88746afd7df810cdbeb6f8f1a77e967d479c (patch)
treea9660575bd4e1aa34677dd31fe7a8823481df245 /science
parent9f1057f9d0f489dccea2cbd59aec2b83e937e93c (diff)
downloadfreebsd-ports-gnome-47fb88746afd7df810cdbeb6f8f1a77e967d479c.tar.gz
freebsd-ports-gnome-47fb88746afd7df810cdbeb6f8f1a77e967d479c.tar.zst
freebsd-ports-gnome-47fb88746afd7df810cdbeb6f8f1a77e967d479c.zip
graphics/py-graphviz: Move to py-pygraphviz, Fix 3.x build
There are numerous graphviz related packages in PyPI, including: graphviz, graphviz-python and pygraphviz. This port, py-graphviz, is not and does not provide the same package as the 'graphviz' package on PyPI (CHEESESHOP). Further, it blocks the creation of a correctly named py-graphviz port, is a POLA violation in terms of users expecting to find and recieve the package they expect based on a standard search, and is likely to create confusion among other ports if they depend on a python graphviz package, which could result in incorrect packages/dependencies. This is why among other reasons, Python packages should be named exactly what they are called in PyPI, or inside install_requires, setup_requires or tests_requires as dependencies in other packages. This change moves py-graphviz to py-pygraphviz to correct the above incorrect naming. While I'm here: - Remove backup (http) MASTER_SITES, CHEESESHOP is highly-available and provides a Geo-aware CDN by Fastly. - Remove {BUILD,RUN}_DEPENDS in favour of the actual LIB_DEPENDS - Use PYDISTUTILS_* framework variables to customise the build instead of hack patching setup.py - Enable autoplist, fixing builds on Python 3.x [1] - Enable concurrent (Python version) installation - Hack patch setup.py to preclude docs installation, as it adds a directory to --record and breaks pkg-plist output [2] - Remove DOCSDIR override (no longer necessary) - Assign MAINTAINER'ship to python@ - Add TEST_DEPENDS and test target - pkg-descr: Match WWW URL to setup.py:homepage field - pkg-descr: Improve package description text (matching upstream) While I'm sweeping dependencies: - Fix a typo in science/gramps: s|>-|>= [2] https://wiki.freebsd.org/Python (Open task for install_data bug) Reported by: Ben Woods (via IRC) [1]
Diffstat (limited to 'science')
-rw-r--r--science/gramps/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/gramps/Makefile b/science/gramps/Makefile
index 2a2a996ede7a..0175df874c6a 100644
--- a/science/gramps/Makefile
+++ b/science/gramps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gramps
PORTVERSION= 3.4.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science gnome python
MASTER_SITES= SF/${PORTNAME}/Stable/${PORTVERSION}
@@ -37,7 +37,7 @@ EXIV_DESC= Managing exiv metadata support
ENCHANT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enchant>=0:${PORTSDIR}/textproc/py-enchant
EXIV_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}exiv2>=0.1.3:${PORTSDIR}/graphics/py-exiv2
GNOME_USE= GNOME=pygnome2,gnomedocutils
-GRAPHVIZ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graphviz>-0:${PORTSDIR}/graphics/py-graphviz
+GRAPHVIZ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygraphviz>=0:${PORTSDIR}/graphics/py-pygraphviz
PYWEBKITGTK_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:${PORTSDIR}/www/py-webkitgtk
pre-extract: