aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-20 07:08:44 +0800
committermat <mat@FreeBSD.org>2013-11-20 07:08:44 +0800
commit57524a11df3f0950e857f0ffa06d8a160baa9437 (patch)
treeab8d23ab014eb4477219665648225ccea56d0295 /science
parent869dfb43fab6a3f2a51d1ab26c1b8cd6cf6e4a7a (diff)
downloadfreebsd-ports-gnome-57524a11df3f0950e857f0ffa06d8a160baa9437.tar.gz
freebsd-ports-gnome-57524a11df3f0950e857f0ffa06d8a160baa9437.tar.zst
freebsd-ports-gnome-57524a11df3f0950e857f0ffa06d8a160baa9437.zip
- Convert to dos2unix.mk
- While at it convert to gmake.mk ports that still USE_GMAKE.
Diffstat (limited to 'science')
-rw-r--r--science/hdf-java/Makefile3
-rw-r--r--science/py-netCDF4/Makefile3
2 files changed, 3 insertions, 3 deletions
diff --git a/science/hdf-java/Makefile b/science/hdf-java/Makefile
index 506f217d4546..1ad2cac7ab23 100644
--- a/science/hdf-java/Makefile
+++ b/science/hdf-java/Makefile
@@ -19,10 +19,9 @@ JAVA_VERSION= 1.6+
JAVA_BUILD= yes
JAVA_RUN= yes
-USE_DOS2UNIX= yes
+USES= dos2unix gmake
DOS2UNIX_REGEX= .*/examples/.*Makefile.in
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jdk=${JAVA_HOME}/include,${JAVA_HOME}/jre/lib/ \
--with-hdf5=${LOCALBASE}/include \
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
index 3027267504d4..516f1a865176 100644
--- a/science/py-netCDF4/Makefile
+++ b/science/py-netCDF4/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= ${PYNUMPY}
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_DOS2UNIX= utils/nc3tonc4
+USES= dos2unix
+DOS2UNIX_FILES= utils/nc3tonc4
USE_PYTHON= yes
USE_PYDISTUTILS= yes
MAKE_ENV= HDF5_INCDIR=${LOCALBASE}/include \