aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2019-04-25 03:35:06 +0800
committerthierry <thierry@FreeBSD.org>2019-04-25 03:35:06 +0800
commita671604c57a8b5cb841e0e81bcf4e6d964d72d4c (patch)
tree2873e75d3650964fc044ad67ff580acce8f594e6 /science
parent5dff5f45bfed177fac7156716d0ca8f966521526 (diff)
downloadfreebsd-ports-gnome-a671604c57a8b5cb841e0e81bcf4e6d964d72d4c.tar.gz
freebsd-ports-gnome-a671604c57a8b5cb841e0e81bcf4e6d964d72d4c.tar.zst
freebsd-ports-gnome-a671604c57a8b5cb841e0e81bcf4e6d964d72d4c.zip
Fix on head by setting LLD_UNSAFE:
ld: error: /usr/lib/libpmc.so: undefined reference to std::__1::__basic_string_common<true>::__throw_length_error() const ld: error: /usr/lib/libpmc.so: undefined reference to std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::append(char const*, unsigned long) cc: error: linker command failed with exit code 1 (use -v to see invocation) Since I'm here, add USES=gl.
Diffstat (limited to 'science')
-rw-r--r--science/medit/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/medit/Makefile b/science/medit/Makefile
index ccbdbbd3e588..47861d04abd7 100644
--- a/science/medit/Makefile
+++ b/science/medit/Makefile
@@ -21,12 +21,13 @@ BUILD_DEPENDS= ${LOCALBASE}/include/cfortran.h:lang/cfortran
USE_XORG= x11 xmu xext
USE_GL= glut
-USES= gmake tar:tgz
+USES= gl gmake tar:tgz
MAKEFILE= makefile
ALL_TARGET= ${OPSYS}
MAKE_ENV= WRKSRC="${WRKSRC}" ARCHI=${OPSYS} ARCH=${ARCH} OSREL=${OSREL}
NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
+LLD_UNSAFE= yes
LIBVERSION= ${PORTVERSION}
SOURCETARB= ${PORTNAME}.${PORTVERSION}${EXTRACT_SUFX}