aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
committerrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
commitb028b113ef13fa7972bb45d681d7a0abe47c40a6 (patch)
treea76a27ca09341f754b493c264ee71c912a553d89 /science
parent855b1df39bc3a6f03abf878d9c99b5ba0838ba35 (diff)
downloadfreebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.gz
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.zst
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Diffstat (limited to 'science')
-rw-r--r--science/gchemutils/Makefile1
-rw-r--r--science/gramps/Makefile1
-rw-r--r--science/gwyddion/Makefile3
-rw-r--r--science/netcdf/Makefile2
-rw-r--r--science/netcdf4/Makefile2
-rw-r--r--science/openbabel/Makefile1
-rw-r--r--science/pnetcdf/Makefile4
7 files changed, 5 insertions, 9 deletions
diff --git a/science/gchemutils/Makefile b/science/gchemutils/Makefile
index e156938d3232..2304a9ed8382 100644
--- a/science/gchemutils/Makefile
+++ b/science/gchemutils/Makefile
@@ -28,7 +28,6 @@ USE_GNOME= gnomehack intlhack libglade2 libgnomeprintui libgnomeui gnomedocutils
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
INSTALLS_ICONS= yes
GCONF_SCHEMAS= gcrystal.schemas
diff --git a/science/gramps/Makefile b/science/gramps/Makefile
index 5f5b6a808648..4221772bf002 100644
--- a/science/gramps/Makefile
+++ b/science/gramps/Makefile
@@ -25,7 +25,6 @@ USE_GNOME= gnomehack pygnome2 pygnomeextras desktopfileutils gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAN1= gramps.1
MANLANG= "" fr
diff --git a/science/gwyddion/Makefile b/science/gwyddion/Makefile
index 059d451baeeb..3a4c44fca5e3 100644
--- a/science/gwyddion/Makefile
+++ b/science/gwyddion/Makefile
@@ -26,8 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
- --disable-pascal --disable-pygwy \
- --mandir=${MANPREFIX}/man
+ --disable-pascal --disable-pygwy
MAKE_ARGS= pkgconfigdatadir=${PREFIX}/libdata/pkgconfig
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index e93513e47bbb..f800c436ba23 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -17,7 +17,7 @@ COMMENT= Library for machine-independent, array-oriented data access
CONFLICTS= hdf-4.*
-CONFIGURE_ARGS= --enable-shared --mandir=${PREFIX}/man --disable-f77
+CONFIGURE_ARGS= --enable-shared --disable-f77
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
USE_BZIP2= YES
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index e93513e47bbb..f800c436ba23 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -17,7 +17,7 @@ COMMENT= Library for machine-independent, array-oriented data access
CONFLICTS= hdf-4.*
-CONFIGURE_ARGS= --enable-shared --mandir=${PREFIX}/man --disable-f77
+CONFIGURE_ARGS= --enable-shared --disable-f77
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
USE_BZIP2= YES
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index 8e84c71b867f..0dc11ec0c506 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -18,7 +18,6 @@ COMMENT= Chemistry file translation program
USE_GCC= 3.4+
USE_GNOME= gnomehack gnometarget libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
USE_LDCONFIG= yes
MAN1= obchiral.1 obfit.1 obgrep.1 obprop.1 obrotate.1 openbabel.1
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index f869386bd0b4..38c6962325d8 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -38,12 +38,12 @@ MAN3= pnetcdf.3
.if defined(WITH_OPENMPI)
BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
-CONFIGURE_ARGS= --enable-shared --mandir=${PREFIX}/man --disable-f77 --with-mpi=${PREFIX}/mpi/openmpi
+CONFIGURE_ARGS= --enable-shared --disable-f77 --with-mpi=${PREFIX}/mpi/openmpi
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
.else
BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
RUN_DEPENDS+= ${LOCALBASE}/mpich2/lib/libmpich.so:${PORTSDIR}/net/mpich2
-CONFIGURE_ARGS= --enable-shared --mandir=${PREFIX}/man --disable-f77 --with-mpi=${PREFIX}/mpich2
+CONFIGURE_ARGS= --enable-shared --disable-f77 --with-mpi=${PREFIX}/mpich2
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
.endif