aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-22 09:15:19 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-22 09:15:19 +0800
commitc35b4e29d6d16a32622548a17d38815d59c59d9e (patch)
tree0c07443b478fb33416592bf0cae1d18b5907dd27 /science
parent4fa4a1e28574ef2665f5294de9c34240a7329a66 (diff)
downloadfreebsd-ports-gnome-c35b4e29d6d16a32622548a17d38815d59c59d9e.tar.gz
freebsd-ports-gnome-c35b4e29d6d16a32622548a17d38815d59c59d9e.tar.zst
freebsd-ports-gnome-c35b4e29d6d16a32622548a17d38815d59c59d9e.zip
Mark these ports as broken on aarch64, and, where appropriate, on armvX.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'science')
-rw-r--r--science/mpqc/Makefile2
-rw-r--r--science/py-dlib/Makefile4
2 files changed, 6 insertions, 0 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index cf0b995531dc..842cca794463 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Massively Parallel Quantum Chemistry Program
+BROKEN_aarch64= fails to compile: lapack.h:2:10: 'chemistry/qc/mbptr12/f77sym.h' file not found
+
LIB_DEPENDS= libint.so:science/libint
GNU_CONFIGURE= yes
diff --git a/science/py-dlib/Makefile b/science/py-dlib/Makefile
index 3e2ee49cb3b7..9065966acd24 100644
--- a/science/py-dlib/Makefile
+++ b/science/py-dlib/Makefile
@@ -12,6 +12,10 @@ COMMENT= Machine learning framework written in C++ (python bindings)
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/dlib/LICENSE.txt
+BROKEN_aarch64= fails to build: CMake Error at test_for_avx/CMakeLists.txt:17 (if): if given arguments: "EQUAL" "0" "AND" "compile_result": Unknown arguments specified
+BROKEN_armv6= fails to build: CMake Error at test_for_avx/CMakeLists.txt:17 (if): if given arguments: "EQUAL" "0" "AND" "compile_result": Unknown arguments specified
+BROKEN_armv7= fails to build: CMake Error at test_for_avx/CMakeLists.txt:17 (if): if given arguments: "EQUAL" "0" "AND" "compile_result": Unknown arguments specified
+
BUILD_DEPENDS= cmake:devel/cmake
LIB_DEPENDS= ${PY_BOOST}