aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2008-02-25 20:56:17 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2008-02-25 20:56:17 +0800
commitf13d72c698f7f6813a8f827d297ce76fbaaa14f9 (patch)
treeb0dc0fad287c9624f626c07530f4a076762be542 /science
parent82d99c8eed83fb3b4746d0aeb2f165cf8ec75950 (diff)
downloadfreebsd-ports-gnome-f13d72c698f7f6813a8f827d297ce76fbaaa14f9.tar.gz
freebsd-ports-gnome-f13d72c698f7f6813a8f827d297ce76fbaaa14f9.tar.zst
freebsd-ports-gnome-f13d72c698f7f6813a8f827d297ce76fbaaa14f9.zip
DTI visualization software from Stanford.
WWW: http://graphics.stanford.edu/projects/dti/ PR: ports/120129 Submitted by: Jason W. Bacon <jwbacon at tds.net>
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/dtiquery/Makefile65
-rw-r--r--science/dtiquery/distinfo3
-rw-r--r--science/dtiquery/files/dtiquery.135
-rw-r--r--science/dtiquery/files/patch-DTIQuery-Makefile13
-rw-r--r--science/dtiquery/files/patch-Makefile.definitions34
-rw-r--r--science/dtiquery/files/patch-precompute-Makefile13
-rw-r--r--science/dtiquery/files/pkg-message.in10
-rw-r--r--science/dtiquery/pkg-descr3
9 files changed, 177 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index caa20ca259d5..ebe08e4306c6 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -24,6 +24,7 @@
SUBDIR += dcl
SUBDIR += devisor
SUBDIR += dft++
+ SUBDIR += dtiquery
SUBDIR += ecs
SUBDIR += elmer-eio
SUBDIR += elmer-fem
diff --git a/science/dtiquery/Makefile b/science/dtiquery/Makefile
new file mode 100644
index 000000000000..aae83268b75a
--- /dev/null
+++ b/science/dtiquery/Makefile
@@ -0,0 +1,65 @@
+############################################################################
+# New ports collection Makefile for: DTI-Query
+# Date created: 10 July 2006
+# Whom: Jason W. Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+############################################################################
+
+PORTNAME= dtiquery
+PORTVERSION= 1.1
+CATEGORIES= science biology
+MASTER_SITES= http://graphics.stanford.edu/projects/dti/
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Stanford DTI Visualization tool
+
+BUILD_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt \
+ ${LOCALBASE}/include/tnt/jama_cholesky.h:${PORTSDIR}/math/jama \
+ ${LOCALBASE}/lib/libRAPID.a:${PORTSDIR}/math/rapid
+EXTRACT_DEPENDS= dos2unix:${PORTSDIR}/converters/unix2dos
+LIB_DEPENDS= wx_gtk2_core-2.8.0:${PORTSDIR}/x11-toolkits/wxgtk28 \
+ vtkCommon.5:${PORTSDIR}/math/vtk5
+
+CONFLICTS= dtiquery-1.0*
+
+RESTRICTED= Must register to download at http://graphics.stanford.edu/projects/dti/
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+USE_GMAKE= yes
+
+PLIST_FILES= bin/dtiquery \
+ bin/dtiprecompute_cmd \
+ bin/dtiprecompute_gui
+
+ALL_TARGET=
+
+MAN1= dtiquery.1 \
+ dtiprecompute_cmd.1 \
+ dtiprecompute_gui.1
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}.tar.gz)
+IGNORE= you must manually fetch ${DISTNAME}.tar.gz from http://graphics.stanford.edu/projects/dti/, place it in ${DISTDIR}, and then run make again
+.endif
+
+post-extract:
+ dos2unix ${WRKSRC}/*/Makefile ${WRKSRC}/Makefile*
+ ${REINPLACE_CMD} "s/zlib-1.2.2 RAPID201//g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/DTIQuery/dtiquery ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/precompute/dtiprecompute_cmd ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/precompute/dtiprecompute_gui ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/dtiquery.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${FILESDIR}/dtiquery.1 ${MAN1PREFIX}/man/man1/dtiprecompute_cmd.1
+ ${INSTALL_MAN} ${FILESDIR}/dtiquery.1 ${MAN1PREFIX}/man/man1/dtiprecompute_gui.1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/science/dtiquery/distinfo b/science/dtiquery/distinfo
new file mode 100644
index 000000000000..814db81f11bd
--- /dev/null
+++ b/science/dtiquery/distinfo
@@ -0,0 +1,3 @@
+MD5 (dtiquery-1.1.tar.gz) = 4104aece50029d9b3183a244c2bb36fe
+SHA256 (dtiquery-1.1.tar.gz) = c59f5911e633f1f364cfd03ed18c296f99963184e2c2ddea937109f45f4b456e
+SIZE (dtiquery-1.1.tar.gz) = 285780
diff --git a/science/dtiquery/files/dtiquery.1 b/science/dtiquery/files/dtiquery.1
new file mode 100644
index 000000000000..46b0516f3f0c
--- /dev/null
+++ b/science/dtiquery/files/dtiquery.1
@@ -0,0 +1,35 @@
+.TH DTIQUERY 1
+.SH NAME \" Section header
+.PP
+
+DTIQuery - DTI Visualization Software
+
+.SH SYNOPSIS
+.PP
+.nf
+.na
+dtiquery
+dtiprecompute_cmd [args]
+dtiprecompute_gui
+
+.ad
+.fi
+
+.SH "DESCRIPTION"
+
+DTIQuery is a software suite for analyzing DTI (Diffusion Tensor Imaging)
+data obtained via MRI (Magnetic Resonence Imaging). For full documentation,
+please visit
+
+http://graphics.stanford.edu/projects/dti/software/.
+
+.SH "SEE ALSO"
+
+afni(1), caret(1), freesurfer(1), fsl(1)
+
+.SH AUTHOR
+.nf
+.na
+David Akers
+Stanford University
+
diff --git a/science/dtiquery/files/patch-DTIQuery-Makefile b/science/dtiquery/files/patch-DTIQuery-Makefile
new file mode 100644
index 000000000000..c7f205c84822
--- /dev/null
+++ b/science/dtiquery/files/patch-DTIQuery-Makefile
@@ -0,0 +1,13 @@
+--- DTIQuery/Makefile.orig Thu Dec 6 13:48:54 2007
++++ DTIQuery/Makefile Thu Dec 6 13:49:24 2007
+@@ -12,8 +12,8 @@
+
+ VTK_LIBS = -lvtkIO \
+ -lvtkRendering -lvtkGraphics -lvtkImaging \
+- -lvtkFiltering -lvtkCommon -lvtkHybrid -lvtkpng -lvtkzlib \
+- -lvtkftgl -lvtkfreetype -lvtkjpeg -lvtkDICOMParser \
++ -lvtkFiltering -lvtkCommon -lvtkHybrid -lpng -lz \
++ -lvtkftgl -lvtkfreetype -ljpeg -lvtkDICOMParser \
+
+ # for FreeBSD, need -lpng -ljpeg -lz instead of -lvtkpng -lvtkzlib -lvtkjpeg
+
diff --git a/science/dtiquery/files/patch-Makefile.definitions b/science/dtiquery/files/patch-Makefile.definitions
new file mode 100644
index 000000000000..593cefc32b3f
--- /dev/null
+++ b/science/dtiquery/files/patch-Makefile.definitions
@@ -0,0 +1,34 @@
+--- Makefile.definitions.orig Wed Dec 19 10:50:50 2007
++++ Makefile.definitions Wed Dec 19 10:51:13 2007
+@@ -1,6 +1,6 @@
+-CYGWIN = 1
++# CYGWIN = 1
+ # mac = 1
+-# FreeBSD = 1
++FreeBSD = 1
+ # linux = 1
+
+ # Uncomment the line above corresponding to your system. Then find the
+@@ -46,18 +46,19 @@
+
+ ifdef FreeBSD
+
+-WX_CONFIG_BIN ?= /usr/X11R6/bin/wxgtk2-2.8-config
++WX_CONFIG_BIN ?= ${X11BASE}/bin/wxgtk2-2.8-config
+ VTK_INCLUDE_PATHS ?= -I/usr/local/include/vtk-5.0/
+ VTK_LIB_PATHS ?= -L/usr/local/lib/vtk-5.0/
+ WX_INCLUDE_PATHS ?= `$(WX_CONFIG_BIN) --cxxflags`
+ WX_LIB_PATHS ?= `$(WX_CONFIG_BIN) --libs` `$(WX_CONFIG_BIN) \
+ --gl-libs`
+-RAPID_INCLUDE_PATH ?= -I/usr/local/include
++RAPID_INCLUDE_PATH ?= -I/usr/local/include/RAPID
+ RAPID_LIB_PATH ?= -L/usr/local/lib
+ TNT_INCLUDE_PATH ?= -I/usr/local/include/tnt/
+ JAMA_INCLUDE_PATH ?= -I/usr/local/include/
+ ZLIB_INCLUDE_PATH ?= -I/usr/include
+-SYS_INCLUDE_PATHS ?= -I/usr/include -I/usr/X11R6/include -I/usr/local/include/gtk-2.0 -I/usr/X11R6/include/gtk-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/include/cairo -I/usr/local/include/pango-1.0 -I/usr/X11R6/include/pango-1.0 -I/usr/local/include/atk-1.0
++SYS_INCLUDE_PATHS ?= -I/usr/include -I${X11BASE}/include -I/usr/local/include/gtk-2.0 -I${X11BASE}/include/gtk-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/include/cairo -I/usr/local/include/pango-1.0 -I${X11BASE}/include/pango-1.0 -I/usr/local/include/atk-1.0
++SYS_CXXFLAGS ?= -g
+ SYS_LIBS ?= -L/usr/local/lib -lXt -lGL -lpng
+
+ else
diff --git a/science/dtiquery/files/patch-precompute-Makefile b/science/dtiquery/files/patch-precompute-Makefile
new file mode 100644
index 000000000000..c6ce2354c1ac
--- /dev/null
+++ b/science/dtiquery/files/patch-precompute-Makefile
@@ -0,0 +1,13 @@
+--- precompute/Makefile.orig Thu Dec 6 13:51:44 2007
++++ precompute/Makefile Thu Dec 6 13:52:16 2007
+@@ -21,8 +21,8 @@
+
+ VTK_LIBS = -lvtkIO \
+ -lvtkRendering -lvtkGraphics -lvtkImaging \
+- -lvtkFiltering -lvtkCommon -lvtkHybrid -lvtkpng -lvtkzlib \
+- -lvtkftgl -lvtkfreetype -lvtkjpeg -lvtkDICOMParser \
++ -lvtkFiltering -lvtkCommon -lvtkHybrid -lpng -lz \
++ -lvtkftgl -lvtkfreetype -ljpeg -lvtkDICOMParser \
+
+ # for FreeBSD, need -lpng -ljpeg -lz instead of -lvtkpng -lvtkzlib -lvtkjpeg
+
diff --git a/science/dtiquery/files/pkg-message.in b/science/dtiquery/files/pkg-message.in
new file mode 100644
index 000000000000..eb6f29e44f07
--- /dev/null
+++ b/science/dtiquery/files/pkg-message.in
@@ -0,0 +1,10 @@
+=============================================================================
+DTI Query users will need %%PREFIX%%/bin in their PATH.
+
+For questions or comments regarding this port, please contact the
+port maintainer.
+
+For dtiquery usage, please visit the WEB site at
+
+http://graphics.stanford.edu/projects/dti/
+=============================================================================
diff --git a/science/dtiquery/pkg-descr b/science/dtiquery/pkg-descr
new file mode 100644
index 000000000000..0791de735e9c
--- /dev/null
+++ b/science/dtiquery/pkg-descr
@@ -0,0 +1,3 @@
+DTI visualization software from Stanford.
+
+WWW: http://graphics.stanford.edu/projects/dti/